]> git.pld-linux.org Git - packages/gd.git/commitdiff
- added upstream patch (taken from Fedora): fixes tiff_invalid_read test failure auto/th/gd-2.2.4-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 23 Apr 2017 06:21:49 +0000 (08:21 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 23 Apr 2017 06:21:49 +0000 (08:21 +0200)
- release 2

gd-upstream.patch [new file with mode: 0644]
gd.spec

diff --git a/gd-upstream.patch b/gd-upstream.patch
new file mode 100644 (file)
index 0000000..8aee1a0
--- /dev/null
@@ -0,0 +1,50 @@
+From c9b601a658a79e6ea2aad29fbf60ca6e24ccef1e Mon Sep 17 00:00:00 2001
+From: "Christoph M. Becker" <cmbecker69@gmx.de>
+Date: Wed, 18 Jan 2017 13:59:02 +0100
+Subject: [PATCH] Fix build issue regarding INT_MAX
+
+For portability gd_gd2.c needs to include <limits.h>.
+---
+ src/gd_gd2.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gd_gd2.c b/src/gd_gd2.c
+index c2904ca..049c4c5 100644
+--- a/src/gd_gd2.c
++++ b/src/gd_gd2.c
+@@ -74,6 +74,7 @@
+ /* 2.0.29: no more errno.h, makes windows happy */
+ #include <math.h>
++#include <limits.h>
+ #include <string.h>
+ #include "gd.h"
+ #include "gd_errors.h"
+
+
+From 55ac28a293eaa8c531870c8bb8ecc04b333975f4 Mon Sep 17 00:00:00 2001
+From: "Christoph M. Becker" <cmbecker69@gmx.de>
+Date: Thu, 19 Jan 2017 01:02:58 +0100
+Subject: [PATCH] Fix #357: 2.2.4: Segfault in test suite.
+
+We make sure to never pass a negative `int` as argument to a `size_t`
+parameter.
+---
+ src/gd_io_dp.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/gd_io_dp.c b/src/gd_io_dp.c
+index eda2eeb..cb38794 100644
+--- a/src/gd_io_dp.c
++++ b/src/gd_io_dp.c
+@@ -292,6 +292,10 @@ static int dynamicGetbuf(gdIOCtxPtr ctx, void *buf, int len)
+               rlen = dp->realSize - dp->pos;
+       }
++      if (rlen < 0) {
++              return 0;
++      }
++
+       memcpy(buf, (void *) ((char *)dp->data + dp->pos), rlen);
+       dp->pos += rlen;
diff --git a/gd.spec b/gd.spec
index 8722d73d74667d809863b9288e169b792aa6624c..c160cd6132926271df777a8cecdf886eec36a9f3 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -15,7 +15,7 @@ Summary(pl.UTF-8):    Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Summary(pt_BR.UTF-8):  Biblioteca para manipulação de imagens
 Name:          gd
 Version:       2.2.4
-Release:       1
+Release:       2
 License:       BSD-like
 Group:         Libraries
 #Source0Download: https://github.com/libgd/libgd/releases
@@ -25,6 +25,7 @@ Patch0:               %{name}-fontpath.patch
 Patch1:                %{name}-2.0.33-BoxBound.patch
 Patch2:                %{name}-loop.patch
 Patch3:                %{name}-liq.patch
+Patch4:                %{name}-upstream.patch
 URL:           https://libgd.github.io/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake
@@ -164,6 +165,7 @@ para uso pelos programas que usam a libgd.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 # hack to avoid inclusion of -s in --ldflags
 %{__sed} -i -e 's,@LDFLAGS@,,g' config/gdlib-config.in
This page took 0.033962 seconds and 4 git commands to generate.