]> git.pld-linux.org Git - packages/gd.git/commitdiff
- fix building with libvpx 1.4 (libvpx.so.2)
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 23 May 2015 19:31:50 +0000 (21:31 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 23 May 2015 19:31:50 +0000 (21:31 +0200)
gd.spec
libvpx2.patch [new file with mode: 0644]

diff --git a/gd.spec b/gd.spec
index 0c6ae0c22e6d502e0bf76195266ef38cec71792d..7a538c933d7feb71f670010ffc004be867ce4cdf 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -18,6 +18,7 @@ Source0:      https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
 Patch0:                %{name}-fontpath.patch
 Patch1:                %{name}-2.0.33-BoxBound.patch
 Patch2:                %{name}-loop.patch
+Patch3:                libvpx2.patch
 URL:           http://www.libgd.org/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake
@@ -154,6 +155,7 @@ para uso pelos programas que usam a libgd.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # hack to avoid inclusion of -s in --ldflags
 %{__sed} -i -e 's,@LDFLAGS@,,g' config/gdlib-config.in
diff --git a/libvpx2.patch b/libvpx2.patch
new file mode 100644 (file)
index 0000000..50e1afd
--- /dev/null
@@ -0,0 +1,24 @@
+--- libgd-2.1.1/src/webpimg.c.orig     2015-05-23 21:28:59.036681960 +0200
++++ libgd-2.1.1/src/webpimg.c  2015-05-23 21:29:28.300382040 +0200
+@@ -711,14 +711,14 @@
+     codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
+     codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
+-    vpx_img_wrap(&img, IMG_FMT_I420,
++    vpx_img_wrap(&img, VPX_IMG_FMT_I420,
+                  y_width, y_height, 16, (uint8*)(Y));
+-    img.planes[PLANE_Y] = (uint8*)(Y);
+-    img.planes[PLANE_U] = (uint8*)(U);
+-    img.planes[PLANE_V] = (uint8*)(V);
+-    img.stride[PLANE_Y] = y_stride;
+-    img.stride[PLANE_U] = uv_stride;
+-    img.stride[PLANE_V] = uv_stride;
++    img.planes[VPX_PLANE_Y] = (uint8*)(Y);
++    img.planes[VPX_PLANE_U] = (uint8*)(U);
++    img.planes[VPX_PLANE_V] = (uint8*)(V);
++    img.stride[VPX_PLANE_Y] = y_stride;
++    img.stride[VPX_PLANE_U] = uv_stride;
++    img.stride[VPX_PLANE_V] = uv_stride;
+     res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
This page took 0.186244 seconds and 4 git commands to generate.