]> git.pld-linux.org Git - packages/gd.git/commitdiff
- fix format string warnings auto/th/gd-2.0.35-11 auto/ti/gd-2.0.35-11
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Dec 2012 12:18:12 +0000 (13:18 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Dec 2012 12:18:12 +0000 (13:18 +0100)
- rel 11

format-security.patch [new file with mode: 0644]
gd.spec

diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..64e358f
--- /dev/null
@@ -0,0 +1,36 @@
+--- gd-2.0.35/gdtestft.c.orig  2012-12-12 13:17:03.460823690 +0100
++++ gd-2.0.35/gdtestft.c       2012-12-12 13:17:31.160822713 +0100
+@@ -74,7 +74,7 @@
+     gdImageStringFT ((gdImagePtr) NULL, &brect[0], 0, f, sz, angle, 0, 0, s);
+   if (err)
+     {
+-      fprintf (stderr, err);
++      fprintf (stderr, "%s", err);
+       return 1;
+     }
+@@ -146,21 +146,21 @@
+   err = gdImageStringFT (im, NULL, blue, f, sz, angle, x, y, s);
+   if (err)
+     {
+-      fprintf (stderr, err);
++      fprintf (stderr, "%s", err);
+       return 1;
+     }
+   /* Without antialiasing (negative color value) */
+   err = gdImageStringFT (im, NULL, -blue, f, sz, angle, sx + x, y, s);
+   if (err)
+     {
+-      fprintf (stderr, err);
++      fprintf (stderr, "%s", err);
+       return 1;
+     }
+   /* With antialiasing, and 50% alpha blending (truecolor only) */
+   err = gdImageStringFT (im, NULL, blueAlpha, f, sz, angle, sx * 2 + x, y, s);
+   if (err)
+     {
+-      fprintf (stderr, err);
++      fprintf (stderr, "%s", err);
+       return 1;
+     }
+   /* TBB: Write img to test/fttest.jpg or test/fttest.png */
diff --git a/gd.spec b/gd.spec
index 987507545cfda4f4353e579ae91cba33a57eeef3..7cdb8d4f5c8f44990e1cf55ad7298d66fd5a1377 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -9,7 +9,7 @@ Summary(pl.UTF-8):      Biblioteka do tworzenia grafiki w formacie PNG, JPEG
 Summary(pt_BR.UTF-8):  Biblioteca para manipulação de imagens
 Name:          gd
 Version:       2.0.35
-Release:       10
+Release:       11
 License:       BSD-like
 Group:         Libraries
 Source0:       http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
@@ -21,6 +21,7 @@ Patch3:               %{name}-2.0.35-AALineThick.patch
 Patch4:                %{name}-2.0.35-overflow.patch
 Patch5:                %{name}-2.0.35-security3.patch
 Patch6:                %{name}-loop.patch
+Patch7:                format-security.patch
 URL:           http://www.libgd.org/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake
@@ -153,6 +154,7 @@ para uso pelos programas que usam a libgd.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 # hack to avoid inclusion of -s in --ldflags
 %{__perl} -pi -e 's,\@LDFLAGS\@,,g' config/gdlib-config.in
This page took 0.157871 seconds and 4 git commands to generate.