]> git.pld-linux.org Git - packages/gd.git/blobdiff - gd.spec
- release 6 (libavif 0.11.x)
[packages/gd.git] / gd.spec
diff --git a/gd.spec b/gd.spec
index 5100d6ca8adee61fe644a6921ba303855de1d439..194982c1e842f7798527c29f0fe101a545b49add 100644 (file)
--- a/gd.spec
+++ b/gd.spec
@@ -1,36 +1,56 @@
 #
 # Conditional build:
-%bcond_without fontconfig      # without fontconfig support
-%bcond_without xpm             # without XPM support (requires X11 libs)
+%bcond_without avif            # AVIF support via libavif
+%bcond_without fontconfig      # fontconfig support
+%bcond_without heif            # HEIF support via libheif
+%bcond_with    libimagequant   # LIQ quantization method support (breaks transparency in TrueColor->palette conversion)
+%bcond_without raqm            # RAQM complex text layout support
+%bcond_with    sse             # SSE math on ix86
+%bcond_without xpm             # XPM support (requires X11 libs)
+%bcond_without tests           # "make check"
 #
+%ifarch pentium3 pentium4
+%define        with_sse        1
+%endif
 Summary:       Library for PNG, JPEG creation
-Summary(es.UTF-8):   Biblioteca para manipulación de imágenes
-Summary(pl.UTF-8):   Biblioteka do tworzenia grafiki w formacie PNG, JPEG
-Summary(pt_BR.UTF-8):   Biblioteca para manipulação de imagens
+Summary(es.UTF-8):     Biblioteca para manipulación de imágenes
+Summary(pl.UTF-8):     Biblioteka do tworzenia grafiki w formacie PNG, JPEG
+Summary(pt_BR.UTF-8):  Biblioteca para manipulação de imagens
 Name:          gd
-Version:       2.0.33
-Release:       10
+Version:       2.3.3
+Release:       6
 License:       BSD-like
 Group:         Libraries
-Source0:       http://www.boutell.com/gd/http/%{name}-%{version}.tar.gz
-# Source0-md5: be0a6d326cd8567e736fbc75df0a5c45
+#Source0Download: https://github.com/libgd/libgd/releases
+Source0:       https://github.com/libgd/libgd/releases/download/%{name}-%{version}/lib%{name}-%{version}.tar.xz
+# Source0-md5: 7a58b54d375eda236414201252a0ee3c
 Patch0:                %{name}-fontpath.patch
-Patch1:                %{name}-SetAAPixel.patch
-Patch2:                %{name}-graphviz.patch
-Patch3:                %{name}-security.patch
-Patch4:                %{name}-rotate_from_php.patch
-URL:           http://www.boutell.com/gd/
+Patch1:                %{name}-loop.patch
+Patch2:                api-breakage.patch
+URL:           https://libgd.github.io/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake
 %{?with_fontconfig:BuildRequires:      fontconfig-devel}
-BuildRequires: freetype-devel >= 2.0
-BuildRequires: gettext-devel
-BuildRequires: libpng-devel
+BuildRequires: freetype-devel >= 1:2.1.10
+BuildRequires: gettext-tools
+%{?with_avif:BuildRequires:    libavif-devel >= 0.8.2}
+%{?with_heif:BuildRequires:    libheif-devel >= 1.7.0}
+%{?with_libimagequant:BuildRequires:   libimagequant-devel}
 BuildRequires: libjpeg-devel
-BuildRequires: libtiff-devel
-BuildRequires: libtool >= 1:1.4.3
-%{?with_xpm:BuildRequires:     xorg-lib-libXpm}
+BuildRequires: libpng-devel >= 2:1.4.0
+%{?with_raqm:BuildRequires:    libraqm-devel}
+BuildRequires: libtiff-devel >= 4
+BuildRequires: libtool >= 2:2
+BuildRequires: libwebp-devel >= 0.2.0
+BuildRequires: pkgconfig
+BuildRequires: sed >= 4
+BuildRequires: tar >= 1:1.22
+%{?with_xpm:BuildRequires:     xorg-lib-libXpm-devel}
+BuildRequires: xz
 BuildRequires: zlib-devel
+Requires:      freetype >= 1:2.1.10
+%{?with_avif:Requires: libavif >= 0.8.2}
+%{?with_heif:Requires: libheif >= 1.7.0}
 Provides:      gd(gif) = %{version}-%{release}
 # versioned by php version rotate_from_php code comes from
 Provides:      gd(imagerotate) = 5.2.0
@@ -71,16 +91,22 @@ programa de desenho; é uma biblioteca.
 
 %package devel
 Summary:       Development part of the GD library
-Summary(es.UTF-8):   Archivos de inclusión y bibliotecas para desarrollar programas usando gd
-Summary(pl.UTF-8):   Część biblioteki GD przeznaczona dla developerów
-Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para desenvolver programas usando gd
+Summary(es.UTF-8):     Archivos de inclusión y bibliotecas para desarrollar programas usando gd
+Summary(pl.UTF-8):     Część biblioteki GD przeznaczona dla developerów
+Summary(pt_BR.UTF-8):  Arquivos de inclusão e bibliotecas para desenvolver programas usando gd
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 2.0
+Requires:      freetype-devel >= 1:2.1.10
+%{?with_avif:Requires: libavif-devel >= 0.8.2}
+%{?with_heif:Requires: libheif-devel >= 1.7.0}
+%{?with_libimagequant:Requires:        libimagequant-devel}
 Requires:      libjpeg-devel
 Requires:      libpng-devel
-%{?with_xpm:Requires:  xorg-lib-libXpm}
+%{?with_raqm:Requires: libraqm-devel}
+Requires:      libtiff-devel >= 4
+Requires:      libwebp-devel >= 0.2.0
+%{?with_xpm:Requires:  xorg-lib-libXpm-devel}
 Requires:      zlib-devel
 Provides:      gd-devel(gif) = %{version}-%{release}
 Provides:      gd-devel(imagerotate) = 5.2.0
@@ -103,8 +129,8 @@ necessárias para desenvolver programas usando gd.
 
 %package static
 Summary:       Static GD library
-Summary(pl.UTF-8):   Statyczna biblioteka GD
-Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com libgd
+Summary(pl.UTF-8):     Statyczna biblioteka GD
+Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com libgd
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Provides:      gd-static(gif) = %{version}-%{release}
@@ -122,9 +148,9 @@ libgd.
 
 %package progs
 Summary:       Utility programs that use libgd
-Summary(es.UTF-8):   Programas utilitarios libgd
-Summary(pl.UTF-8):   Narzędzia używające libgd
-Summary(pt_BR.UTF-8):   Programas utilitários libgd
+Summary(es.UTF-8):     Programas utilitarios libgd
+Summary(pl.UTF-8):     Narzędzia używające libgd
+Summary(pt_BR.UTF-8):  Programas utilitários libgd
 Group:         Applications/Graphics
 Requires:      %{name} = %{version}-%{release}
 
@@ -143,33 +169,58 @@ Este pacote inclui vários utilitários para manipulação de arquivos gd
 para uso pelos programas que usam a libgd.
 
 %prep
-%setup -q
+%setup -q -n libgd-%{version}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
-
-# hack to avoid inclusion of -s in --ldflags
-%{__perl} -pi -e 's,\@LDFLAGS\@,,g' config/gdlib-config.in
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__automake}
 %{__autoheader}
 %{__autoconf}
+%ifarch %{ix86}
+%if %{with sse}
+CFLAGS="%{rpmcflags} -msse -mfpmath=sse"
+%endif
+%endif
 %configure \
+       --enable-gd-formats \
+       %{!?with_avif:--without-avif} \
        %{!?with_fontconfig:--without-fontconfig} \
+       %{!?with_heif:--without-heif} \
+       %{!?with_libimagequant:--without-liq} \
+       %{!?with_raqm:--without-raqm} \
        %{!?with_xpm:--without-xpm}
 %{__make}
 
+%if %{with tests}
+%ifarch %{ix86}
+# https://github.com/libgd/libgd/issues/359
+XFAIL_TESTS="$XFAIL_TESTS gdimagegrayscale/basic"
+%if %{without sse}
+# 387 arithmetic is inexact, https://github.com/libgd/libgd/issues/242
+XFAIL_TESTS="$XFAIL_TESTS gdimagecopyresampled/bug00201"
+%endif
+%endif
+%if %{with raqm}
+# https://github.com/libgd/libgd/issues/613
+XFAIL_TESTS="$XFAIL_TESTS gdimagestringft/gdimagestringft_bbox"
+%endif
+export XFAIL_TESTS
+%{__make} check
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgd.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -178,15 +229,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING index.html
+%doc CONTRIBUTORS COPYING README.md
 %attr(755,root,root) %{_libdir}/libgd.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgd.so.3
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/gdlib-config
 %attr(755,root,root) %{_libdir}/libgd.so
-%{_libdir}/libgd.la
-%{_includedir}/*.h
+%{_includedir}/gd*.h
+%{_pkgconfigdir}/gdlib.pc
 
 %files static
 %defattr(644,root,root,755)
@@ -194,5 +245,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files progs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%exclude %{_bindir}/gdlib-config
+%attr(755,root,root) %{_bindir}/annotate
+%attr(755,root,root) %{_bindir}/bdftogd
+%attr(755,root,root) %{_bindir}/gd2copypal
+%attr(755,root,root) %{_bindir}/gd2togif
+%attr(755,root,root) %{_bindir}/gd2topng
+%attr(755,root,root) %{_bindir}/gdcmpgif
+%attr(755,root,root) %{_bindir}/gdparttopng
+%attr(755,root,root) %{_bindir}/gdtopng
+%attr(755,root,root) %{_bindir}/giftogd2
+%attr(755,root,root) %{_bindir}/pngtogd
+%attr(755,root,root) %{_bindir}/pngtogd2
+%attr(755,root,root) %{_bindir}/webpng
This page took 0.190302 seconds and 4 git commands to generate.