]> git.pld-linux.org Git - packages/gcstar.git/blame - gcstar.spec
rm BOM from perl files (perl.prov doesn't like BOM's)
[packages/gcstar.git] / gcstar.spec
CommitLineData
8eff6485 1# NOTES:- warnings like this: /usr/lib/rpm/perl.prov: weird, cannot determine the package name for
2# `/mnt/hda5/tmp/gcstar-0.5.0-root-inter/usr/lib/gcstar/GCLang/BG/GCstar.pm'
5f263671 3# - mark with lang() _datadir/lib/GCLang/*
8eff6485 4#
2bcc22c6
ZU
5# /usr/lib/rpm/perl.prov: weird, cannot determine the package name for `/root/tmp/gcstar-1.4.2-root-root/usr/share/gcstar/lib/GCLang/SV/GCstar.pm'
6# and similar
7# TODO: - fix this message, IMHO the first byte of utf8 is the source of error - see with 'less' (uzsolt)
8# - after the done of the first todo, clear the 'Provides' fields
4a7c6738 9# - maybe create subpackage
ec5ebfe7
SS
10# - fix permssions of /usr/share/gcstar/helpers/xdg-open (or use system xdg-open)
11#
2d948bf5 12%include /usr/lib/rpm/macros.perl
c448fb71 13Summary: GCstar: collection manager
d58332be 14Summary(hu.UTF-8): GCstar: gyűjtemény kezelő
4e3f85ee 15Summary(pl.UTF-8): GCstar: zarządca kolekcji
00b89f0a 16Name: gcstar
e59c7e14
SS
17Version: 1.7.0
18Release: 0.1
00b89f0a 19License: GPL
4a7c6738 20Group: X11/Applications
00b89f0a 21Source0: http://download.gna.org/gcstar/%{name}-%{version}.tar.gz
e59c7e14 22# Source0-md5: 94d0c4d6acc912b4b4d3a72d934cc16d
00b89f0a 23Patch0: %{name}-mandir.patch
24Patch1: %{name}-desktop.patch
290001d9 25# copy gcstar perl-libs to /usr/share instead of /usr/lib
5f263671 26Patch2: %{name}-perlmoddir.patch
a399d7d3 27URL: http://www.gcstar.org/
8eff6485 28BuildRequires: perl-Archive-Zip
c448fb71 29BuildRequires: perl-Gtk2
83b45a9f 30BuildRequires: perl-HTML-Parser
0705dc9b 31BuildRequires: perl-Sort-Naturally
2d948bf5 32BuildRequires: perl-XML-LibXML
aca574c6 33BuildRequires: perl-XML-Simple
64f1bcda 34BuildRequires: perl-libwww
2d948bf5 35BuildRequires: rpm-perlprov
64f1bcda 36Requires(post,postun): desktop-file-utils
5f263671 37BuildArch: noarch
00b89f0a 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
74573e9b 40# parts of Gtk2.pm package
41%define gtk2_subpkgs Dialog\\\\|MenuBar\\\\|MessageDialog\\\\|ScrolledWindow\\\\|Toolbar\\\\|TreeView\\\\|VBox\\\\|Window
42
43# don't require/provide itself, it isn't in standard search path
44%define _noautoprov ^perl(GC.*)$
45%define _noautoreq ^perl(GC.*)$ ^perl(Gtk2::\\\\(%{gtk2_subpkgs}\\\\))$
46
00b89f0a 47%description
9901e863 48GCstar is an application to manage different kind of collections. It
49is designed to be able to support as many type of collections as
50needed. For the moment it supports these ones:
51 - Movies
52 - Video games
53 - Books
54 - User defined collections
55
d58332be
ZU
56%description -l hu.UTF-8
57GCstar egy alkalmazás, amellyel gyűjtemények különféle fajtáit
58tarthatjuk nyilván. Annyi típusú gyűjteményt tud kezelni, amennyire
59csak szükségünk lehet. Jelenleg a következőket:
60 - filmek
61 - videójátékok
62 - könyvek
63 - felhasználó által definiált gyűjtemények
64
d8f50ea5
JR
65%description -l pl.UTF-8
66GCstar jest aplikacją do zarządzania różnymi rodzajami kolekcji. Jest
67zaprojektowana by móc wspierać wszystkie potrzebne typy kolekcji.
149bd910 68Aktualnie wspiera kolekcje:
d8f50ea5 69 - filmów
9901e863 70 - gier wideo
d8f50ea5
JR
71 - książek
72 - kolekcje zdefiniowane przez użytkownika
00b89f0a 73
74%prep
75%setup -q -n %{name}
76%patch0 -p1
77%patch1 -p1
290001d9 78%patch2 -p1
00b89f0a 79
15cac200
SS
80#rm BOM from files - it can confuse perl.prov
81find -type f -name '*.pm' | xargs sed -i 's/^\xef\xbb\xbf//'
82
00b89f0a 83%install
84rm -rf $RPM_BUILD_ROOT
85
c448fb71 86./install --text \
87 --prefix=$RPM_BUILD_ROOT%{_prefix}
00b89f0a 88
89install -d $RPM_BUILD_ROOT%{_desktopdir}
90install -d $RPM_BUILD_ROOT%{_pixmapsdir}
91install share/applications/gcstar.desktop $RPM_BUILD_ROOT%{_desktopdir}
92install share/gcstar/icons/gcstar_64x64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post
98%update_desktop_database_post
99
100%postun
101%update_desktop_database_postun
102
103%files
104%defattr(644,root,root,755)
105%doc README
106%attr(755,root,root) %{_bindir}/*
74573e9b 107%{_datadir}/%{name}
00b89f0a 108%{_mandir}/man1/*
109%{_desktopdir}/*.desktop
110%{_pixmapsdir}/*.png
This page took 0.090821 seconds and 4 git commands to generate.