]> git.pld-linux.org Git - packages/gcl.git/commitdiff
- Updated to 2.6.7, removed obsolete patch. This version builds.
authorqrczak <qrczak@pld-linux.org>
Sun, 2 Oct 2005 16:11:33 +0000 (16:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcl-gcc4.patch -> 1.2
    gcl.spec -> 1.48

gcl-gcc4.patch [deleted file]
gcl.spec

diff --git a/gcl-gcc4.patch b/gcl-gcc4.patch
deleted file mode 100644 (file)
index 1b3c179..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
---- gcl-2.6.6/o/num_sfun.c.orig        2003-11-06 17:16:52.000000000 +0100
-+++ gcl-2.6.6/o/num_sfun.c     2005-09-30 12:31:51.000000000 +0200
-@@ -43,6 +43,8 @@
-       return(z);
- }
-+static object number_sin(object x), number_cos(object x);
-+
- static object
- number_exp(object x)
- {
-@@ -64,7 +66,6 @@
-       case t_complex:
-       {
-               object y, y1;
--              static object number_sin(object x), number_cos(object x);
-               vs_mark;
-       
-               y = x->cmp.cmp_imag;
-@@ -88,12 +89,13 @@
-       }
- }
-+static object number_nlog(object x);
-+
- object
- number_expt(object x, object y)
- {
-       enum type tx, ty;
-       object z;
--      static object number_nlog(object x);
-       vs_mark;
-       tx = type_of(x);
-@@ -172,12 +174,13 @@
-       return(z);
- }
-+static object number_sqrt(object x), number_atan2(object y, object x);
-+
- static object
- number_nlog(object x)
- {
-       double log(double);
-       object r=Cnil, i=Cnil, a, p;
--      static object number_sqrt(object x), number_atan2(object y, object x);
-       vs_mark;
-       if (type_of(x) == t_complex) {
---- gcl-2.6.6/o/format.c.orig  2003-11-06 17:16:50.000000000 +0100
-+++ gcl-2.6.6/o/format.c       2005-09-30 12:38:58.000000000 +0200
-@@ -1794,13 +1794,15 @@
-       x = x->sm.sm_object0;
-       if (!colon && !atsign)
-               for (i = 0;  i < x->st.st_fillp;  i++) {
--                      if (isUpper(j = x->st.st_self[i]))
-+                      j = x->st.st_self[i];
-+                      if (isUpper(j))
-                               j += 'a' - 'A';
-                       writec_stream(j, fmt_stream);
-               }
-       else if (colon && !atsign)
-               for (b = TRUE, i = 0;  i < x->st.st_fillp;  i++) {
--                      if (isLower(j = x->st.st_self[i])) {
-+                      j = x->st.st_self[i];
-+                      if (isLower(j)) {
-                               if (b)
-                                       j -= 'a' - 'A';
-                               b = FALSE;
-@@ -1814,7 +1816,8 @@
-               }
-       else if (!colon && atsign)
-               for (b = TRUE, i = 0;  i < x->st.st_fillp;  i++) {
--                      if (isLower(j = x->st.st_self[i])) {
-+                      j = x->st.st_self[i];
-+                      if (isLower(j)) {
-                               if (b)
-                                       j -= 'a' - 'A';
-                               b = FALSE;
-@@ -1827,7 +1830,8 @@
-               }
-       else
-               for (i = 0;  i < x->st.st_fillp;  i++) {
--                      if (isLower(j = x->st.st_self[i]))
-+                      j = x->st.st_self[i];
-+                      if (isLower(j))
-                               j -= 'a' - 'A';
-                       writec_stream(j, fmt_stream);
-               }
---- gcl-2.6.6/o/unixfsys.c.orig        2005-01-15 17:44:37.000000000 +0100
-+++ gcl-2.6.6/o/unixfsys.c     2005-09-30 12:42:39.000000000 +0200
-@@ -266,7 +266,6 @@
-       char truefilename[MAXPATHLEN];
-       char current_directory[MAXPATHLEN];
-       char directory[MAXPATHLEN];
--      static char *getwd(char *buffer);
- #ifdef __MINGW32__ 
-         DWORD current_directory_length =
-             GetCurrentDirectory ( MAXPATHLEN, current_directory ); 
index a1761b352cc1b4ddadbb6071b39307d785849661..d77d897650c05ad058c7d1096c7a921bd79b27e5 100644 (file)
--- a/gcl.spec
+++ b/gcl.spec
@@ -6,18 +6,17 @@
 Summary:       GNU Common Lisp system
 Summary(pl):   System GNU Common Lisp
 Name:          gcl
-Version:       2.6.6
-Release:       3
+Version:       2.6.7
+Release:       1
 License:       LGPL v2
 Group:         Development/Languages
 Source0:       ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
-# Source0-md5: 45d67331b29cafc3e9b1eacb488044ec
+# Source0-md5: c0f42e1f391162e5ac90912a70e8ecc3
 Patch0:                %{name}-make.patch
 Patch1:                %{name}-info.patch
 # It seems this patch doesn't fix what it should: still doesn't build with
 # newer binutils
 #Patch2:               %{name}-binutils.patch
-Patch3:                %{name}-gcc4.patch
 URL:           http://www.gnu.org/software/gcl/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -52,7 +51,6 @@ Interfejs Tcl/Tk dla GNU Common Lisp.
 %patch0 -p1
 %patch1 -p1
 #%%patch2 -p1
-%patch3 -p1
 
 %build
 %{__aclocal}
This page took 0.073898 seconds and 4 git commands to generate.