]> git.pld-linux.org Git - packages/gcl.git/commitdiff
- added info patch (added texinfof to BuildRequires), gcl-2_4_0-1
authorkloczek <kloczek@pld-linux.org>
Thu, 6 Dec 2001 04:48:32 +0000 (04:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed doc-html subpackage (we have one copy doc in info format),
- added gcl man page to main package,
- use xemacs for building elc files (instead emacs-leim).
TODO: add patches for using system installed gmp and mpi libraries.

Changed files:
    gcl.spec -> 1.3

gcl.spec

index 8c7ecf85fdb2f23ed37532293c7decd55f658004..aed8ea39736303f67fd64d95be7f39305fd00ac2 100644 (file)
--- a/gcl.spec
+++ b/gcl.spec
@@ -10,9 +10,10 @@ Group(pl):   Programowanie/J
 Source0:       ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
 Patch0:                %{name}-make.patch
 Patch1:                %{name}-OPT.patch
+Patch2:                %{name}-info.patch
 URL:           http://www.gnu.org/projects/gcl
 BuildRequires: tk-devel
-BuildRequires: emacs-leim
+BuildRequires: xemacs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,44 +31,39 @@ Group(pl):  Programowanie/J
 Requires:      %{name} = %{version}
 
 %description tk
-Tcl/tk bindings for GNU Common Lisp
+Tcl/tk bindings for GNU Common Lisp.
 
 %description tk -l pl
-Intefejs Tcl/tk dla GNU Common Lisp
-
-%package doc-html
-Summary:       HTML documntation for GNU Common Lisp
-Summary(pl):   Dokumentacja dla GNU Common Lisp w formacie HTML
-Group:         Development/Languages
-Group(de):     Entwicklung/Sprachen
-Group(pl):     Programowanie/Jêzyki
-Requires:      %{name} = %{version}
-
-%description doc-html
-HTML documntation for GNU Common Lisp.
-
-%description doc-html -l pl
-Dokumentacja dla GNU Common Lisp w formacie HTML.
+Intefejs Tcl/tk dla GNU Common Lisp.
 
 %prep
 %setup  -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 GCC="%{__cc}"; export GCC
 %configure2_13 \
        --enable-notify=no
-%{__make} OPTFLAGS="%{rpmcflags}"
+
+%{__make} OPTFLAGS="%{rpmcflags}" \
+       EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
+       $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
+       $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
+
+(cd info
+rm -f *info*
+makeinfo gcl-si.texi gcl-tk.texi
+install gcl*info* $RPM_BUILD_ROOT%{_infodir})
+install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
-install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk}
-install -d $RPM_BUILD_ROOT{%{_infodir},%{_bindir}}
-install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
-install info/*info*.gz $RPM_BUILD_ROOT%{_infodir}
+install info/*info* $RPM_BUILD_ROOT%{_infodir}
 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
@@ -78,20 +74,20 @@ ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
 #!/bin/sh
 exec %{_libdir}/gcl/unixport/saved_gcl \
-   -dir {_libdir}/gcl/unixport/ \
-   -libdir %{_libdir}/gcl/ \
-   -eval '(setq si::*allow-gzipped-file* t)' \
-     "$@"
+       -dir {_libdir}/gcl/unixport/ \
+       -libdir %{_libdir}/gcl/ \
+       -eval '(setq si::*allow-gzipped-file* t)' \
+       "$@"
 EOF
 
 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
 #!/bin/sh
 exec %{_libdir}/gcl/unixport/saved_gcl \
-   -dir {_libdir}/gcl/unixport/ \
-   -libdir %{_libdir}/gcl/ \
-   -eval '(setq si::*allow-gzipped-file* t)' \
-   -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
-     "$@"
+       -dir {_libdir}/gcl/unixport/ \
+       -libdir %{_libdir}/gcl/ \
+       -eval '(setq si::*allow-gzipped-file* t)' \
+       -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
+       "$@"
 EOF
 
 gzip -9nf readme faq ChangeLog
@@ -119,11 +115,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcl/cmpnew
 %{_libdir}/gcl/lsp
 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
-%{_infodir}/gcl-si.info*.gz
-
-%files doc-html
-%defattr(644,root,root,755)
-%doc info/*.html
+%{_infodir}/gcl-si.info*
+%{_mandir}/man1/*
 
 %files tk
 %defattr(644,root,root,755)
This page took 0.04503 seconds and 4 git commands to generate.