]> git.pld-linux.org Git - packages/gcl.git/commitdiff
- updated to 2.6.10 master
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 17 Nov 2013 19:39:08 +0000 (20:39 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 17 Nov 2013 19:39:08 +0000 (20:39 +0100)
- updated make,info patches
- added format patch (fix error in sprintf usage found by -Werror=format-security)
- added xemacs bcond

gcl-format.patch [new file with mode: 0644]
gcl-info.patch
gcl-make.patch
gcl.spec

diff --git a/gcl-format.patch b/gcl-format.patch
new file mode 100644 (file)
index 0000000..654d186
--- /dev/null
@@ -0,0 +1,11 @@
+--- gcl/gcl-tk/tkMain.c.orig   2013-11-11 15:55:48.000000000 +0100
++++ gcl/gcl-tk/tkMain.c        2013-11-17 17:37:21.967828865 +0100
+@@ -121,7 +121,7 @@
+ TCL_signal_error(x)
+      char *x;
+ {char buf[300] ;
+- sprintf("error %s",x);
++ sprintf(buf, "error %s",x);
+  Tcl_Eval(interp,buf);
+  dfprintf(stderr,x);
+ }
index c1177bf2f3884a8a067a20bba43ee2f77bbf61ae..6556e71ef1b3f850257b8188d8423168c78f6c31 100644 (file)
@@ -1,34 +1,28 @@
---- gcl-2.6.2/info/gcl-si.texi.orig    2002-02-19 20:21:19.000000000 +0100
-+++ gcl-2.6.2/info/gcl-si.texi 2004-07-15 21:12:02.600648356 +0200
-@@ -24,10 +24,10 @@
- Copyright 1994 William F. Schelter
+--- gcl/info/gcl-si.texi.orig  2013-11-17 16:07:03.788056245 +0100
++++ gcl/info/gcl-si.texi       2013-11-17 16:08:48.101385200 +0100
+@@ -18,9 +18,9 @@
  
- @format
--INFO-DIR-SECTION GNU Common Lisp
--START-INFO-DIR-ENTRY
--* gcl-si: (gcl-si.info). GNU Common Lisp System Internals
--END-INFO-DIR-ENTRY
+ @setchapternewpage odd
+-@dircategory GNU Common Lisp
 +@dircategory Programming Languages:
-+@direntry
+ @direntry 
+-* gcl-si: (gcl-si.info). GNU Common Lisp System Internals
 +* gcl-si: (gcl-si).                   GNU Common Lisp System Internals
-+@end direntry
- @end format
- @end ifinfo
+ @end direntry
+ @ifinfo
+--- gcl/info/gcl-tk.texi.orig  2013-11-17 16:07:03.988056236 +0100
++++ gcl/info/gcl-tk.texi       2013-11-17 16:09:21.064717150 +0100
+@@ -18,9 +18,9 @@
  
---- gcl-2.6.2/info/gcl-tk.texi.orig    2004-07-15 21:12:39.619802947 +0200
-+++ gcl-2.6.2/info/gcl-tk.texi 2004-07-15 21:13:16.702941603 +0200
-@@ -14,10 +14,10 @@
- Copyright 1994 William F. Schelter
  
- @format
--INFO-DIR-SECTION GNU Common Lisp
--START-INFO-DIR-ENTRY
--* gcl-tk: (gcl-tk.info). GNU Common Lisp Tk Manual
--END-INFO-DIR-ENTRY
+ @setchapternewpage odd
+-@dircategory GNU Common Lisp
 +@dircategory Programming Languages:
-+@direntry
-+* gcl-tk: (gcl-tk).                   GNU Common Lisp Tk Manual
-+@end direntry
- @end format
- @end ifinfo
+ @direntry 
+-* gcl-tk: (gcl-tk.info). GNU TK Manual
++* gcl-tk: (gcl-tk).                   GNU TK Manual
+ @end direntry
  
+ @ifinfo
index 6f055191ec6c6540170cdd852cf12955daa2184e..091f2db36315a31507ee3629b7fc9ea14f66e86e 100644 (file)
@@ -1,7 +1,7 @@
---- gcl-2.6.2/makefile.orig    2004-05-26 04:22:25.000000000 +0200
-+++ gcl-2.6.2/makefile 2004-07-15 19:44:19.787820607 +0200
-@@ -51,26 +51,30 @@
      cp $(<D)/../include/$(@F) $@
+--- gcl/makefile.orig  2013-11-11 15:55:48.000000000 +0100
++++ gcl/makefile       2013-11-17 16:06:26.011391163 +0100
+@@ -64,27 +64,27 @@
#     cp $(<D)/../include/$(@F) $@
  
  $(PORTDIR)/saved_pre_gcl: $(HDIR)cmpinclude.h
 -      (cd $(BINDIR); $(MAKE) all)
 +      $(MAKE) -C $(ODIR) all
        cd $(@D) && $(MAKE) $(@F)
  
- $(PORTDIR)/saved_gcl: $(HDIR)cmpinclude.h $(PORTDIR)/saved_pre_gcl
+ $(PORTDIR)/saved_gcl: $(PORTDIR)/saved_pre_gcl $(HDIR)cmpinclude.h 
 -      (cd $(LSPDIR); touch *.lsp ; $(MAKE) all)
 -      (cd $(CMPDIR); touch *.lsp ; $(MAKE) all)
-+      (cd $(LSPDIR); touch *.lsp)
-+      $(MAKE) -C $(LSPDIR) all
-+      (cd $(CMPDIR); touch *.lsp)
-+      $(MAKE) -C $(CMPDIR) all
+-      [ -z "$(X_LIBS)" ] || (cd xgcl-2 && $(MAKE) LISP=../$<)
++      (cd $(LSPDIR); touch *.lsp) ; $(MAKE) -C $(LSPDIR) all
++      (cd $(CMPDIR); touch *.lsp) ; $(MAKE) -C $(CMPDIR) all
++      [ -z "$(X_LIBS)" ] || $(MAKE) -C xgcl-2 LISP=../$<
        cd $(@D) && $(MAKE) $(@F)
  
  $(PORTDIR)/saved_pcl_gcl: $(PORTDIR)/saved_gcl
 -      (cd $(PCLDIR); rm -f *.c; $(MAKE) all)
-+      (cd $(PCLDIR); rm -f *.c)
-+      $(MAKE) -C $(PCLDIR) all
++      (cd $(PCLDIR); rm -f *.c) ; $(MAKE) -C $(PCLDIR) all
        cd $(@D) && $(MAKE) $(@F)
  
  $(PORTDIR)/saved_ansi_gcl: $(PORTDIR)/saved_pcl_gcl
 -      (cd $(CLCSDIR); rm -f *.c; $(MAKE) all)
-+      (cd $(CLCSDIR); rm -f *.c)
-+      $(MAKE) -C $(CLCSDIR) all
++      (cd $(CLCSDIR); rm -f *.c) ; $(MAKE) -C $(CLCSDIR) all
        cd $(@D) && $(MAKE) $(@F)
  
  ansi-tests/test_results: $(PORTDIR)/saved_ansi_gcl
-@@ -102,7 +106,7 @@
+@@ -116,7 +116,7 @@
  mpfiles: $(MPFILES)
  
  $(MPDIR)/libmport.a:
@@ -47,7 +45,7 @@
  
  $(GMPDIR)/libgmp.a: $(GMPDIR)/Makefile
        cd $(GMPDIR) && $(MAKE) && rm -f libgmp.a &&  ar qc libgmp.a *.o */*.o
-@@ -234,7 +238,7 @@
+@@ -253,7 +253,7 @@
  OTHERS=$(HDIR)notcomp.h $(HDIR)rgbc.h $(HDIR)stacks.h 
  
  $(HDIR)new_decl.h:
@@ -55,8 +53,8 @@
 +      $(MAKE) -C o ../$@
  
  $(HDIR)cmpinclude.h: $(CMPINCLUDE_FILES) $(HDIR)config.h
-       cat $(HDIR)config.h | sed -e "1,/Begin for cmpincl/d" \
-@@ -258,7 +262,7 @@
+       cat $(HDIR)config.h | sed -e "1,/Begin for cmpincl/d" -e "/End for cmpinclude/,50000d" > $(@F)
+@@ -278,7 +278,7 @@
        chmod a+rx configure
  
  kcp:
@@ -65,6 +63,4 @@
 +      $(MAKE) -C go "CFLAGS = -I../h -pg  -c -g "
 +      $(MAKE) -C unixport gcp
  
--#.INTERMEDIATE: unixport/saved_pcl_gcl
-\ No newline at end of file
-+#.INTERMEDIATE: unixport/saved_pcl_gcl
+ #.INTERMEDIATE: unixport/saved_pcl_gcl
index c0db4ff2d58f3d4b0e6f0a3c7c56aece49a19d02..1e81c1dbdaa6aa41788fbd0e638faf97a0736bc6 100644 (file)
--- a/gcl.spec
+++ b/gcl.spec
@@ -1,31 +1,31 @@
+# TODO:
+# - package tk-demos?
+# - package emacs-lisp files (if building with xemacs)
 #
 # Conditional build:
-%bcond_without builtin_bfd     # use built in bfd instead of system one
-#              (currently does not build with system one from new binutils)
+%bcond_without xemacs  # don't build/package emacs-lisp parts
 #
+%define        tk_ver  8.5
 Summary:       GNU Common Lisp system
 Summary(pl.UTF-8):     System GNU Common Lisp
 Name:          gcl
-Version:       2.6.7
+Version:       2.6.10
 Release:       1
 License:       LGPL v2
 Group:         Development/Languages
 Source0:       http://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
-# Source0-md5: c0f42e1f391162e5ac90912a70e8ecc3
+# Source0-md5: 7cb9c388e9e77696f4e27e7a1d118524
 Patch0:                %{name}-make.patch
 Patch1:                %{name}-info.patch
-# It seems this patch doesn't fix what it should: still doesn't build with
-# newer binutils
-#Patch2:               %{name}-binutils.patch
+Patch2:                %{name}-format.patch
 URL:           http://www.gnu.org/software/gcl/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 BuildRequires: gmp-devel >= 4.0
 BuildRequires: readline-devel
 BuildRequires: texinfo
-%define        _tkline 8.4
-BuildRequires: tk-devel >= %{_tkline}
-BuildRequires: xemacs
+BuildRequires: tk-devel >= %{tk_ver}
+%{?with_xemacs:BuildRequires:  xemacs}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -47,32 +47,22 @@ Tcl/Tk bindings for GNU Common Lisp.
 Interfejs Tcl/Tk dla GNU Common Lisp.
 
 %prep
-%setup -q
+%setup -q -n %{name}
 %patch0 -p1
 %patch1 -p1
-#%%patch2 -p1
+%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 cp -f /usr/share/automake/config.* .
 GCC="%{__cc}"; export GCC
-# note: full path to xemacs must be passed
-EMACS=/usr/bin/xemacs; export EMACS
 %configure \
-       --disable-statsysbfd \
-%ifnarch alpha hppa ia64 mips
-%if %{with builtin_bfd}
-       --enable-locbfd \
-%else
-       --enable-dynsysbfd \
-%endif
-%endif
+       %{?with_xemacs:EMACS=/usr/bin/xemacs} \
        --enable-dynsysgmp \
        --enable-notify=no
 
-%{__make} \
-       EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -92,7 +82,7 @@ ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
 #!/bin/sh
 exec %{_libdir}/gcl/unixport/saved_gcl \
-       -dir {_libdir}/gcl/unixport/ \
+       -dir %{_libdir}/gcl/unixport/ \
        -libdir %{_libdir}/gcl/ \
        -eval '(setq si::*allow-gzipped-file* t)' \
        "$@"
@@ -101,26 +91,28 @@ EOF
 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
 #!/bin/sh
 exec %{_libdir}/gcl/unixport/saved_gcl \
-       -dir {_libdir}/gcl/unixport/ \
+       -dir %{_libdir}/gcl/unixport/ \
        -libdir %{_libdir}/gcl/ \
        -eval '(setq si::*allow-gzipped-file* t)' \
-       -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
+       -eval '(setq si::*tk-library* "/usr/lib/tk%{tk_ver}")' \
        "$@"
 EOF
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{dwdoc*,gcl-si*,gcl-tk*}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p      /sbin/postshell
+%post  -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun        -p      /sbin/postshell
+%postun        -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post tk       -p      /sbin/postshell
+%post  tk -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun tk     -p      /sbin/postshell
+%postun        tk -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
@@ -134,20 +126,24 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcl/h
 %{_libdir}/gcl/lsp
 %{_libdir}/gcl/pcl
+%{_libdir}/gcl/xgcl-2
 %dir %{_libdir}/gcl/unixport
 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
 %{_libdir}/gcl/unixport/*.lsp
+%{_libdir}/gcl/unixport/gcl.script
 # to -devel?
-#%{_libdir}/gcl/unixport/*.a
+%{_libdir}/gcl/unixport/libgcl.a
+%{_libdir}/gcl/unixport/libgclp.a
 %{_infodir}/gcl-si.info*
-%{_mandir}/man1/*
+%{_mandir}/man1/gcl.1*
 
 %files tk
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gcl-tk
 %dir %{_libdir}/gcl/gcl-tk
-%attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
-%attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
+%attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
+%attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
 %{_libdir}/gcl/gcl-tk/*.o
 %{_libdir}/gcl/gcl-tk/*.tcl
+%{_libdir}/gcl/gcl-tk/tk-package.lsp
 %{_infodir}/gcl-tk.info*
This page took 0.072157 seconds and 4 git commands to generate.