]> git.pld-linux.org Git - packages/gcl.git/blobdiff - gcl.spec
- typos / formatting / etc.
[packages/gcl.git] / gcl.spec
index 7f5daafca8ce9cf558ed957f0f2c02e11db98e0d..741917e317a70e246475deed91dc3b0179576917 100644 (file)
--- a/gcl.spec
+++ b/gcl.spec
@@ -1,26 +1,23 @@
-
-Summary:       GNU Common Lisp
-Summary(pl):   GNU Common Lisp
+Summary:       GNU Common Lisp system
+Summary(pl):   System GNU Common Lisp
 Name:          gcl
-Version:       2.4.3
+Version:       2.6.5
 Release:       2
 License:       LGPL v2
 Group:         Development/Languages
-Source0:       ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
-# Source0-md5: 5ad1a3e004b84363496f3f1e7eb81012
+Source0:       ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
+# Source0-md5: e0852318b81c93b76bc7e012f036ec6c
 Patch0:                %{name}-make.patch
-Patch1:                %{name}-OPT.patch
-Patch2:                %{name}-info.patch
-Patch3:                %{name}-libgmp.patch
-Patch4:                %{name}-bdf.patch
-URL:           http://www.ma.utexas.edu/users/wfs/gcl.html
+Patch1:                %{name}-info.patch
+URL:           http://www.gnu.org/software/gcl/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: gmp-devel
-BuildRequires: tk-devel
+BuildRequires: gmp-devel >= 4.0
+BuildRequires: readline-devel
+%define        _tkline 8.4
+BuildRequires: tk-devel >= %{_tkline}
 BuildRequires: xemacs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-ExclusiveArch: %{ix86} sparc
 
 %description
 The GNU Common Lisp system, based on KCL.
@@ -29,27 +26,23 @@ The GNU Common Lisp system, based on KCL.
 System GNU Common Lisp, bazuj±cy na KCL.
 
 %package tk
-Summary:       Tcl/tk bindings for GNU Common Lisp
-Summary(pl):   Interfejs Tcl/tk do GNU Common Lisp
+Summary:       Tcl/Tk bindings for GNU Common Lisp
+Summary(pl):   Interfejs Tcl/Tk do GNU Common Lisp
 Group:         Development/Languages
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description tk
-Tcl/tk bindings for GNU Common Lisp.
+Tcl/Tk bindings for GNU Common Lisp.
 
 %description tk -l pl
-Intefejs Tcl/tk dla GNU Common Lisp.
+Interfejs Tcl/Tk dla GNU Common Lisp.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-rm -f missing
 %{__aclocal}
 %{__autoconf}
 cp -f /usr/share/automake/config.* .
@@ -57,29 +50,28 @@ GCC="%{__cc}"; export GCC
 # note: full path to xemacs must be passed
 EMACS=/usr/bin/xemacs; export EMACS
 %configure \
+       --disable-statsysbfd \
+%ifnarch alpha hppa ia64 mips
+       --enable-dynsysbfd \
+%endif
+       --enable-dynsysgmp \
        --enable-notify=no
 
-%{__make} OPTFLAGS="%{rpmcflags}" \
+%{__make} \
        EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
-       $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
-       $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
-
-(cd info
-rm -f *info*
-makeinfo gcl-si.texi gcl-tk.texi
-install gcl*info* $RPM_BUILD_ROOT%{_infodir})
-install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
+
+%{__make} install1 \
+       DESTDIR=$RPM_BUILD_ROOT \
+       INSTALL_LIB_DIR=%{_libdir}/gcl
 
-install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
-install info/*info* $RPM_BUILD_ROOT%{_infodir}
-install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
-install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
-install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
-       $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
+mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
+rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
+
+install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
 
@@ -98,7 +90,7 @@ exec %{_libdir}/gcl/unixport/saved_gcl \
        -dir {_libdir}/gcl/unixport/ \
        -libdir %{_libdir}/gcl/ \
        -eval '(setq si::*allow-gzipped-file* t)' \
-       -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
+       -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
        "$@"
 EOF
 
@@ -122,9 +114,17 @@ rm -rf $RPM_BUILD_ROOT
 %doc readme faq ChangeLog
 %attr(755,root,root) %{_bindir}/gcl
 %attr(755,root,root) %{_bindir}/gcl.exe
+%dir %{_libdir}/gcl
+%{_libdir}/gcl/clcs
 %{_libdir}/gcl/cmpnew
+%{_libdir}/gcl/h
 %{_libdir}/gcl/lsp
+%{_libdir}/gcl/pcl
+%dir %{_libdir}/gcl/unixport
 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
+%{_libdir}/gcl/unixport/*.lsp
+# to -devel?
+#%{_libdir}/gcl/unixport/*.a
 %{_infodir}/gcl-si.info*
 %{_mandir}/man1/*
 
This page took 0.088359 seconds and 4 git commands to generate.