]> git.pld-linux.org Git - packages/gcl.git/blame - gcl.spec
- updated to 2.6.10
[packages/gcl.git] / gcl.spec
CommitLineData
1cc927bc
JB
1# TODO:
2# - package tk-demos?
3# - package emacs-lisp files (if building with xemacs)
53838840 4#
5# Conditional build:
1cc927bc 6%bcond_without xemacs # don't build/package emacs-lisp parts
53838840 7#
1cc927bc 8%define tk_ver 8.5
444a6bb2 9Summary: GNU Common Lisp system
68a7060f 10Summary(pl.UTF-8): System GNU Common Lisp
f7b10388 11Name: gcl
1cc927bc 12Version: 2.6.10
ec457178 13Release: 1
511dae64 14License: LGPL v2
f7b10388 15Group: Development/Languages
062318ce 16Source0: http://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
1cc927bc 17# Source0-md5: 7cb9c388e9e77696f4e27e7a1d118524
f7b10388 18Patch0: %{name}-make.patch
cff490b4 19Patch1: %{name}-info.patch
1cc927bc 20Patch2: %{name}-format.patch
4c1392ac 21URL: http://www.gnu.org/software/gcl/
1cc927bc 22BuildRequires: autoconf >= 2.61
16004e02 23BuildRequires: automake
cff490b4
JB
24BuildRequires: gmp-devel >= 4.0
25BuildRequires: readline-devel
2e08fe4e 26BuildRequires: texinfo
1cc927bc
JB
27BuildRequires: tk-devel >= %{tk_ver}
28%{?with_xemacs:BuildRequires: xemacs}
f7b10388 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32The GNU Common Lisp system, based on KCL.
33
12ccc44d
JR
34%description -l pl.UTF-8
35System GNU Common Lisp, bazujący na KCL.
f7b10388 36
37%package tk
b893fe57 38Summary: Tcl/Tk bindings for GNU Common Lisp
68a7060f 39Summary(pl.UTF-8): Interfejs Tcl/Tk do GNU Common Lisp
f7b10388 40Group: Development/Languages
cff490b4 41Requires: %{name} = %{version}-%{release}
f7b10388 42
43%description tk
b893fe57 44Tcl/Tk bindings for GNU Common Lisp.
f7b10388 45
12ccc44d 46%description tk -l pl.UTF-8
a400aa1f 47Interfejs Tcl/Tk dla GNU Common Lisp.
f7b10388 48
49%prep
1cc927bc 50%setup -q -n %{name}
f7b10388 51%patch0 -p1
52%patch1 -p1
1cc927bc 53%patch2 -p1
f7b10388 54
55%build
f7463ca7 56%{__aclocal}
7ccfaa0b 57%{__autoconf}
92ced808 58cp -f /usr/share/automake/config.* .
37557a1a 59GCC="%{__cc}"; export GCC
511dae64 60%configure \
1cc927bc 61 %{?with_xemacs:EMACS=/usr/bin/xemacs} \
cff490b4 62 --enable-dynsysgmp \
f7b10388 63 --enable-notify=no
1acb6ac9 64
1cc927bc 65%{__make}
f7b10388 66
67%install
68rm -rf $RPM_BUILD_ROOT
cff490b4 69install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
1acb6ac9 70
cff490b4
JB
71%{__make} install1 \
72 DESTDIR=$RPM_BUILD_ROOT \
73 INSTALL_LIB_DIR=%{_libdir}/gcl
3be8d08d 74
cff490b4
JB
75mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
76rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
f7b10388 77
cff490b4 78install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
f7b10388 79
80ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
81
82cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
83#!/bin/sh
84exec %{_libdir}/gcl/unixport/saved_gcl \
1cc927bc 85 -dir %{_libdir}/gcl/unixport/ \
1acb6ac9 86 -libdir %{_libdir}/gcl/ \
87 -eval '(setq si::*allow-gzipped-file* t)' \
88 "$@"
f7b10388 89EOF
90
91cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
92#!/bin/sh
93exec %{_libdir}/gcl/unixport/saved_gcl \
1cc927bc 94 -dir %{_libdir}/gcl/unixport/ \
1acb6ac9 95 -libdir %{_libdir}/gcl/ \
96 -eval '(setq si::*allow-gzipped-file* t)' \
1cc927bc 97 -eval '(setq si::*tk-library* "/usr/lib/tk%{tk_ver}")' \
1acb6ac9 98 "$@"
f7b10388 99EOF
100
1cc927bc
JB
101%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{dwdoc*,gcl-si*,gcl-tk*}
102
3c5d3ae9
JB
103%clean
104rm -rf $RPM_BUILD_ROOT
105
1cc927bc 106%post -p /sbin/postshell
0b8192e9 107-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 108
1cc927bc 109%postun -p /sbin/postshell
0b8192e9 110-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 111
1cc927bc 112%post tk -p /sbin/postshell
999262ac 113-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 114
1cc927bc 115%postun tk -p /sbin/postshell
999262ac 116-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 117
f7b10388 118%files
119%defattr(644,root,root,755)
a2a46def 120%doc readme faq ChangeLog
f7b10388 121%attr(755,root,root) %{_bindir}/gcl
122%attr(755,root,root) %{_bindir}/gcl.exe
444a6bb2 123%dir %{_libdir}/gcl
cff490b4 124%{_libdir}/gcl/clcs
f7b10388 125%{_libdir}/gcl/cmpnew
cff490b4 126%{_libdir}/gcl/h
f7b10388 127%{_libdir}/gcl/lsp
cff490b4 128%{_libdir}/gcl/pcl
1cc927bc 129%{_libdir}/gcl/xgcl-2
444a6bb2 130%dir %{_libdir}/gcl/unixport
f7b10388 131%attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
cff490b4 132%{_libdir}/gcl/unixport/*.lsp
1cc927bc 133%{_libdir}/gcl/unixport/gcl.script
cff490b4 134# to -devel?
1cc927bc
JB
135%{_libdir}/gcl/unixport/libgcl.a
136%{_libdir}/gcl/unixport/libgclp.a
1acb6ac9 137%{_infodir}/gcl-si.info*
1cc927bc 138%{_mandir}/man1/gcl.1*
f7b10388 139
140%files tk
3c5d3ae9 141%defattr(644,root,root,755)
f7b10388 142%attr(755,root,root) %{_bindir}/gcl-tk
90da9ded 143%dir %{_libdir}/gcl/gcl-tk
1cc927bc
JB
144%attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
145%attr(755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
f1883a5f 146%{_libdir}/gcl/gcl-tk/*.o
147%{_libdir}/gcl/gcl-tk/*.tcl
1cc927bc 148%{_libdir}/gcl/gcl-tk/tk-package.lsp
37557a1a 149%{_infodir}/gcl-tk.info*
This page took 0.098271 seconds and 4 git commands to generate.