]> git.pld-linux.org Git - packages/gccxml.git/commitdiff
- initial; unfortunately the last release doesn't work properly with gcc 4.9+
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 15:52:26 +0000 (17:52 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 15:52:26 +0000 (17:52 +0200)
gccxml-includes.patch [new file with mode: 0644]
gccxml.spec [new file with mode: 0644]

diff --git a/gccxml-includes.patch b/gccxml-includes.patch
new file mode 100644 (file)
index 0000000..cf03e9f
--- /dev/null
@@ -0,0 +1,21 @@
+--- gccxml-0.6.0/GCC_XML/KWSys/SystemTools.cxx.orig    2004-02-04 23:50:19.000000000 +0100
++++ gccxml-0.6.0/GCC_XML/KWSys/SystemTools.cxx 2015-10-06 22:07:00.491875951 +0200
+@@ -26,6 +26,7 @@
+ #include <sys/stat.h>
+ #include <ctype.h>
+ #include <errno.h>
++#include <string.h>
+ #include <time.h>
+ // support for realpath call
+--- gccxml-0.6.0/GCC_XML/GXFront/gxConfiguration.cxx.orig      2004-02-04 23:50:19.000000000 +0100
++++ gccxml-0.6.0/GCC_XML/GXFront/gxConfiguration.cxx   2015-10-06 22:12:09.615196312 +0200
+@@ -16,6 +16,8 @@
+ =========================================================================*/
+ #include "gxConfiguration.h"
++#include <string.h>
++
+ //----------------------------------------------------------------------------
+ const char* gxConfigurationVc6Registry =
+ "HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\"
diff --git a/gccxml.spec b/gccxml.spec
new file mode 100644 (file)
index 0000000..8c1e635
--- /dev/null
@@ -0,0 +1,67 @@
+Summary:       GCC-XML - dump XML description of C++ source code
+Summary(pl.UTF-8):     GCC-XML - zrzut opisu XML kodu źródłowego w C++
+Name:          gccxml
+Version:       0.6.0
+Release:       1
+License:       GPL v2+ (GCC code), BSD-like (GCC-XML)
+Group:         Development/Tools
+Source0:       https://github.com/gccxml/gccxml/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 0458765b917dc385d91e0f14156572a8
+Patch0:                %{name}-includes.patch
+URL:           http://gccxml.github.io/HTML/Index.html
+BuildRequires: cmake
+BuildRequires: libstdc++-devel
+BuildRequires: rpmbuild(macros) >= 1.605
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+GCC-XML program dumps an XML description of C++ source code using an
+extension on the GCC C++ compiler.
+
+%description -l pl.UTF-8
+GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
+użyciu rozszerzenia kompulatora C++ GCC.
+
+%prep
+%setup -q
+%patch0 -p1
+
+# replace with new version
+cp -f /usr/include/obstack.h GCC/include/obstack.h
+
+%build
+install -d build
+cd build
+%cmake ..
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# packaged as %doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.6
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README GCC_XML/Copyright.txt build/bin/doc/gccxml.html
+%attr(755,root,root) %{_bindir}/gccxml
+%attr(755,root,root) %{_bindir}/gccxml_cc1plus
+%dir %{_datadir}/gccxml-0.6
+%{_datadir}/gccxml-0.6/gccxml_config
+%attr(755,root,root) %{_datadir}/gccxml-0.6/gccxml_find_flags
+%dir %{_datadir}/gccxml-0.6/GCC
+%{_datadir}/gccxml-0.6/GCC/2.95
+%{_datadir}/gccxml-0.6/GCC/3.3
+%attr(755,root,root) %{_datadir}/gccxml-0.6/GCC/find_flags
+%dir %{_datadir}/gccxml-0.6/Intel
+%attr(755,root,root) %{_datadir}/gccxml-0.6/Intel/find_flags
+%dir %{_datadir}/gccxml-0.6/MIPSpro
+%{_datadir}/gccxml-0.6/MIPSpro/7.3
+%attr(755,root,root) %{_datadir}/gccxml-0.6/MIPSpro/find_flags
+%{_mandir}/man1/gccxml.1*
This page took 0.065913 seconds and 4 git commands to generate.