]> git.pld-linux.org Git - packages/gccxml.git/blobdiff - gccxml.spec
- added naive gcc 5.1/5.2 support (treat as 4.9); release .3
[packages/gccxml.git] / gccxml.spec
index 8c1e63578fa0be6e87ae1b5aa25cb6fcc16db3dd..82da8f1cafda4125a88f816d75b4b94c118cb932 100644 (file)
@@ -1,13 +1,16 @@
 Summary:       GCC-XML - dump XML description of C++ source code
 Summary(pl.UTF-8):     GCC-XML - zrzut opisu XML kodu źródłowego w C++
 Name:          gccxml
-Version:       0.6.0
-Release:       1
+Version:       0.9.0
+%define        gitref  3afa8ba5be6866e603dcabe80aff79856b558e24
+%define        snap    20150424
+%define        rel     3
+Release:       0.%{snap}.%{rel}
 License:       GPL v2+ (GCC code), BSD-like (GCC-XML)
 Group:         Development/Tools
-Source0:       https://github.com/gccxml/gccxml/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 0458765b917dc385d91e0f14156572a8
-Patch0:                %{name}-includes.patch
+Source0:       https://github.com/gccxml/gccxml/archive/%{gitref}/%{name}-%{snap}.tar.gz
+# Source0-md5: 70e4b145feb2a7036c835cf214cae26a
+Patch0:                %{name}-gcc.patch
 URL:           http://gccxml.github.io/HTML/Index.html
 BuildRequires: cmake
 BuildRequires: libstdc++-devel
@@ -23,12 +26,9 @@ GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
 użyciu rozszerzenia kompulatora C++ GCC.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{gitref}
 %patch0 -p1
 
-# replace with new version
-cp -f /usr/include/obstack.h GCC/include/obstack.h
-
 %build
 install -d build
 cd build
@@ -42,26 +42,56 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # packaged as %doc
-%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.6
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.9
+
+for ver in 5.1 5.2 ; do
+       ln -sf 4.9 $RPM_BUILD_ROOT%{_datadir}/gccxml-0.9/GCC/$ver
+done
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README GCC_XML/Copyright.txt build/bin/doc/gccxml.html
+%doc LICENSE.rst README.rst GCC_XML/Copyright.txt build/GCC_XML/doc/gccxml.html
 %attr(755,root,root) %{_bindir}/gccxml
 %attr(755,root,root) %{_bindir}/gccxml_cc1plus
-%dir %{_datadir}/gccxml-0.6
-%{_datadir}/gccxml-0.6/gccxml_config
-%attr(755,root,root) %{_datadir}/gccxml-0.6/gccxml_find_flags
-%dir %{_datadir}/gccxml-0.6/GCC
-%{_datadir}/gccxml-0.6/GCC/2.95
-%{_datadir}/gccxml-0.6/GCC/3.3
-%attr(755,root,root) %{_datadir}/gccxml-0.6/GCC/find_flags
-%dir %{_datadir}/gccxml-0.6/Intel
-%attr(755,root,root) %{_datadir}/gccxml-0.6/Intel/find_flags
-%dir %{_datadir}/gccxml-0.6/MIPSpro
-%{_datadir}/gccxml-0.6/MIPSpro/7.3
-%attr(755,root,root) %{_datadir}/gccxml-0.6/MIPSpro/find_flags
+%dir %{_datadir}/gccxml-0.9
+%{_datadir}/gccxml-0.9/gccxml_config
+%{_datadir}/gccxml-0.9/gccxml_identify_compiler.cc
+%dir %{_datadir}/gccxml-0.9/GCC
+%{_datadir}/gccxml-0.9/GCC/2.95
+%{_datadir}/gccxml-0.9/GCC/2.96
+%{_datadir}/gccxml-0.9/GCC/3.0
+%{_datadir}/gccxml-0.9/GCC/3.1
+%{_datadir}/gccxml-0.9/GCC/3.2
+%{_datadir}/gccxml-0.9/GCC/3.3
+%{_datadir}/gccxml-0.9/GCC/3.4
+%{_datadir}/gccxml-0.9/GCC/4.0
+%{_datadir}/gccxml-0.9/GCC/4.1
+%{_datadir}/gccxml-0.9/GCC/4.2
+%{_datadir}/gccxml-0.9/GCC/4.3
+%{_datadir}/gccxml-0.9/GCC/4.4
+%{_datadir}/gccxml-0.9/GCC/4.5
+%{_datadir}/gccxml-0.9/GCC/4.6
+%{_datadir}/gccxml-0.9/GCC/4.7
+%{_datadir}/gccxml-0.9/GCC/4.8
+%{_datadir}/gccxml-0.9/GCC/4.9
+%{_datadir}/gccxml-0.9/GCC/5.1
+%{_datadir}/gccxml-0.9/GCC/5.2
+%dir %{_datadir}/gccxml-0.9/IBM
+%{_datadir}/gccxml-0.9/IBM/8.0
+%attr(755,root,root) %{_datadir}/gccxml-0.9/IBM/find_flags
+%{_datadir}/gccxml-0.9/IBM/find_flags_common
+%dir %{_datadir}/gccxml-0.9/Intel
+%attr(755,root,root) %{_datadir}/gccxml-0.9/Intel/find_flags
+%{_datadir}/gccxml-0.9/Intel/pthread.h
+%dir %{_datadir}/gccxml-0.9/MIPSpro
+%{_datadir}/gccxml-0.9/MIPSpro/7.3
+%attr(755,root,root) %{_datadir}/gccxml-0.9/MIPSpro/find_flags
+%{_datadir}/gccxml-0.9/MIPSpro/mipspro_defs.cxx
+%dir %{_datadir}/gccxml-0.9/Sun
+%{_datadir}/gccxml-0.9/Sun/5.8
+%attr(755,root,root) %{_datadir}/gccxml-0.9/Sun/find_flags
+%{_datadir}/gccxml-0.9/Sun/find_flags_common
 %{_mandir}/man1/gccxml.1*
This page took 0.134464 seconds and 4 git commands to generate.