]> git.pld-linux.org Git - packages/gccxml.git/blob - gccxml.spec
- added gcc patch (fixes build with gcc 5)
[packages/gccxml.git] / gccxml.spec
1 Summary:        GCC-XML - dump XML description of C++ source code
2 Summary(pl.UTF-8):      GCC-XML - zrzut opisu XML kodu źródłowego w C++
3 Name:           gccxml
4 Version:        0.9.0
5 %define gitref  3afa8ba5be6866e603dcabe80aff79856b558e24
6 %define snap    20150424
7 %define rel     2
8 Release:        0.%{snap}.%{rel}
9 License:        GPL v2+ (GCC code), BSD-like (GCC-XML)
10 Group:          Development/Tools
11 Source0:        https://github.com/gccxml/gccxml/archive/%{gitref}/%{name}-%{snap}.tar.gz
12 # Source0-md5:  70e4b145feb2a7036c835cf214cae26a
13 Patch0:         %{name}-gcc.patch
14 URL:            http://gccxml.github.io/HTML/Index.html
15 BuildRequires:  cmake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 GCC-XML program dumps an XML description of C++ source code using an
22 extension on the GCC C++ compiler.
23
24 %description -l pl.UTF-8
25 GCC-XML to program zrzucający opis XML kodu źródłowego w C++ przy
26 użyciu rozszerzenia kompulatora C++ GCC.
27
28 %prep
29 %setup -q -n %{name}-%{gitref}
30 %patch0 -p1
31
32 %build
33 install -d build
34 cd build
35 %cmake ..
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C build install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 # packaged as %doc
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gccxml-0.9
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc LICENSE.rst README.rst GCC_XML/Copyright.txt build/GCC_XML/doc/gccxml.html
53 %attr(755,root,root) %{_bindir}/gccxml
54 %attr(755,root,root) %{_bindir}/gccxml_cc1plus
55 %dir %{_datadir}/gccxml-0.9
56 %{_datadir}/gccxml-0.9/gccxml_config
57 %{_datadir}/gccxml-0.9/gccxml_identify_compiler.cc
58 %dir %{_datadir}/gccxml-0.9/GCC
59 %{_datadir}/gccxml-0.9/GCC/2.95
60 %{_datadir}/gccxml-0.9/GCC/2.96
61 %{_datadir}/gccxml-0.9/GCC/3.0
62 %{_datadir}/gccxml-0.9/GCC/3.1
63 %{_datadir}/gccxml-0.9/GCC/3.2
64 %{_datadir}/gccxml-0.9/GCC/3.3
65 %{_datadir}/gccxml-0.9/GCC/3.4
66 %{_datadir}/gccxml-0.9/GCC/4.0
67 %{_datadir}/gccxml-0.9/GCC/4.1
68 %{_datadir}/gccxml-0.9/GCC/4.2
69 %{_datadir}/gccxml-0.9/GCC/4.3
70 %{_datadir}/gccxml-0.9/GCC/4.4
71 %{_datadir}/gccxml-0.9/GCC/4.5
72 %{_datadir}/gccxml-0.9/GCC/4.6
73 %{_datadir}/gccxml-0.9/GCC/4.7
74 %{_datadir}/gccxml-0.9/GCC/4.8
75 %{_datadir}/gccxml-0.9/GCC/4.9
76 %dir %{_datadir}/gccxml-0.9/IBM
77 %{_datadir}/gccxml-0.9/IBM/8.0
78 %attr(755,root,root) %{_datadir}/gccxml-0.9/IBM/find_flags
79 %{_datadir}/gccxml-0.9/IBM/find_flags_common
80 %dir %{_datadir}/gccxml-0.9/Intel
81 %attr(755,root,root) %{_datadir}/gccxml-0.9/Intel/find_flags
82 %{_datadir}/gccxml-0.9/Intel/pthread.h
83 %dir %{_datadir}/gccxml-0.9/MIPSpro
84 %{_datadir}/gccxml-0.9/MIPSpro/7.3
85 %attr(755,root,root) %{_datadir}/gccxml-0.9/MIPSpro/find_flags
86 %{_datadir}/gccxml-0.9/MIPSpro/mipspro_defs.cxx
87 %dir %{_datadir}/gccxml-0.9/Sun
88 %{_datadir}/gccxml-0.9/Sun/5.8
89 %attr(755,root,root) %{_datadir}/gccxml-0.9/Sun/find_flags
90 %{_datadir}/gccxml-0.9/Sun/find_flags_common
91 %{_mandir}/man1/gccxml.1*
This page took 0.075088 seconds and 3 git commands to generate.