]> git.pld-linux.org Git - packages/gcc4.git/blobdiff - gcc4.spec
- updated to 4.1.0-20051005T0949UTC.
[packages/gcc4.git] / gcc4.spec
index 0e5ab6706cecaac7806291dbf4fef6b2e7e1ddf9..9a453975b824ea7510f7e3b206ca28709a03c6a6 100644 (file)
--- a/gcc4.spec
+++ b/gcc4.spec
@@ -1,8 +1,4 @@
 #
-# TODO:
-#              - http://gcc.gnu.org/PR11203 (inline-asm)
-#              - http://gcc.gnu.org/PR20128 (ice with mudflap + profile generate)
-#
 # Conditional build:
 %bcond_without ada             # build without ADA support
 %bcond_without cxx             # build without C++ support
 %bcond_without objc            # build without Objective-C support
 %bcond_without objcxx          # build without Objective-C++ support
 %bcond_with    multilib        # build with multilib support (it needs glibc[32&64]-devel)
-%bcond_without profiling       # build without profiling
+%bcond_with    profiling       # build with profiling
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
 
-# debuginfo not needed for devel snaps.
-%define                _enable_debug_packages  0
-
 %if %{with multilib}
 # the latest chrpath(64) can't handle 32-bit binaries :/
 %define                _noautochrpath  .*/lib/.*\\.so.*
@@ -46,15 +39,15 @@ Summary(pl):        Kolekcja kompilator
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       4.1.0
-%define                _snap   20050724T0642UTC
-Release:       0.%{_snap}.0.1
+%define                _snap   20051005T0949UTC
+Release:       0.%{_snap}.1
 Epoch:         5
 License:       GPL v2+
 Group:         Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/snapshots/4.1-%{_snap}/gcc-4.1-%{_snap}.tar.bz2
 Source0:       gcc-4.1-%{_snap}.tar.bz2
-# Source0-md5: 3d9b5c5a60b7b6bb3f5f00ef7727b355
+# Source0-md5: 19b30d36af9aaa6216af104b77714cad
 Source1:       %{name}-optimize-la.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -66,11 +59,13 @@ Patch6:             %{name}-keep-volatile-sematics.patch
 # PRs
 Patch10:       %{name}-pr7776.patch
 Patch11:       %{name}-pr20297.patch
-Patch12:       %{name}-pr22484.patch
-Patch13:       %{name}-pr22493.patch
-Patch14:       %{name}-pr22037.patch
-Patch15:       %{name}-pr22533.patch
-#Patch16:      %{name}-mmx-x87-fpu-mode-switching-and-mmx-vectorizer.patch     NEEDS UPDATE
+
+Patch13:       %{name}-pr22533.patch
+Patch14:       %{name}-x87-mmx-switch.patch
+Patch15:       %{name}-x87-mmx-eh.patch
+Patch16:       %{name}-pr23948.patch
+Patch17:       %{name}-pr19505.patch
+Patch18:       %{name}-pr20606_pr24069.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
@@ -121,11 +116,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libdir32       /usr/lib
 %endif
 
-%ifarch i686
-# workaround PR wrong-code/22584
-%define                optflags        -march=i486 -O2
-%endif
-
 %description
 A compiler aimed at integrating all the optimizations and features
 necessary for a high-performance and stable development environment.
@@ -739,11 +729,13 @@ Statyczne biblioteki Obiektowego C.
 # PRs
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
+
 %patch13 -p1
-%patch14 -p1
-%patch15 -p1
-#patch16 -p1   NEEDS UPDATE
+#patch14 -p1   NEEDS UPDATE
+#patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -805,7 +797,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%{?with_tests:%{__make} -k -C obj-%{_target_platform} check}
+%{?with_tests:%{__make} -k -C obj-%{_target_platform} check 2>&1 ||:}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -889,20 +881,21 @@ done
 # by fixincludes, we don't want former
 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
 mkdir  $gccdir/tmp
+
 # we have to save these however
-%{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jni.h,jvmpi.h} $gccdir/tmp}
-%{?with_objc:mv -f $gccdir/include/objc        $gccdir/tmp}
-mv -f  $gccdir/include/syslimits.h $gccdir/tmp
-rm -rf $gccdir/include
-mv -f  $gccdir/tmp $gccdir/include
-cp -f  $gccdir/install-tools/include/*.h $gccdir/include
+%{?with_java:mv $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jni.h,jni_md.h,jvmpi.h} $gccdir/tmp}
+%{?with_objc:mv $gccdir/include/objc $gccdir/tmp}
+mv $gccdir/include/syslimits.h $gccdir/tmp
+rm -rf $gccdir/include
+mv $gccdir/tmp $gccdir/include
+cp $gccdir/install-tools/include/*.h $gccdir/include
 # but we don't want anything more from install-tools
-rm -rf $gccdir/install-tools
+rm -rf $gccdir/install-tools
 
 %if %{with multilib}
-ln -sf %{_slibdir32}/libgcc_s.so.1     $gccdir/32/libgcc_s.so
+ln -sf %{_slibdir32}/libgcc_s.so.1     $gccdir/32/libgcc_s.so
 %endif
-ln -sf %{_slibdir}/libgcc_s.so.1       $gccdir/libgcc_s.so
+ln -sf %{_slibdir}/libgcc_s.so.1       $gccdir/libgcc_s.so
 
 %find_lang gcc
 %{?with_cxx:%find_lang libstdc\+\+}
@@ -990,7 +983,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libssp.la
 %attr(755,root,root) %{_libdir}/libssp.a
 %attr(755,root,root) %{_libdir}/libssp.so
-#{_libdir}/libssp_nonshared.*
+%{_libdir}/libssp_nonshared.a
+%{_libdir}/libssp_nonshared.la
 %if %{with multilib}
 %dir %{_libdir}/gcc/*/*/32
 %{_libdir}/gcc/*/*/32/libgcov.a
@@ -1000,7 +994,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir32}/libssp.la
 %attr(755,root,root) %{_libdir32}/libssp.a
 %attr(755,root,root) %{_libdir32}/libssp.so
-#{_libdir32}/libssp_nonshared.*
+%{_libdir32}/libssp_nonshared.a
+%{_libdir32}/libssp_nonshared.la
 %endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
@@ -1184,8 +1179,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
 %{_infodir}/fastjar*
 %{_infodir}/gcj*
-%{_infodir}/hacking*
-%{_infodir}/vmintegration*
 %{_mandir}/man1/fastjar*
 %{_mandir}/man1/gcj*
 %{_mandir}/man1/gjnih*
This page took 0.097363 seconds and 4 git commands to generate.