]> git.pld-linux.org Git - packages/gcc.git/commitdiff
- rel 6; fixes branch diff patch; fix in branch.sh auto/th/gcc-7.2.0-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 15 Jan 2018 08:23:50 +0000 (09:23 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 15 Jan 2018 08:23:50 +0000 (09:23 +0100)
branch.sh
gcc.spec

index 83ff9ac3a4ff8a47e92dc27564f9f863c1142297..9d1d6a142eaf19158ca992a6eb3eb15fba1f3ff1 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -9,7 +9,9 @@ out=$package-branch.diff
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
        # remove revno's for smaller diffs
-       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+       # replace svn nonexistend with '0' date, so patch will know that file needs to be removed from disk
+       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,' | \
+       sed -e 's,^\([-+]\{3\} .*\t\)(nonexistent)$,\11970-01-01 01:00:00.000000000 +0100,'
 }
 
 old=$svn/$tag
index 65121153a6ddeae39743fa4fe3f6cd0b971b027d..df78f4244f4b06c6db6ac8fc1d3b46530bbef7da 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -105,7 +105,7 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       5
+Release:       6
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
@@ -117,7 +117,7 @@ Source3:    libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update glibc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        4a58511a43a1387d3f2e004ff67d6fb6
+# Patch100-md5:        5e61603c46bcf0986d005cf6b7b53bf3
 # https://github.com/hjl-tools/gcc.git
 # git log -p --reverse origin/gcc-7-branch..hjl/indirect/gcc-7-branch/master > ~/rpm/packages/gcc/gcc-retpoline.patch
 Patch101:      %{name}-retpoline.patch
This page took 0.060589 seconds and 4 git commands to generate.