]> git.pld-linux.org Git - packages/gc.git/blobdiff - gc.spec
- updated pl summary
[packages/gc.git] / gc.spec
diff --git a/gc.spec b/gc.spec
index 2270ccc2d5550025ee3ea4466dcc81b351ff4115..4033fb4fe8f1ce31b0927fdf4a7d64e4503a0350 100644 (file)
--- a/gc.spec
+++ b/gc.spec
@@ -1,19 +1,20 @@
-Summary:       Conservative garbage collector
-Summary(pl):   Konserwatywny od¶miecacz pamiêci
+Summary:       The Boehm-Demers-Weiser conservative garbage collector
+Summary(pl):   Konserwatywny od¶miecacz pamiêci Boehma-Demersa-Weisera
 Name:          gc
-Version:       6.2
-Release:       2
+Version:       6.8
+Release:       1
 License:       BSD-like
-Group:         Development/Libraries
+Group:         Libraries
 Source0:       http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
-# Source0-md5: 15492b14ca7b9a9e035238611e9cd1e3
-Patch0:                %{name}-ac_libdl_fix.patch
+# Source0-md5: 418d38bd9c66398386a372ec0435250e
 URL:           http://www.hpl.hp.com/personal/Hans_Boehm/gc/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.53
 BuildRequires: automake
 BuildRequires: libtool
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _includedir     %{_prefix}/include/gc
+
 %description
 Gc is a conservative garbage collector for C and C++. It is used as a
 replacement for standard malloc() and free(). GC_malloc will attempt
@@ -23,14 +24,14 @@ garbage collector at appropriate points.
 %description -l pl
 Gc jest konserwatywnym od¶miecaczem pamiêci dla C i C++. Jest u¿ywany
 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
-próbuje odzyskaæ niedostêpna pamiêc automatycznie przez wywo³ywanie
+próbuje odzyskaæ niedostêpna pamiêæ automatycznie przez wywo³ywanie
 konserwatywnego od¶miecacza pamiêci w odpowiednich miejscach.
 
 %package devel
 Summary:       Headers for conservative garbage collector
 Summary(pl):   Nag³ówki dla konserwatywnego od¶miecacza pamiêci
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Headers for conservative garbage collector
@@ -42,7 +43,7 @@ Nag
 Summary:       Static version of gc library
 Summary(pl):   Statyczna wersja biblioteki gc
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of gc library
@@ -52,48 +53,51 @@ Statyczna wersja biblioteki gc
 
 %prep
 %setup -q -n %{name}%{version}
-%patch0 -p1
+
+# kill libtool.m4 inclusion
+%{__perl} -pi -e 's/^sinclude.*//' acinclude.m4
+
+%{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/Makefile.am
 
 %build
-rm -f acinclude.m4
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
 %configure \
+       CPPFLAGS="-DUSE_LIBC_PRIVATES" \
        --enable-threads=posix
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_includedir}/gc,%{_mandir}/man3}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f include/Makefile*
-cp -ar include/* $RPM_BUILD_ROOT%{_includedir}/gc
-install doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
+install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
+install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
 %doc doc/*.html
-%attr(755,root,root) %{_libdir}/*.so.*.*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/gc
-%{_libdir}/*.so
-%{_libdir}/*.la
-%{_mandir}/*/*
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/lib*.la
+%{_includedir}
+%{_mandir}/man3/gc.3*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/lib*.a
This page took 0.110386 seconds and 4 git commands to generate.