]> git.pld-linux.org Git - packages/gazpacho.git/blame_incremental - gazpacho.spec
- release 3
[packages/gazpacho.git] / gazpacho.spec
... / ...
CommitLineData
1Summary: Building Interfaces the easy way
2Summary(pl.UTF-8): Tworzenie interfejsów w łatwy sposób
3Name: gazpacho
4Version: 0.7.2
5Release: 3
6License: LGPL
7Group: Development/Building
8Source0: http://ftp.acc.umu.se/pub/GNOME/sources/gazpacho/0.7/%{name}-%{version}.tar.bz2
9# Source0-md5: ca9c3c308a63194e6dcec3c932c98fbc
10Patch0: %{name}-desktop.patch
11URL: http://gazpacho.sicem.biz/
12BuildRequires: python-devel
13BuildRequires: sed >= 4.0
14BuildRequires: python-kiwi
15Requires: python-pygtk-gtk >= 1:2.6.0
16%pyrequires_eq python-modules
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _noautocompressdoc AUTHORS CONTRIBUTORS COPYING
21
22%description
23This program allows you to create the Graphical User Interface (GUI)
24of your GTK+ program in a visual way. It started as a Glade-3 clone
25but now it is more complete and featured than its ancestor. It tries
26to be compatible with libglade but it can handle some widgets that
27still lack support in libglade.
28
29%description -l pl.UTF-8
30Ten program pozwala tworzyć graficzny interfejs użytkownika (GUI) dla
31programów GTK+ w sposób wizualny. Z początku był klonem Glade-3, ale w
32chwili obecnej jest bardziej zaawansowany od swojego przodka. Gazpacho
33stara się być kompatybilnym z libglade, choć zawiera kilka kontrolek
34wciąż nie wspieranych przez libglade.
35
36%prep
37%setup -q
38#%patch0 -p1
39
40sed -i -e "s/from gazpacho import application//" \
41 -e "s/application.__version__/'%{version}'/" \
42 setup.py
43
44#sed -i -e "s@return self._variables\['docs_dir'\]\[0\]@return '/usr/share/doc/%{name}-%{version}/'@" gazpacho/environ.py
45
46%build
47%{__python} setup.py build
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_pixmapsdir}}
52
53%{__python} setup.py install \
54 --optimize=2 \
55 --root $RPM_BUILD_ROOT
56
57find $RPM_BUILD_ROOT%{py_sitescriptdir}/gazpacho -name '*.py' -exec rm -f {} \;
58
59rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
60
61%find_lang %{name}
62
63install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64install pixmaps/gazpacho-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/gazpacho.png
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post
70umask 022
71[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
72
73%postun
74if [ $1 = 0 ]; then
75 umask 022
76 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
77fi
78
79%files -f %{name}.lang
80%defattr(644,root,root,755)
81# do not remove COPYING -- needed at runtime
82%doc AUTHORS COPYING CONTRIBUTORS ChangeLog NEWS README
83%attr(755,root,root) %{_bindir}/*
84%{_datadir}/gazpacho
85%{py_sitescriptdir}/gazpacho
86%{_desktopdir}/*.desktop
87%{_examplesdir}/%{name}-%{version}
88%{_pixmapsdir}/*.png
This page took 0.074683 seconds and 4 git commands to generate.