]> git.pld-linux.org Git - packages/gawk.git/blobdiff - gawk.spec
- be _libexecdir aware
[packages/gawk.git] / gawk.spec
index 7939daf2815c39b107719fc10a985ec493365a47..cdbe8f889c62b1d510b33879bc9fa093ed8411ad 100644 (file)
--- a/gawk.spec
+++ b/gawk.spec
@@ -1,3 +1,7 @@
+#
+# Conditional build
+%bcond_without tests   # do not perform "make check"
+
 Summary:       The GNU version of the awk text processing utility
 Summary(de.UTF-8):     Die GNU-Version des AWK-Textverarbeitungsutilitys
 Summary(es.UTF-8):     Utilitarios GNU para manipulación de archivos texto
@@ -9,29 +13,33 @@ Summary(ru.UTF-8):   GNU версия утилиты обработки текст
 Summary(tr.UTF-8):     GNU araçları metin düzenleyici
 Summary(uk.UTF-8):     GNU версія утиліти обробки текстів awk
 Name:          gawk
-Version:       3.1.6
+Version:       4.2.0
 Release:       1
 License:       GPL v3+
 Group:         Applications/Text
-Source0:       http://ftp.gnu.org/gnu/gawk/%{name}-%{version}.tar.bz2
-# Source0-md5: c9926c0bc8c177cb9579708ce67f0d75
+Source0:       http://ftp.gnu.org/gnu/gawk/%{name}-%{version}.tar.lz
+# Source0-md5: 716b498c13c96c01758ab59415763e72
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 80753d75be0f469f70e8c90e75121a9c
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-shutup.patch
-Patch2:                %{name}-pl.po-update.patch
-Patch3:                %{name}-3.1.3-getpgrp_void.patch
-BuildRequires: autoconf >= 2.61
-BuildRequires: automake >= 1:1.10
-BuildRequires: gettext-devel >= 0.16.1
+Patch2:                no-pty-test.patch
+URL:           http://www.gnu.org/software/gawk/
+BuildRequires: autoconf >= 2.69
+BuildRequires: automake >= 1:1.15
+BuildRequires: gettext-tools >= 0.19.7
+BuildRequires: gmp-devel
+BuildRequires: libsigsegv
+BuildRequires: lzip
+BuildRequires: mpfr-devel
+BuildRequires: readline-devel
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.3
 Requires:      mktemp
 Requires:      sed
 Obsoletes:     gawk-doc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _includedir     %{_prefix}/include/awk
-
 %description
 The gawk packages contains the GNU version of awk, a text processing
 utility. Awk interprets a special-purpose programming language to do
@@ -115,9 +123,8 @@ Ten pakiet zawiera pliki nagłówkowe dla gawka.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
-rm -f po/stamp-po
+%{__rm} po/stamp-po
 
 %build
 %{__gettextize}
@@ -125,51 +132,75 @@ rm -f po/stamp-po
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+
+%configure \
+       --datadir=%{_libdir}
 
 %{__make} -j1
 
+%{?with_tests:%{__make} -j1 check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_includedir}
-install *.h $RPM_BUILD_ROOT%{_includedir}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/gawk-%{version}
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+
+# mawk provides system wide 'awk'
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/awk
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-rm -f $RPM_BUILD_ROOT%{_bindir}/gawk-%{version}
-rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.gawk-non-english-man-pages
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gawk-non-english-man-pages
+# igawk is declared as obsolete since 4.0.0, dropped in 4.2.0
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{es,fr,it,ja,pl}/man1/igawk.1
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p      /sbin/postshell
+%post  -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun        -p      /sbin/postshell
+%postun        -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README FUTURES LIMITATIONS NEWS POSIX.STD PROBLEMS README
+%doc AUTHORS ChangeLog NEWS POSIX.STD README
 %attr(755,root,root) %{_bindir}/gawk
-%attr(755,root,root) %{_bindir}/igawk
-%attr(755,root,root) %{_bindir}/pgawk*
-%{_mandir}/man1/*
-%lang(es) %{_mandir}/es/man1/*
-%lang(fr) %{_mandir}/fr/man1/*
-%lang(it) %{_mandir}/it/man1/*
-%lang(ja) %{_mandir}/ja/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
-%{_infodir}/*.info*
-%attr(755,root,root) %{_libdir}/awk
-%{_datadir}/awk
+%dir %{_libdir}/gawk
+%attr(755,root,root) %{_libdir}/gawk/*.so
+%dir %{_libdir}/awk
+%{_libdir}/awk/*.awk
+%if "%{_libexecdir}" != "%{_libdir}"
+%dir %{_libexecdir}/awk
+%endif
+%attr(755,root,root) %{_libexecdir}/awk/grcat
+%attr(755,root,root) %{_libexecdir}/awk/pwcat
+/etc/profile.d/gawk.csh
+/etc/profile.d/gawk.sh
+%{_mandir}/man1/gawk.1*
+%{_mandir}/man3/filefuncs.3am*
+%{_mandir}/man3/fnmatch.3am*
+%{_mandir}/man3/fork.3am*
+%{_mandir}/man3/inplace.3am*
+%{_mandir}/man3/ordchr.3am*
+%{_mandir}/man3/readdir.3am*
+%{_mandir}/man3/readfile.3am*
+%{_mandir}/man3/revoutput.3am*
+%{_mandir}/man3/revtwoway.3am*
+%{_mandir}/man3/rwarray.3am*
+%{_mandir}/man3/time.3am*
+%lang(es) %{_mandir}/es/man1/gawk.1*
+%lang(fr) %{_mandir}/fr/man1/gawk.1*
+%lang(it) %{_mandir}/it/man1/gawk.1*
+%lang(ja) %{_mandir}/ja/man1/gawk.1*
+%lang(pl) %{_mandir}/pl/man1/gawk.1*
+%{_infodir}/gawk*.info*
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}
+%{_includedir}/gawkapi.h
This page took 0.050178 seconds and 4 git commands to generate.