]> git.pld-linux.org Git - packages/gawk.git/blob - gawk.spec
- s-/usr/bin-%{_bindir}-
[packages/gawk.git] / gawk.spec
1 Summary:        GNU utilities text processor.
2 Summary(de):    GNU-Utilities Text-Prozessor
3 Summary(fr):    Traitement de texte des utilitaires GNU
4 Summary(pl):    Narzêdzia do obróbki plików tekstowych z GNU
5 Summary(tr):    GNU araçlarý metin düzenleyici
6 Name:           gawk
7 Version:        3.0.3
8 Release:        8
9 Copyright:      GPL
10 Group:          Utilities/Text
11 Group(pl):      Narzêdzia/Tekst
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Source1:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}-ps.tar.gz
14 Patch0:         gawk-unaligned.patch
15 Patch1:         gawk-info.patch
16 Buildroot:      /tmp/%{name}-%{version}-root
17
18 %description
19 This is GNU Awk. It should be upwardly compatible with the Bell Labs
20 research version of awk.  It is almost completely compliant with the
21 1993 POSIX 1003.2 standard for awk.
22
23 Gawk can be used to process text files and is considered a standard
24 Linux tool.
25
26 %description -l de
27 Dies ist GNU Awk. Es sollte aufwärtskompatibel mit der Bell Labs-
28 Version von awk sein. Es ist fast vollständig konform mit dem 1993 
29 POSIX 1003.2-Standard für awk.
30 Gawk läßt sich zum Verarbeiten von Textdateien einsetzen und gilt als
31 ein Standard-Linux-Tool.
32
33 %description -l fr
34 awk de GNU, compatible vers le haut avec les versions awk des Bell Labs.
35 Il est presque totalement conforme au standard 1993 POSIX 1003.2 de awk.
36
37 gawk sert à traiter les fichiers texte est est considéré comme un outil
38 standard de Linux.
39
40 %description -l pl
41 Pakiet zawiera implementacjê GNU interpretera jêzyka awk, który powinien
42 byæ kompatybilny z aplikacj± o tej samej nazwie zrobion± przez Bell Labs.
43 GNU awk jest w pe³ni zgodny ze standardem 1993 POSIX 1003.2.
44
45 Gawk (GNU awk) jest zaawansowanym jêzykiem skryptowym, doskonale nadaj±cym
46 sie do obróbki plików tekstowych. Jest to jedno z podstawowych narzêdzi
47 systemu Linux.
48
49 %description -l tr
50 Gawk metin dosyalarýný iþlemek için kullanýlan standart Linux araçlarýndan
51 biridir.
52
53 %prep
54 %setup -q -b 1
55 %patch0 -p1
56 %patch1 -p1
57
58 %build
59 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
60 ./configure %{_target} \
61         --prefix=/usr
62 make
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_bindir}
67
68 make install prefix=$RPM_BUILD_ROOT/usr bindir=$RPM_BUILD_ROOT/bin
69
70 echo ".so gawk.1" > $RPM_BUILD_ROOT%{_mandir}/man1/awk.1
71 ln -sf /bin/gawk $RPM_BUILD_ROOT%{_bindir}/awk 
72 ln -sf /bin/gawk $RPM_BUILD_ROOT%{_bindir}/gawk 
73
74 gzip -9f $RPM_BUILD_ROOT/usr/{info/gawk.info*,man/man1/*} \
75         README ACKNOWLEDGMENT FUTURES LIMITATIONS NEWS PORTS \
76         README_d/README.linux POSIX.STD doc/gawk.ps doc/awkcard.ps
77
78 %post
79 /sbin/install-info %{_infodir}/gawk.info.gz /etc/info-dir
80
81 %preun
82 if [ "$1" = "0" ]; then
83         /sbin/install-info --delete %{_infodir}/gawk.info.gz /etc/info-dir
84 fi
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc *gz README_d/README.linux.gz doc/*.ps.gz
92 %attr(755,root,root) /bin/*
93 %attr(755,root,root) %{_bindir}/*
94 %{_mandir}/man1/*
95 %{_infodir}/*info*
96 %attr(755,root,root) /usr/libexec/awk
97 %{_datadir}/awk
98
99 %changelog
100 * Mon Apr 19 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
101   [3.0.3-8]
102 - recompiles on new rpm.
103
104 * Wed Apr 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
105   [3.0.3-7]
106 - removed man group from man pages,
107 - gzipping %doc.
108
109 * Sat Jan 02 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
110   [3.0.3-5]
111 - added %post, %preun with {un}registering gawk info
112   pages (added gawk-info.patch),
113 - added gzipping man pages,
114 - added using LDFLAGS="-s" to ./configure enviroment.
115
116 * Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
117   [3.0.3-4]
118 - awk(1) man page is now maked as nroff include to gawk(1) instead
119   making sym link to gawk.1 (this allow compress man pages in future),
120 - removed INSTALL and COPYING from %doc (copyright statment is in Copyright
121   field).
122
123 * Sun Jul 19 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
124 - added pl translation,
125 - added -q %setup parameter,
126 - buildroot canged to /tmp/%{name}-%{version}-root.
127
128 * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
129 - don't package %{_infodir}/dir
130
131 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
132 - translations modified for de, fr, tr
133
134 * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
135 - upgraded to 3.0.3
136 - added documentation and buildroot
137
138 * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
139 - built against glibc
This page took 0.107139 seconds and 4 git commands to generate.