]> git.pld-linux.org Git - packages/ganeti-p2v-transfer.git/blob - ganeti-p2v-transfer.spec
- noatch
[packages/ganeti-p2v-transfer.git] / ganeti-p2v-transfer.spec
1 Summary:        Tool for converting a physical computer into a Ganeti instance
2 Name:           ganeti-p2v-transfer
3 Version:        0.1
4 Release:        2
5 License:        GPL v2
6 Group:          Applications/System
7 Source0:        https://ganeti.googlecode.com/files/%{name}-%{version}.tar.gz
8 # Source0-md5:  c0333098304fa1868ffcaa82a942eba0
9 Patch0:         DESTDIR.patch
10 Patch1:         kpartx-sync.patch
11 URL:            https://code.google.com/p/ganeti/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  docutils
15 BuildRequires:  rpmbuild(macros) >= 1.647
16 Requires:       blockdev
17 Requires:       coreutils
18 Requires:       dump
19 Requires:       e2fsprogs
20 Requires:       ganeti
21 Requires:       kpartx
22 Requires:       losetup
23 Requires:       mawk
24 Requires:       mount
25 Requires:       sed
26 Requires:       tar
27 Requires:       util-linux
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This is a tool for converting a physical computer into a ganeti
33 instance. It consists of two parts, a ganeti instance OS template that
34 allows the instance to be booted to receive the files, and a script
35 that is run on the source machine to make the transfer.
36
37 A design document is available in doc/design.rst that describes the
38 functioning of the system. This document will focus on getting the
39 system up and running, and the process for actually performing
40 physical-to-virtual transfers.
41
42 %package source
43 Summary:        Source system transfer script.
44 Group:          Applications/System
45
46 %description source
47 This script is run from the transfer OS to establish an SSH connection
48 with the bootstrap OS, mount the source filesystem(s), and copy
49 the data over to the target. It will prompt the user for credentials
50 as necessary to gain access to the bootstrap OS.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 %{__aclocal}
59 %{__autoconf}
60 %{__automake}
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install-source install-target \
68         DESTDIR=$RPM_BUILD_ROOT
69
70
71 %{__mv} $RPM_BUILD_ROOT%{_datadir}/ganeti/os/p2v-target/variants.list $RPM_BUILD_ROOT%{_sysconfdir}/ganeti/instance-p2v-target
72 ln -s %{_sysconfdir}/ganeti/instance-p2v-target//variants.list $RPM_BUILD_ROOT%{_datadir}/ganeti/os/p2v-target/variants.list
73
74 %{__rm} -r $RPM_BUILD_ROOT/%{_docdir}/%{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc NEWS README* doc/design.* doc/instance-p2v-target.*
82 %dir %{_sysconfdir}/ganeti/instance-p2v-target
83 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/p2v-target.conf
84 %dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes
85 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/10_fix_fstab
86 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/20_remove_persistent_rules
87 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_inittab
88 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/30_add_console_upstart
89 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/fixes/40_copy_hostname
90 %dir %{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib
91 %{_sysconfdir}/ganeti/instance-p2v-target/fixes/fixlib/*.py*
92 %dir %{_sysconfdir}/ganeti/instance-p2v-target/hooks
93 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/clear-root-password
94 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/install-fixes
95 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/interfaces
96 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/ramboot
97 %attr(755,root,root) %{_sysconfdir}/ganeti/instance-p2v-target/hooks/xen-hvc0
98 %dir %{_sysconfdir}/ganeti/instance-p2v-target/variants
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/variants/default.conf
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ganeti/instance-p2v-target/variants.list
101 %dir %{_datadir}/ganeti/os/p2v-target
102 %{_datadir}/ganeti/os/p2v-target/common.sh
103 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/create
104 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/export
105 %{_datadir}/ganeti/os/p2v-target/ganeti_api_version
106 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/import
107 %attr(755,root,root) %{_datadir}/ganeti/os/p2v-target/rename
108 %{_datadir}/ganeti/os/p2v-target/variants.list
109 %attr(755,root,root) %{_sbindir}/make_ramboot_initrd.py
110
111 %files source
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_sbindir}/p2v_transfer.py
This page took 0.053375 seconds and 3 git commands to generate.