]> git.pld-linux.org Git - packages/gammu.git/blobdiff - gammu.spec
- macros for cmake
[packages/gammu.git] / gammu.spec
index 9492f2e739f480fae20b94c14d11bc5428c219a7..d66c5ade4f2e16944b31dd2ea336346322b445ce 100644 (file)
@@ -1,20 +1,22 @@
-Summary:       Linux/Unix tool suite for Nokia mobile phones
-Summary(pl):   Linuksowy/uniksowy zestaw narzêdzi dla telefonów komórkowych Nokia
+Summary:       GNU tool suite for mobile phones
+Summary(pl.UTF-8):     Zestaw narzędzi GNU dla telefonów komórkowych
 Name:          gammu
-Version:       1.06.00
+Version:       1.12.92
 Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Applications/Communications
-Source0:       http://cihar.com/gammu/zips/gammu/stable/latest/%{name}-%{version}.tar.bz2
-# Source0-md5: d7ad43992fbc32bd9e371afeb73e487f
+Source0:       http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: 5bcb87a39e9004c654e080bf8df7cd43
 Patch0:                %{name}-etc_dir.patch
-Patch1:                %{name}-no_nss.patch
-Patch2:                %{name}-sparc-speeds.patch
 URL:           http://www.gammu.org/
-BuildRequires: autoconf
 BuildRequires: bluez-libs-devel
+BuildRequires: cmake
+BuildRequires: gettext-devel
 BuildRequires: mysql-devel
+BuildRequires: postgresql-devel
+BuildRequires: rpmbuild(macros) >= 1.293
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Provides:      mygnokii2
 Obsoletes:     mygnokii2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -28,74 +30,116 @@ WaveCom, IPAQ, and other). It has a command line version with many
 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
 calls, etc. It can also make full backups and restore them.
 
-%description -l pl
-Gammu (poprzednio znany jako MyGnokii2) jest narzêdziem do zarz±dzania
-ró¿nymi telefonami komórkowymi i modemami. Aktualnie obs³uguje Nokie
+%description -l pl.UTF-8
+Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
+różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
-82xx, 8310, 9110 i 3210 oraz urz±dzenia AT (takie jak Siemens,
-Alcatel, WaveCom, IPAQ i inne). Ma wersjê dzia³aj±c± z linii poleceñ z
-wieloma funkcjami do dzwonków, ksi±¿ki telefonicznej, SMS-ów, logo,
-WAP, daty/czasu, budzika, dzwonienia itp. Mo¿e tak¿e wykonywaæ pe³ne
-kopie zapasowe danych i odtwarzaæ je.
+82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
+Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
+wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
+WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
+kopie zapasowe danych i odtwarzać je.
+
+%package libs
+Summary:       Gammu library
+Summary(pl.UTF-8):     Biblioteka Gammu
+Group:         Libraries
+
+%description libs
+Gammu tool suite library.
+
+%description libs -l pl.UTF-8
+Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
+
+%package devel
+Summary:       Header files for Gammu tool suite for mobile phones
+Summary(pl.UTF-8):     Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      bluez-libs-devel
+
+%description devel
+Header files for Gammu tool suite for mobile phones.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
+
+%package static
+Summary:       Gammu static library
+Summary(pl.UTF-8):     Biblioteka statyczna Gammu
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+
+%description static
+Gammu static library.
+
+%description static -l pl.UTF-8
+Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
 
 %prep
 %setup -q
 #%patch0 -p1
-%patch1 -p1
-cp -f version cfg/autoconf/VERSION
-mv docs/docs/english/gammu.1 .
 
 %build
-cd cfg/autoconf
-%{__autoconf}
-%configure \
-       --disable-static \
-       --without-rpmdir \
-       --enable-cb \
-       --enable-7110incoming \
-       --enable-6210calendar \
-       --with-localedir=%{_datadir}/%{name}
-cd ../..
-%{__make} shared
+mkdir -p build
+cd build
+%cmake ../ \
+       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+       -DCMAKE_VERBOSE_MAKEFILE=1 \
+       -DENABLE_SHARED=OFF \
+       -DINSTALL_LIB_DIR=%{_libdir} \
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
+%{__make}
+mv common/libGammu.a ..
+%cmake ../ \
+       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+       -DCMAKE_VERBOSE_MAKEFILE=1 \
+       -DENABLE_SHARED=ON \
+       -DINSTALL_LIB_DIR=%{_libdir} \
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version},%{_datadir}/%{name}}
-%{__make} installlocales installlibonly \
-       DESTDIR=$RPM_BUILD_ROOT \
-       prefix=%{_prefix} \
-       INSTALL_LIB_DIR=%{_libdir} \
-       INSTALL_MAN_DIR=%{_mandir}/man1 \
-       FIND=find
-
-install -D gammu.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install libGammu.a $RPM_BUILD_ROOT%{_libdir}
+%find_lang %{name}
 
 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
-# anybody feels like developing gammu-based apps?
-rm -rf $RPM_BUILD_ROOT{%{_includedir},%{_libdir}/{*.{so,a},pkgconfig}}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post   libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc changelog docs/docs/english/gammu.htm other/bash readme.txt
-%doc %lang(it) docs/docs/italian
+%doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
+%doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
 %attr(755,root,root) %{_bindir}/%{name}
-%attr(755,root,root) %{_libdir}/*.so.*
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
-%dir %{_datadir}/%{name}
-%lang(cs) %{_datadir}/gammu/gammu_cs.txt
-%lang(de) %{_datadir}/gammu/gammu_de.txt
-%lang(es) %{_datadir}/gammu/gammu_es.txt
-%lang(it) %{_datadir}/gammu/gammu_it.txt
-%lang(pl) %{_datadir}/gammu/gammu_pl.txt
-%lang(ru) %{_datadir}/gammu/gammu_ru.txt
-%{_datadir}/gammu/gammu_us.txt
 %{_examplesdir}/%{name}-%{version}
 %{_mandir}/man1/*
+
+%files libs
+%defattr(755,root,root,755)
+%attr(755,root,root) %{_libdir}/libGammu.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libGammu.so.2
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/%{name}-config
+%attr(755,root,root) %{_libdir}/libGammu.so
+%{_includedir}/*
+%{_pkgconfigdir}/gammu.pc
+
+%files static
+%defattr(755,root,root,755)
+%{_libdir}/libGammu.a
This page took 0.059831 seconds and 4 git commands to generate.