]> git.pld-linux.org Git - packages/gammu.git/blobdiff - gammu.spec
- up to 2.5.0
[packages/gammu.git] / gammu.spec
index 1d92e5b02e4c1e0481ab9b5b45692b1907eb86c4..ca4bcf21290e8d3d1ece05a98c22241fd8afe1fc 100644 (file)
@@ -1,20 +1,23 @@
-Summary:       GNU tool suite for mobile phones
-Summary(pl.UTF-8):     Zestaw narzędzi GNU dla telefonów komórkowych
+Summary:       Tool suite for mobile phones
+Summary(pl.UTF-8):     Zestaw narzędzi do telefonów komórkowych
 Name:          gammu
-Version:       1.14.0
-Release:       3
+Version:       1.25.0
+Release:       1
 Epoch:         1
-License:       GPL v2
+License:       GPL v2+
 Group:         Applications/Communications
 Source0:       http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 87b923d623b400c81d88ceb0d4b14b8c
+# Source0-md5: 49cb33609cc8cfb4b1f998319cd12b7c
 Patch0:                %{name}-etc_dir.patch
 URL:           http://www.gammu.org/
 BuildRequires: bluez-libs-devel
 BuildRequires: cmake >= 2.4.6
+BuildRequires: curl-devel
 BuildRequires: gettext-devel
 BuildRequires: mysql-devel
 BuildRequires: postgresql-devel
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.293
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Provides:      mygnokii2
@@ -64,6 +67,19 @@ Header files for Gammu tool suite for mobile phones.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
 
+%package -n python-gammu
+Summary:       Python bingings for Gammu library
+Summary(pl.UTF-8):     Wiązania języka Python dla biblioteki Gammu
+Group:         Development/Languages/Python
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+%pyrequires_eq python-modules
+
+%description -n python-gammu
+Python bingings for Gammu library.
+
+%description -n python-gammu -l pl.UTF-8
+Wiązania języka Python dla biblioteki Gammu.
+
 %package static
 Summary:       Gammu static library
 Summary(pl.UTF-8):     Biblioteka statyczna Gammu
@@ -76,29 +92,43 @@ Gammu static library.
 %description static -l pl.UTF-8
 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
 
+%package -n bash-completion-gammu
+Summary:       bash-completion for gammu
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gammu
+Group:         Applications/Shells
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      bash-completion
+
+%description -n bash-completion-gammu
+This package provides bash-completion for gammu.
+
+%description -n bash-completion-gammu -l pl.UTF-8
+Pakiet ten dostarcza bashowe uzupełnianie nazw dla gammu.
+
 %prep
 %setup -q
-#%patch0 -p1
+%patch0 -p1
 
 %build
 mkdir -p build
 cd build
-%cmake ../ \
+%cmake .. \
        -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
-       -DCMAKE_VERBOSE_MAKEFILE=1 \
-       -DENABLE_SHARED=OFF \
+       -DCMAKE_VERBOSE_MAKEFILE=ON \
+       -DBUILD_SHARED_LIBS=OFF \
        -DINSTALL_LIB_DIR=%{_lib} \
        -DINSTALL_LIBDATA_DIR=%{_libdir} \
-       %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
 %{__make}
-mv common/libGammu.a ..
-%cmake ../ \
+mv libgammu/libGammu.a ..
+mv smsd/libgsmsd.a ..
+%cmake .. \
        -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
-       -DCMAKE_VERBOSE_MAKEFILE=1 \
-       -DENABLE_SHARED=ON \
+       -DCMAKE_VERBOSE_MAKEFILE=ON \
+       -DBUILD_SHARED_LIBS=ON \
        -DINSTALL_LIB_DIR=%{_lib} \
        -DINSTALL_LIBDATA_DIR=%{_libdir} \
-       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
 %{__make}
 
 %install
@@ -108,9 +138,11 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
-cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
+cp -r docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
+install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
+
 %find_lang %{name}
 
 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
@@ -126,25 +158,47 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
+%doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(755,root,root) %{_bindir}/gammu-smsd
+%attr(755,root,root) %{_bindir}/gammu-smsd-inject
+%attr(755,root,root) %{_bindir}/gammu-smsd-monitor
+%attr(755,root,root) %{_bindir}/jadmaker
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
 %{_examplesdir}/%{name}-%{version}
-%{_mandir}/man1/*
+%{_mandir}/man[157]/*
+%lang(cs) %{_mandir}/cs/man[157]/*
 
 %files libs
-%defattr(755,root,root,755)
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libGammu.so.3
+%attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.6
+%attr(755,root,root) %ghost %{_libdir}/libGammu.so.6
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/%{name}-config
 %attr(755,root,root) %{_libdir}/libGammu.so
+%attr(755,root,root) %{_libdir}/libgsmsd.so
 %{_includedir}/*
+%dir %{py_sitedir}/gammu/
+%attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
 %{_pkgconfigdir}/gammu.pc
+%{_pkgconfigdir}/gammu-smsd.pc
+
+%files -n python-gammu
+%defattr(644,root,root,755)
+%dir %{py_sitedir}/gammu
+%attr(755,root,root) %{py_sitedir}/gammu/*.so
+%{py_sitedir}/gammu/*.py
 
 %files static
-%defattr(755,root,root,755)
+%defattr(644,root,root,755)
+%{_libdir}/libgsmsd.a
 %{_libdir}/libGammu.a
+
+%files -n bash-completion-gammu
+%defattr(644,root,root,755)
+%{_sysconfdir}/bash_completion.d/gammu
This page took 0.078137 seconds and 4 git commands to generate.