]> git.pld-linux.org Git - packages/gammu.git/blobdiff - gammu.spec
- up to 1.36.5
[packages/gammu.git] / gammu.spec
index 62b34d89b790b2a58da8b98fbbbc15a8f85a29ed..c5ab0799f3d629f7dc667ae6f754fefc87397357 100644 (file)
@@ -1,26 +1,29 @@
+# TODO: gammu-smsd-inject should be in seperate package
 Summary:       Tool suite for mobile phones
 Summary(pl.UTF-8):     Zestaw narzędzi do telefonów komórkowych
 Name:          gammu
-Version:       1.27.0
+Version:       1.36.2
 Release:       2
 Epoch:         1
 License:       GPL v2+
 Group:         Applications/Communications
-Source0:       http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 320f2a6fa5e0510cc5200f9bef15f92e
+Source0:       http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.xz
+# Source0-md5: 60702f67a756b058706995824f40016a
 Source1:       %{name}-smsd.init
 Source2:       %{name}-smsd.sysconfig
+Source3:       %{name}.tmpfiles
 Patch0:                %{name}-etc_dir.patch
+Patch1:                %{name}-werror.patch
 URL:           http://www.gammu.org/
 BuildRequires: bluez-libs-devel
 BuildRequires: cmake >= 2.4.6
 BuildRequires: curl-devel
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 BuildRequires: mysql-devel
 BuildRequires: postgresql-devel
-BuildRequires: python-devel >= 1:2.5
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.293
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz >= 1:4.999.7
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Suggests:      %{name}-smsd = %{epoch}:%{version}-%{release}
 Provides:      mygnokii2
@@ -59,12 +62,11 @@ messages enqueued in this storage. It is perfect tool for managing big
 amounts of received or sent messages and automatically process them.
 
 %description smsd -l pl.UTF-8
-Demon SMS Gammu jest programem, któr okresowo sprawdza czy modem GSM
-odebrał jakieś wiadomości, przechowuje je w zdefiniowanym 
-zasobie a także wysyła wiadomości skolejkowane w tym zasobie.
-Jest idealnym narzędziem do zarządzania dużą ilością
-otrzymanych lub wysyłanych wiadomości i atomatycznego
-przetwarzania ich.
+Demon SMS Gammu jest programem, który okresowo sprawdza czy modem GSM
+odebrał jakieś wiadomości, przechowuje je w zdefiniowanym zasobie a
+także wysyła wiadomości skolejkowane w tym zasobie. Jest idealnym
+narzędziem do zarządzania dużą ilością otrzymanych lub wysyłanych
+wiadomości i automatycznego przetwarzania ich.
 
 %package libs
 Summary:       Gammu library
@@ -90,19 +92,6 @@ Header files for Gammu tool suite for mobile phones.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
 
-%package -n python-gammu
-Summary:       Python bingings for Gammu library
-Summary(pl.UTF-8):     Wiązania języka Python dla biblioteki Gammu
-Group:         Development/Languages/Python
-Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
-%pyrequires_eq python-modules
-
-%description -n python-gammu
-Python bingings for Gammu library.
-
-%description -n python-gammu -l pl.UTF-8
-Wiązania języka Python dla biblioteki Gammu.
-
 %package static
 Summary:       Gammu static library
 Summary(pl.UTF-8):     Biblioteka statyczna Gammu
@@ -121,6 +110,9 @@ Summary(pl.UTF-8):  bashowe uzupełnianie nazw dla gammu
 Group:         Applications/Shells
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      bash-completion
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-gammu
 This package provides bash-completion for gammu.
@@ -131,38 +123,34 @@ Pakiet ten dostarcza bashowe uzupełnianie nazw dla gammu.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 mkdir -p build
 cd build
 %cmake .. \
-       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
-       -DCMAKE_VERBOSE_MAKEFILE=ON \
        -DBUILD_SHARED_LIBS=OFF \
        -DINSTALL_LIB_DIR=%{_lib} \
-       -DINSTALL_LIBDATA_DIR=%{_libdir} \
-       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
+       -DINSTALL_LIBDATA_DIR=%{_libdir}
 %{__make}
 mv libgammu/libGammu.a ..
 mv smsd/libgsmsd.a ..
 %cmake .. \
-       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
-       -DCMAKE_VERBOSE_MAKEFILE=ON \
        -DBUILD_SHARED_LIBS=ON \
        -DINSTALL_LIB_DIR=%{_lib} \
-       -DINSTALL_LIBDATA_DIR=%{_libdir} \
-       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
+       -DINSTALL_LIBDATA_DIR=%{_libdir}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}} \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
-cp -r docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+#cp -r docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
 install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}-smsd $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
@@ -172,10 +160,12 @@ cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-smsd
 install -d $RPM_BUILD_ROOT/%{_varrun}/%{name}-smsd
 install -d $RPM_BUILD_ROOT/%{_sharedstatedir}/%{name}-smsd
 
+install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
 %find_lang %{name}
 %find_lang libgammu
 
-rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 
 # for rpm autodeps
 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
@@ -208,24 +198,25 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
-%doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
+%doc AUTHORS ChangeLog docs/manual/Gammu.htm
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(755,root,root) %{_bindir}/%{name}-detect
 %attr(755,root,root) %{_bindir}/jadmaker
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
 %{_examplesdir}/%{name}-%{version}
+%{_datadir}/gammu
 %{_mandir}/man[157]/*
-%lang(cs) %{_mandir}/cs/man[157]/*
 
 %files smsd
-%defattr(640,root,root,750)
+%defattr(644,root,root,755)
 %doc docs/sql/*.sql
 %attr(755,root,root) %{_bindir}/gammu-smsd
 %attr(755,root,root) %{_bindir}/gammu-smsd-inject
 %attr(755,root,root) %{_bindir}/gammu-smsd-monitor
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-smsd
-%config(noreplace) /etc/sysconfig/%{name}-smsd
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}-smsd
 %{_sysconfdir}/%{name}-smsd
+/usr/lib/tmpfiles.d/%{name}.conf
 %attr(750,root,gammu-smsd) %{_varrun}/%{name}-smsd
 %attr(750,gammu-smsd,gammu-smsd) %{_sharedstatedir}/%{name}-smsd
 
@@ -233,8 +224,8 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
 %attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.?
-%attr(755,root,root) %ghost %{_libdir}/libGammu.so.?
+%attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.7
+%attr(755,root,root) %ghost %{_libdir}/libGammu.so.7
 
 %files devel
 %defattr(644,root,root,755)
@@ -242,17 +233,9 @@ fi
 %attr(755,root,root) %{_libdir}/libGammu.so
 %attr(755,root,root) %{_libdir}/libgsmsd.so
 %{_includedir}/*
-%dir %{py_sitedir}/gammu/
-%attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
 %{_pkgconfigdir}/gammu.pc
 %{_pkgconfigdir}/gammu-smsd.pc
 
-%files -n python-gammu
-%defattr(644,root,root,755)
-%dir %{py_sitedir}/gammu
-%attr(755,root,root) %{py_sitedir}/gammu/*.so
-%{py_sitedir}/gammu/*.py
-
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libgsmsd.a
This page took 0.039715 seconds and 4 git commands to generate.