]> git.pld-linux.org Git - packages/gammu.git/blobdiff - gammu.spec
- up to 1.25.93 testing
[packages/gammu.git] / gammu.spec
index a799f01eeded8b03538dc0731cb6dd9331167018..bb6e4ecf89819519deec5716517a74e2a83e4f56 100644 (file)
@@ -1,19 +1,25 @@
-Summary:       Linux/Unix tool suite for Nokia mobile phones
-Summary(pl.UTF-8):     Linuksowy/uniksowy zestaw narzędzi dla telefonów komórkowych Nokia
+Summary:       Tool suite for mobile phones
+Summary(pl.UTF-8):     Zestaw narzędzi do telefonów komórkowych
 Name:          gammu
-Version:       1.07.00
-Release:       1
+Version:       1.25.93
+Release:       0.1
 Epoch:         1
-License:       GPL v2
+License:       GPL v2+
 Group:         Applications/Communications
-Source0:       http://www.mwiacek.com/zips/gsm/gammu/stable/1_0x/%{name}-%{version}.tar.gz
-# Source0-md5: b706e35a6f003acc47f8c2bb71fa8036
+Source0:       http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: a26354e5d16a398765c3bb26c4296103
 Patch0:                %{name}-etc_dir.patch
-Patch1:                %{name}-no_nss.patch
 URL:           http://www.gammu.org/
-BuildRequires: autoconf
 BuildRequires: bluez-libs-devel
+BuildRequires: cmake >= 2.4.6
+BuildRequires: curl-devel
+BuildRequires: gettext-devel
 BuildRequires: mysql-devel
+BuildRequires: postgresql-devel
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.293
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Provides:      mygnokii2
 Obsoletes:     mygnokii2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -37,64 +43,162 @@ wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
 kopie zapasowe danych i odtwarzać je.
 
+%package libs
+Summary:       Gammu library
+Summary(pl.UTF-8):     Biblioteka Gammu
+Group:         Libraries
+
+%description libs
+Gammu tool suite library.
+
+%description libs -l pl.UTF-8
+Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
+
+%package devel
+Summary:       Header files for Gammu tool suite for mobile phones
+Summary(pl.UTF-8):     Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      bluez-libs-devel
+
+%description devel
+Header files for Gammu tool suite for mobile phones.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
+
+%package -n python-gammu
+Summary:       Python bingings for Gammu library
+Summary(pl.UTF-8):     Wiązania języka Python dla biblioteki Gammu
+Group:         Development/Languages/Python
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+%pyrequires_eq python-modules
+
+%description -n python-gammu
+Python bingings for Gammu library.
+
+%description -n python-gammu -l pl.UTF-8
+Wiązania języka Python dla biblioteki Gammu.
+
+%package static
+Summary:       Gammu static library
+Summary(pl.UTF-8):     Biblioteka statyczna Gammu
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+
+%description static
+Gammu static library.
+
+%description static -l pl.UTF-8
+Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
+
+%package -n bash-completion-gammu
+Summary:       bash-completion for gammu
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gammu
+Group:         Applications/Shells
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      bash-completion
+
+%description -n bash-completion-gammu
+This package provides bash-completion for gammu.
+
+%description -n bash-completion-gammu -l pl.UTF-8
+Pakiet ten dostarcza bashowe uzupełnianie nazw dla gammu.
+
 %prep
 %setup -q
-#%patch0 -p1
-%patch1 -p1
-cp -f version cfg/autoconf/VERSION
-mv docs/docs/english/gammu.1 .
+%patch0 -p1
 
 %build
-cd cfg/autoconf
-%{__autoconf}
-%configure \
-       --disable-static \
-       --without-rpmdir \
-       --enable-cb \
-       --enable-7110incoming \
-       --enable-6210calendar \
-       --with-localedir=%{_datadir}/%{name}
-cd ../..
-%{__make} shared
+mkdir -p build
+cd build
+%cmake .. \
+       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+       -DCMAKE_VERBOSE_MAKEFILE=ON \
+       -DBUILD_SHARED_LIBS=OFF \
+       -DINSTALL_LIB_DIR=%{_lib} \
+       -DINSTALL_LIBDATA_DIR=%{_libdir} \
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
+%{__make}
+mv libgammu/libGammu.a ..
+mv smsd/libgsmsd.a ..
+%cmake .. \
+       -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
+       -DCMAKE_VERBOSE_MAKEFILE=ON \
+       -DBUILD_SHARED_LIBS=ON \
+       -DINSTALL_LIB_DIR=%{_lib} \
+       -DINSTALL_LIBDATA_DIR=%{_libdir} \
+       %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version},%{_datadir}/%{name}}
-%{__make} installlocales installlibonly \
-       DESTDIR=$RPM_BUILD_ROOT \
-       prefix=%{_prefix} \
-       INSTALL_LIB_DIR=%{_libdir} \
-       INSTALL_MAN_DIR=%{_mandir}/man1 \
-       FIND=find
-
-install -D gammu.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
-install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
-cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
+cp -r docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install libGammu.a $RPM_BUILD_ROOT%{_libdir}
+install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
+
+%find_lang %{name}
 
 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
-# anybody feels like developing gammu-based apps?
-rm -rf $RPM_BUILD_ROOT{%{_includedir},%{_libdir}/{*.{so,a},pkgconfig}}
+
+# for rpm autodeps
+chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post   libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc changelog docs/docs/english/gammu.htm other/bash readme.txt
-%doc %lang(it) docs/docs/italian
+%doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
+%doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
 %attr(755,root,root) %{_bindir}/%{name}
-%attr(755,root,root) %{_libdir}/*.so.*
+%attr(755,root,root) %{_bindir}/gammu-smsd
+%attr(755,root,root) %{_bindir}/gammu-smsd-inject
+%attr(755,root,root) %{_bindir}/gammu-smsd-monitor
+%attr(755,root,root) %{_bindir}/jadmaker
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
-%dir %{_datadir}/%{name}
-%lang(cs) %{_datadir}/gammu/gammu_cs.txt
-%lang(de) %{_datadir}/gammu/gammu_de.txt
-%lang(es) %{_datadir}/gammu/gammu_es.txt
-%lang(it) %{_datadir}/gammu/gammu_it.txt
-%lang(pl) %{_datadir}/gammu/gammu_pl.txt
-%lang(ru) %{_datadir}/gammu/gammu_ru.txt
-%{_datadir}/gammu/gammu_us.txt
 %{_examplesdir}/%{name}-%{version}
-%{_mandir}/man1/*
+%{_mandir}/man[157]/*
+%lang(cs) %{_mandir}/cs/man[157]/*
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libGammu.so.*.*
+%attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.7
+%attr(755,root,root) %ghost %{_libdir}/libGammu.so.7
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/%{name}-config
+%attr(755,root,root) %{_libdir}/libGammu.so
+%attr(755,root,root) %{_libdir}/libgsmsd.so
+%{_includedir}/*
+%dir %{py_sitedir}/gammu/
+%attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
+%{_pkgconfigdir}/gammu.pc
+%{_pkgconfigdir}/gammu-smsd.pc
+
+%files -n python-gammu
+%defattr(644,root,root,755)
+%dir %{py_sitedir}/gammu
+%attr(755,root,root) %{py_sitedir}/gammu/*.so
+%{py_sitedir}/gammu/*.py
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libgsmsd.a
+%{_libdir}/libGammu.a
+
+%files -n bash-completion-gammu
+%defattr(644,root,root,755)
+%{_sysconfdir}/bash_completion.d/gammu
This page took 0.062136 seconds and 4 git commands to generate.