]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- fix libdir name on x86_64
[packages/gammu.git] / gammu.spec
1 Summary:        GNU tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi GNU dla telefonów komórkowych
3 Name:           gammu
4 Version:        1.14.0
5 Release:        2
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  87b923d623b400c81d88ceb0d4b14b8c
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake
15 BuildRequires:  gettext-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  postgresql-devel
18 BuildRequires:  rpmbuild(macros) >= 1.293
19 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
20 Provides:       mygnokii2
21 Obsoletes:      mygnokii2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Gammu (formerly known as MyGnokii2) is cellular manager for various
26 mobile phones and modems. It currently supports Nokia 3210, 33xx,
27 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
28 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
29 WaveCom, IPAQ, and other). It has a command line version with many
30 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
31 calls, etc. It can also make full backups and restore them.
32
33 %description -l pl.UTF-8
34 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
35 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
36 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
37 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
38 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
39 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
40 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
41 kopie zapasowe danych i odtwarzać je.
42
43 %package libs
44 Summary:        Gammu library
45 Summary(pl.UTF-8):      Biblioteka Gammu
46 Group:          Libraries
47
48 %description libs
49 Gammu tool suite library.
50
51 %description libs -l pl.UTF-8
52 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
53
54 %package devel
55 Summary:        Header files for Gammu tool suite for mobile phones
56 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
57 Group:          Development/Libraries
58 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
59 Requires:       bluez-libs-devel
60
61 %description devel
62 Header files for Gammu tool suite for mobile phones.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
66
67 %package static
68 Summary:        Gammu static library
69 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Gammu static library.
75
76 %description static -l pl.UTF-8
77 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
78
79 %prep
80 %setup -q
81 #%patch0 -p1
82
83 %build
84 mkdir -p build
85 cd build
86 %cmake ../ \
87         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
88         -DCMAKE_VERBOSE_MAKEFILE=1 \
89         -DENABLE_SHARED=OFF \
90         -DINSTALL_LIB_DIR=%{_lib} \
91         -DINSTALL_LIBDATA_DIR=%{_libdir} \
92         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
93 %{__make}
94 mv common/libGammu.a ..
95 %cmake ../ \
96         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
97         -DCMAKE_VERBOSE_MAKEFILE=1 \
98         -DENABLE_SHARED=ON \
99         -DINSTALL_LIB_DIR=%{_lib} \
100         -DINSTALL_LIBDATA_DIR=%{_libdir} \
101         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
107
108 %{__make} -C build install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
112 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
114 %find_lang %{name}
115
116 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
117
118 # for rpm autodeps
119 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   libs -p /sbin/ldconfig
125 %postun libs -p /sbin/ldconfig
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
130 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
131 %attr(755,root,root) %{_bindir}/%{name}
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
133 %{_examplesdir}/%{name}-%{version}
134 %{_mandir}/man1/*
135
136 %files libs
137 %defattr(755,root,root,755)
138 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
139 #%attr(755,root,root) %ghost %{_libdir}/libGammu.so.2
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/%{name}-config
144 %attr(755,root,root) %{_libdir}/libGammu.so
145 %{_includedir}/*
146 %{_pkgconfigdir}/gammu.pc
147
148 %files static
149 %defattr(755,root,root,755)
150 %{_libdir}/libGammu.a
This page took 0.062713 seconds and 3 git commands to generate.