]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- up to 1.23.1
[packages/gammu.git] / gammu.spec
1 Summary:        Tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi do telefonów komórkowych
3 Name:           gammu
4 Version:        1.23.1
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  bb1d23eb766ecd9d21bc79c2f8a1d480
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake >= 2.4.6
15 BuildRequires:  curl-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  mysql-devel
18 BuildRequires:  postgresql-devel
19 BuildRequires:  rpmbuild(macros) >= 1.293
20 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
21 Provides:       mygnokii2
22 Obsoletes:      mygnokii2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Gammu (formerly known as MyGnokii2) is cellular manager for various
27 mobile phones and modems. It currently supports Nokia 3210, 33xx,
28 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
29 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
30 WaveCom, IPAQ, and other). It has a command line version with many
31 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
32 calls, etc. It can also make full backups and restore them.
33
34 %description -l pl.UTF-8
35 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
36 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
37 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
38 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
39 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
40 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
41 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
42 kopie zapasowe danych i odtwarzać je.
43
44 %package libs
45 Summary:        Gammu library
46 Summary(pl.UTF-8):      Biblioteka Gammu
47 Group:          Libraries
48
49 %description libs
50 Gammu tool suite library.
51
52 %description libs -l pl.UTF-8
53 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
54
55 %package devel
56 Summary:        Header files for Gammu tool suite for mobile phones
57 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
60 Requires:       bluez-libs-devel
61
62 %description devel
63 Header files for Gammu tool suite for mobile phones.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
67
68 %package static
69 Summary:        Gammu static library
70 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
73
74 %description static
75 Gammu static library.
76
77 %description static -l pl.UTF-8
78 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 mkdir -p build
86 cd build
87 %cmake .. \
88         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
89         -DCMAKE_VERBOSE_MAKEFILE=ON \
90         -DBUILD_SHARED_LIBS=OFF \
91         -DINSTALL_LIB_DIR=%{_lib} \
92         -DINSTALL_LIBDATA_DIR=%{_libdir} \
93         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
94 %{__make}
95 mv libgammu/libGammu.a ..
96 mv smsd/libgsmsd.a ..
97 %cmake .. \
98         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
99         -DCMAKE_VERBOSE_MAKEFILE=ON \
100         -DBUILD_SHARED_LIBS=ON \
101         -DINSTALL_LIB_DIR=%{_lib} \
102         -DINSTALL_LIBDATA_DIR=%{_libdir} \
103         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
109
110 %{__make} -C build install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
114 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
115 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
116 install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
117
118 %find_lang %{name}
119
120 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
121
122 # for rpm autodeps
123 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   libs -p /sbin/ldconfig
129 %postun libs -p /sbin/ldconfig
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
134 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
135 %attr(755,root,root) %{_bindir}/%{name}
136 %attr(755,root,root) %{_bindir}/gammu-smsd
137 %attr(755,root,root) %{_bindir}/gammu-smsd-inject
138 %attr(755,root,root) %{_bindir}/gammu-smsd-monitor
139 %attr(755,root,root) %{_bindir}/jadmaker
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
141 %{_examplesdir}/%{name}-%{version}
142 %{_mandir}/man1/*
143 %{_mandir}/man5/*
144 %{_mandir}/man7/*
145
146 %files libs
147 %defattr(755,root,root,755)
148 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
149 %attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.6
151 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.6
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/%{name}-config
156 %attr(755,root,root) %{_libdir}/libGammu.so
157 %attr(755,root,root) %{_libdir}/libgsmsd.so
158 %{_includedir}/*
159 %dir %{py_sitedir}/gammu/
160 %attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
161 %{_pkgconfigdir}/gammu.pc
162 %{_pkgconfigdir}/gammu-smsd.pc
163
164 %files static
165 %defattr(755,root,root,755)
166 %{_libdir}/libgsmsd.a
167 %{_libdir}/libGammu.a
This page took 0.076994 seconds and 3 git commands to generate.