]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
b3a9023c4729a9b02cf6b2adbadad609081a489a
[packages/gammu.git] / gammu.spec
1 Summary:        Tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi do telefonów komórkowych
3 Name:           gammu
4 Version:        1.27.0
5 Release:        1
6 Epoch:          1
7 License:        GPL v2+
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  320f2a6fa5e0510cc5200f9bef15f92e
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake >= 2.4.6
15 BuildRequires:  curl-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  mysql-devel
18 BuildRequires:  postgresql-devel
19 BuildRequires:  python-devel >= 1:2.5
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.293
22 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
23 Provides:       mygnokii2
24 Obsoletes:      mygnokii2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Gammu (formerly known as MyGnokii2) is cellular manager for various
29 mobile phones and modems. It currently supports Nokia 3210, 33xx,
30 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
31 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
32 WaveCom, IPAQ, and other). It has a command line version with many
33 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
34 calls, etc. It can also make full backups and restore them.
35
36 %description -l pl.UTF-8
37 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
38 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
39 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
40 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
41 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
42 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
43 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
44 kopie zapasowe danych i odtwarzać je.
45
46 %package libs
47 Summary:        Gammu library
48 Summary(pl.UTF-8):      Biblioteka Gammu
49 Group:          Libraries
50
51 %description libs
52 Gammu tool suite library.
53
54 %description libs -l pl.UTF-8
55 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
56
57 %package devel
58 Summary:        Header files for Gammu tool suite for mobile phones
59 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
62 Requires:       bluez-libs-devel
63
64 %description devel
65 Header files for Gammu tool suite for mobile phones.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
69
70 %package -n python-gammu
71 Summary:        Python bingings for Gammu library
72 Summary(pl.UTF-8):      Wiązania języka Python dla biblioteki Gammu
73 Group:          Development/Languages/Python
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75 %pyrequires_eq  python-modules
76
77 %description -n python-gammu
78 Python bingings for Gammu library.
79
80 %description -n python-gammu -l pl.UTF-8
81 Wiązania języka Python dla biblioteki Gammu.
82
83 %package static
84 Summary:        Gammu static library
85 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
88
89 %description static
90 Gammu static library.
91
92 %description static -l pl.UTF-8
93 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
94
95 %package -n bash-completion-gammu
96 Summary:        bash-completion for gammu
97 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gammu
98 Group:          Applications/Shells
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100 Requires:       bash-completion
101
102 %description -n bash-completion-gammu
103 This package provides bash-completion for gammu.
104
105 %description -n bash-completion-gammu -l pl.UTF-8
106 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gammu.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 mkdir -p build
114 cd build
115 %cmake .. \
116         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
117         -DCMAKE_VERBOSE_MAKEFILE=ON \
118         -DBUILD_SHARED_LIBS=OFF \
119         -DINSTALL_LIB_DIR=%{_lib} \
120         -DINSTALL_LIBDATA_DIR=%{_libdir} \
121         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
122 %{__make}
123 mv libgammu/libGammu.a ..
124 mv smsd/libgsmsd.a ..
125 %cmake .. \
126         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
127         -DCMAKE_VERBOSE_MAKEFILE=ON \
128         -DBUILD_SHARED_LIBS=ON \
129         -DINSTALL_LIB_DIR=%{_lib} \
130         -DINSTALL_LIBDATA_DIR=%{_libdir} \
131         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
137
138 %{__make} -C build install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
142 cp -r docs/develop $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
143 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
144 install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
145
146 %find_lang %{name}
147 %find_lang libgammu
148
149 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
150
151 # for rpm autodeps
152 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
163 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
164 %attr(755,root,root) %{_bindir}/%{name}
165 %attr(755,root,root) %{_bindir}/gammu-smsd
166 %attr(755,root,root) %{_bindir}/gammu-smsd-inject
167 %attr(755,root,root) %{_bindir}/gammu-smsd-monitor
168 %attr(755,root,root) %{_bindir}/jadmaker
169 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
170 %{_examplesdir}/%{name}-%{version}
171 %{_mandir}/man[157]/*
172 %lang(cs) %{_mandir}/cs/man[157]/*
173
174 %files libs -f libgammu.lang
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
177 %attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.?
179 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.?
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/%{name}-config
184 %attr(755,root,root) %{_libdir}/libGammu.so
185 %attr(755,root,root) %{_libdir}/libgsmsd.so
186 %{_includedir}/*
187 %dir %{py_sitedir}/gammu/
188 %attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
189 %{_pkgconfigdir}/gammu.pc
190 %{_pkgconfigdir}/gammu-smsd.pc
191
192 %files -n python-gammu
193 %defattr(644,root,root,755)
194 %dir %{py_sitedir}/gammu
195 %attr(755,root,root) %{py_sitedir}/gammu/*.so
196 %{py_sitedir}/gammu/*.py
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/libgsmsd.a
201 %{_libdir}/libGammu.a
202
203 %files -n bash-completion-gammu
204 %defattr(644,root,root,755)
205 %{_sysconfdir}/bash_completion.d/gammu
This page took 0.035743 seconds and 2 git commands to generate.