]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
a497bcc75c022d469c8c3d9db0508403409a7f9d
[packages/gammu.git] / gammu.spec
1 Summary:        GNU tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi GNU dla telefonów komórkowych
3 Name:           gammu
4 Version:        1.12.92
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  5bcb87a39e9004c654e080bf8df7cd43
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake
15 BuildRequires:  gettext-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  postgresql-devel
18 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
19 Provides:       mygnokii2
20 Obsoletes:      mygnokii2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Gammu (formerly known as MyGnokii2) is cellular manager for various
25 mobile phones and modems. It currently supports Nokia 3210, 33xx,
26 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
27 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
28 WaveCom, IPAQ, and other). It has a command line version with many
29 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
30 calls, etc. It can also make full backups and restore them.
31
32 %description -l pl.UTF-8
33 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
34 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
35 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
36 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
37 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
38 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
39 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
40 kopie zapasowe danych i odtwarzać je.
41
42 %package libs
43 Summary:        Gammu library
44 Summary(pl.UTF-8):      Biblioteka Gammu
45 Group:          Libraries
46
47 %description libs
48 Gammu tool suite library.
49
50 %description libs -l pl.UTF-8
51 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
52
53 %package devel
54 Summary:        Header files for Gammu tool suite for mobile phones
55 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
56 Group:          Development/Libraries
57 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
58 Requires:       bluez-libs-devel
59
60 %description devel
61 Header files for Gammu tool suite for mobile phones.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
65
66 %package static
67 Summary:        Gammu static library
68 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 Gammu static library.
74
75 %description static -l pl.UTF-8
76 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
77
78 %prep
79 %setup -q
80 #%patch0 -p1
81
82 %build
83 mkdir -p build
84 cd build
85 %cmake ../ \
86         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
87         -DCMAKE_VERBOSE_MAKEFILE=1 \
88         -DENABLE_SHARED=OFF \
89         -DINSTALL_LIB_DIR=%{_libdir} \
90         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
91 %{__make}
92 mv common/libGammu.a ..
93 %cmake ../ \
94         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
95         -DCMAKE_VERBOSE_MAKEFILE=1 \
96         -DENABLE_SHARED=ON \
97         -DINSTALL_LIB_DIR=%{_libdir} \
98         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
104
105 %{__make} -C build install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
109 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
111 %find_lang %{name}
112
113 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   libs -p /sbin/ldconfig
119 %postun libs -p /sbin/ldconfig
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
124 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
125 %attr(755,root,root) %{_bindir}/%{name}
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
127 %{_examplesdir}/%{name}-%{version}
128 %{_mandir}/man1/*
129
130 %files libs
131 %defattr(755,root,root,755)
132 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.2
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/%{name}-config
138 %attr(755,root,root) %{_libdir}/libGammu.so
139 %{_includedir}/*
140 %{_pkgconfigdir}/gammu.pc
141
142 %files static
143 %defattr(755,root,root,755)
144 %{_libdir}/libGammu.a
This page took 0.036473 seconds and 2 git commands to generate.