]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- fix .so perms to autogenerate deps (cmake vs rpm war continued)
[packages/gammu.git] / gammu.spec
1 Summary:        GNU tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi GNU dla telefonów komórkowych
3 Name:           gammu
4 Version:        1.12.92
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  5bcb87a39e9004c654e080bf8df7cd43
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake
15 BuildRequires:  gettext-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  postgresql-devel
18 BuildRequires:  rpmbuild(macros) >= 1.293
19 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
20 Provides:       mygnokii2
21 Obsoletes:      mygnokii2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Gammu (formerly known as MyGnokii2) is cellular manager for various
26 mobile phones and modems. It currently supports Nokia 3210, 33xx,
27 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
28 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
29 WaveCom, IPAQ, and other). It has a command line version with many
30 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
31 calls, etc. It can also make full backups and restore them.
32
33 %description -l pl.UTF-8
34 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
35 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
36 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
37 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
38 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
39 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
40 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
41 kopie zapasowe danych i odtwarzać je.
42
43 %package libs
44 Summary:        Gammu library
45 Summary(pl.UTF-8):      Biblioteka Gammu
46 Group:          Libraries
47
48 %description libs
49 Gammu tool suite library.
50
51 %description libs -l pl.UTF-8
52 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
53
54 %package devel
55 Summary:        Header files for Gammu tool suite for mobile phones
56 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
57 Group:          Development/Libraries
58 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
59 Requires:       bluez-libs-devel
60
61 %description devel
62 Header files for Gammu tool suite for mobile phones.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
66
67 %package static
68 Summary:        Gammu static library
69 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Gammu static library.
75
76 %description static -l pl.UTF-8
77 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
78
79 %prep
80 %setup -q
81 #%patch0 -p1
82
83 %build
84 mkdir -p build
85 cd build
86 %cmake ../ \
87         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
88         -DCMAKE_VERBOSE_MAKEFILE=1 \
89         -DENABLE_SHARED=OFF \
90         -DINSTALL_LIB_DIR=%{_libdir} \
91         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
92 %{__make}
93 mv common/libGammu.a ..
94 %cmake ../ \
95         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
96         -DCMAKE_VERBOSE_MAKEFILE=1 \
97         -DENABLE_SHARED=ON \
98         -DINSTALL_LIB_DIR=%{_libdir} \
99         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
105
106 %{__make} -C build install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
110 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
112 %find_lang %{name}
113
114 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
115
116 # for rpm autodeps
117 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   libs -p /sbin/ldconfig
123 %postun libs -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
128 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
129 %attr(755,root,root) %{_bindir}/%{name}
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
131 %{_examplesdir}/%{name}-%{version}
132 %{_mandir}/man1/*
133
134 %files libs
135 %defattr(755,root,root,755)
136 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.2
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/%{name}-config
142 %attr(755,root,root) %{_libdir}/libGammu.so
143 %{_includedir}/*
144 %{_pkgconfigdir}/gammu.pc
145
146 %files static
147 %defattr(755,root,root,755)
148 %{_libdir}/libGammu.a
This page took 0.149728 seconds and 3 git commands to generate.