]> git.pld-linux.org Git - packages/gammu.git/blame - gammu.spec
- fix .so perms to autogenerate deps (cmake vs rpm war continued)
[packages/gammu.git] / gammu.spec
CommitLineData
e9da6d17 1Summary: GNU tool suite for mobile phones
2Summary(pl.UTF-8): Zestaw narzędzi GNU dla telefonów komórkowych
e4c35d43 3Name: gammu
32e1a0a0
MWP
4Version: 1.12.92
5Release: 1
f836a189 6Epoch: 1
e4c35d43 7License: GPL v2
f836a189 8Group: Applications/Communications
736b1f60 9Source0: http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
32e1a0a0 10# Source0-md5: 5bcb87a39e9004c654e080bf8df7cd43
e721ad3e 11Patch0: %{name}-etc_dir.patch
a331b5e4 12URL: http://www.gammu.org/
54d86c80 13BuildRequires: bluez-libs-devel
35238559 14BuildRequires: cmake
9ab30125 15BuildRequires: gettext-devel
101d1802 16BuildRequires: mysql-devel
736b1f60 17BuildRequires: postgresql-devel
0f8fbb9c 18BuildRequires: rpmbuild(macros) >= 1.293
3b248c9a 19Requires: %{name}-libs = %{epoch}:%{version}-%{release}
e4c35d43
PG
20Provides: mygnokii2
21Obsoletes: mygnokii2
f836a189 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
e4c35d43 25Gammu (formerly known as MyGnokii2) is cellular manager for various
99e7d737
JB
26mobile phones and modems. It currently supports Nokia 3210, 33xx,
273410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
288310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
29WaveCom, IPAQ, and other). It has a command line version with many
30functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
31calls, etc. It can also make full backups and restore them.
32
1b85dc8f
JR
33%description -l pl.UTF-8
34Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
35różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
99e7d737 363210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
1b85dc8f
JR
3782xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
38Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
39wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
40WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
41kopie zapasowe danych i odtwarzać je.
f836a189 42
e9da6d17 43%package libs
736b1f60 44Summary: Gammu library
45Summary(pl.UTF-8): Biblioteka Gammu
46Group: Libraries
e9da6d17 47
48%description libs
49Gammu tool suite library.
50
35238559 51%description libs -l pl.UTF-8
e9da6d17 52Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
53
3b248c9a
JB
54%package devel
55Summary: Header files for Gammu tool suite for mobile phones
56Summary(pl.UTF-8): Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
57Group: Development/Libraries
58Requires: %{name}-libs = %{epoch}:%{version}-%{release}
a860cb8f 59Requires: bluez-libs-devel
3b248c9a
JB
60
61%description devel
62Header files for Gammu tool suite for mobile phones.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
66
e9da6d17 67%package static
736b1f60 68Summary: Gammu static library
69Summary(pl.UTF-8): Biblioteka statyczna Gammu
70Group: Development/Libraries
3b248c9a 71Requires: %{name}-devel = %{epoch}:%{version}-%{release}
e9da6d17 72
73%description static
74Gammu static library.
75
35238559 76%description static -l pl.UTF-8
e9da6d17 77Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
78
f836a189 79%prep
44bab158 80%setup -q
ecc2fee0 81#%patch0 -p1
f836a189 82
83%build
35238559
TP
84mkdir -p build
85cd build
86%cmake ../ \
87 -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
a860cb8f 88 -DCMAKE_VERBOSE_MAKEFILE=1 \
35238559 89 -DENABLE_SHARED=OFF \
a860cb8f 90 -DINSTALL_LIB_DIR=%{_libdir} \
48c85e31 91 %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
36390489 92%{__make}
35238559
TP
93mv common/libGammu.a ..
94%cmake ../ \
95 -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
a860cb8f 96 -DCMAKE_VERBOSE_MAKEFILE=1 \
35238559 97 -DENABLE_SHARED=ON \
a860cb8f 98 -DINSTALL_LIB_DIR=%{_libdir} \
32e1a0a0 99 %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
36390489 100%{__make}
f836a189 101
102%install
103rm -rf $RPM_BUILD_ROOT
35238559 104install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
3b248c9a
JB
105
106%{__make} -C build install \
35238559 107 DESTDIR=$RPM_BUILD_ROOT
35238559 108
a683d7d8 109install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
a3c0577f 110cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
35238559 111install libGammu.a $RPM_BUILD_ROOT%{_libdir}
9ab30125 112%find_lang %{name}
11342faf 113
114rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
f836a189 115
5f592fd2
JB
116# for rpm autodeps
117chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
118
f836a189 119%clean
120rm -rf $RPM_BUILD_ROOT
121
a860cb8f
JB
122%post libs -p /sbin/ldconfig
123%postun libs -p /sbin/ldconfig
11342faf 124
9ab30125 125%files -f %{name}.lang
f836a189 126%defattr(644,root,root,755)
fd27f926 127%doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
9ab30125 128%doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
e4c35d43 129%attr(755,root,root) %{_bindir}/%{name}
a3c0577f 130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
a3c0577f 131%{_examplesdir}/%{name}-%{version}
11342faf 132%{_mandir}/man1/*
e9da6d17 133
3b248c9a
JB
134%files libs
135%defattr(755,root,root,755)
a860cb8f
JB
136%attr(755,root,root) %{_libdir}/libGammu.so.*.*
137%attr(755,root,root) %ghost %{_libdir}/libGammu.so.2
3b248c9a 138
e9da6d17 139%files devel
140%defattr(644,root,root,755)
35238559 141%attr(755,root,root) %{_bindir}/%{name}-config
a860cb8f 142%attr(755,root,root) %{_libdir}/libGammu.so
e9da6d17 143%{_includedir}/*
a860cb8f 144%{_pkgconfigdir}/gammu.pc
e9da6d17 145
e9da6d17 146%files static
147%defattr(755,root,root,755)
a860cb8f 148%{_libdir}/libGammu.a
This page took 0.091739 seconds and 4 git commands to generate.