]> git.pld-linux.org Git - packages/gamin.git/commitdiff
- replace deprecated G_CONST_RETURN with 'const' auto/th/gamin-0.1.10-4
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Dec 2012 12:13:40 +0000 (13:13 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 12 Dec 2012 12:13:40 +0000 (13:13 +0100)
- rel 4

gamin-glib.patch [new file with mode: 0644]
gamin.spec

diff --git a/gamin-glib.patch b/gamin-glib.patch
new file mode 100644 (file)
index 0000000..5cc06b7
--- /dev/null
@@ -0,0 +1,44 @@
+--- gamin-0.1.10/server/gam_subscription.h~    2007-07-04 15:36:49.000000000 +0200
++++ gamin-0.1.10/server/gam_subscription.h     2012-12-12 13:11:32.054168714 +0100
+@@ -21,7 +21,7 @@
+ int                  gam_subscription_get_reqno    (GamSubscription *sub);
+-G_CONST_RETURN char *gam_subscription_get_path     (GamSubscription *sub);
++const char *gam_subscription_get_path     (GamSubscription *sub);
+ GamListener         *gam_subscription_get_listener (GamSubscription *sub);
+--- gamin-0.1.10/server/gam_subscription.c~    2007-07-04 15:36:49.000000000 +0200
++++ gamin-0.1.10/server/gam_subscription.c     2012-12-12 13:12:01.167501021 +0100
+@@ -141,7 +141,7 @@
+  * @param sub the GamSubscription
+  * @returns The path being monitored.  It should not be freed.
+  */
+-G_CONST_RETURN char *
++const char *
+ gam_subscription_get_path(GamSubscription * sub)
+ {
+     if (sub == NULL)
+--- gamin-0.1.10/server/gam_node.h~    2007-07-04 15:36:49.000000000 +0200
++++ gamin-0.1.10/server/gam_node.h     2012-12-12 13:12:26.337500133 +0100
+@@ -58,7 +58,7 @@
+ void                  gam_node_set_is_dir          (GamNode         *node,
+                                                  gboolean        is_dir);
+       
+-G_CONST_RETURN char  *gam_node_get_path            (GamNode         *node);
++const char  *gam_node_get_path            (GamNode         *node);
+ GList                *gam_node_get_subscriptions   (GamNode         *node);
+--- gamin-0.1.10/server/gam_node.c~    2007-07-04 15:36:49.000000000 +0200
++++ gamin-0.1.10/server/gam_node.c     2012-12-12 13:12:40.917499618 +0100
+@@ -122,7 +122,7 @@
+  * it has finished with the string.  If it must keep it longer, it
+  * should makes its own copy.  The returned string must not be freed.
+  */
+-G_CONST_RETURN char *
++const char *
+ gam_node_get_path(GamNode * node)
+ {
+     g_assert(node);
index 6f5efde6f34e88fa9f8ece6ef7303f04beca4c35..e7f1b784469de5e466f12690b83ff54391261e09 100644 (file)
@@ -2,11 +2,12 @@ Summary:      Library providing the gamin File Alteration Monitor API
 Summary(pl.UTF-8):     Biblioteka dostarczająca File Alteration Monitor API gamina
 Name:          gamin
 Version:       0.1.10
-Release:       3
+Release:       4
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       http://www.gnome.org/~veillard/gamin/sources/%{name}-%{version}.tar.gz
 # Source0-md5: b4ec549e57da470c04edd5ec2876a028
+Patch0:                %{name}-glib.patch
 URL:           http://www.gnome.org/~veillard/gamin/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -92,6 +93,7 @@ Moduły języka Python dla gamina.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.08816 seconds and 4 git commands to generate.