]> git.pld-linux.org Git - packages/gallery-remote.git/blob - gallery-remote.spec
- added desktop entry
[packages/gallery-remote.git] / gallery-remote.spec
1 Summary:        Gallery Remote - client-side frontend to Gallery
2 Summary(pl):    Gallery Remote - frontend do Gallery dzia³aj±cy po stronie klienta
3 Name:           gallery-remote
4 Version:        1.4.1
5 Release:        0.15
6 License:        GPL v2
7 Group:          Applications/Publishing
8 Source0:        http://dl.sourceforge.net/gallery/GalleryRemote.%{version}.jar
9 # Source0-md5:  763af4f97120f5142222961f02e3943d
10 Source1:        %{name}.png
11 URL:            http://gallery.menalto.com/modules.php?op=modload&name=phpWiki&file=index&pagename=Gallery%20Remote
12 BuildRequires:  sed >= 4.0
13 Requires:       ImageMagick
14 Requires:       ImageMagick-coder-jpeg
15 Requires:       ImageMagick-coder-jpeg2
16 Requires:       ImageMagick-coder-png
17 Requires:       ImageMagick-coder-tiff
18 Requires:       jre >= 1.4
19 Requires:       libjpeg-progs
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _appdir %{_datadir}/%{name}
24
25 %description
26 Gallery Remote is a client-side Java application that provides users
27 with a rich front-end to Gallery. This application makes it easier to
28 upload images to your Gallery.
29
30 %description -l pl
31 Gallery Remote to aplikacja w Javie dzia³aj±ca po stronie klienta
32 udostêpniaj±ca u¿ytkownikom bogaty frontend do Gallery. Ta aplikacja
33 czyni ³atwiejszym umieszczanie obrazków w Gallery.
34
35 %prep
36 %setup -q -c
37 unzip -qq Disk1/InstData/Resource1.zip
38
39 # use better names
40 mv '$IA_PROJECT_DIR$' %{name}
41
42 cd %{name}
43
44 mv gallery_docs/dist/grpackage html
45 rm -f LICENSE # GPL v2
46 rm -rf */{win32,macos} # wrong os
47
48 # make it configured
49 mv imagemagick/im.properties{.preinstalled,}
50 mv imagemagick/HOWTO HOWTO.imagemagick
51 rm imagemagick/LICENSE # imagemagick license
52
53 # and jpegtran too
54 mv jpegtran/{linux/,}jpegtran.properties
55 rm jpegtran/linux/jpegtran # binary
56 rm jpegtran/jpegtran.preinstalled
57 rm -rf jpegtran/linux
58 sed -i -e '/^jp\.path/s/=.*/=jpegtran/' jpegtran/jpegtran.properties
59 # undos
60 sed -i -e 's,
61 $,,' jpegtran/jpegtran.properties
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 cd %{name}
66
67 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_pixmapsdir},%{_desktopdir}}
68 cp -a imagemagick img jpegtran lib $RPM_BUILD_ROOT%{_appdir}
69 cp -a defaults.properties rar*.* $RPM_BUILD_ROOT%{_appdir}
70 cp -a *.jar $RPM_BUILD_ROOT%{_appdir}
71 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
72 #!/bin/sh
73 exec java -cp %{_appdir}/GalleryRemote.jar com.gallery.GalleryRemote.GalleryRemote
74 EOF
75 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
76 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
77 [Desktop Entry]
78 Encoding=UTF-8
79 Name=Gallery Remote
80 Comment=Gallery Remote - client-side frontend to Gallery
81 Icon=%{name}.png
82 Exec=%{name}
83 Terminal=false
84 Type=Application
85 Categories=Graphics;
86 # vi: encoding=utf-8
87 EOF
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc %{name}/{ChangeLog,README,HOWTO.imagemagick,html}
95 %attr(755,root,root) %{_bindir}/*
96 %{_appdir}
97 %{_desktopdir}/*.desktop
98 %{_pixmapsdir}/*.png
This page took 0.077974 seconds and 3 git commands to generate.