]> git.pld-linux.org Git - packages/gallery-remote.git/blob - gallery-remote.spec
- new version. i think
[packages/gallery-remote.git] / gallery-remote.spec
1 #
2 %define         _base   1.5
3 %define         _ver    b31
4 Summary:        Gallery Remote - client-side frontend to Gallery
5 Summary(pl.UTF-8):      Gallery Remote - frontend do Gallery działający po stronie klienta
6 Name:           gallery-remote
7 Version:        1.5.1
8 Release:        %{_ver}_0.1
9 License:        GPL v2
10 Group:          Applications/Publishing
11 Source0:        http://dl.sourceforge.net/gallery/GalleryRemote.%{_base}.jar
12 # Source0-md5:  6043106f54f85380b1bbc06d8dd19d4f
13 Source1:        http://dl.sourceforge.net/gallery/GalleryRemote.1.5.Linux.NoVM.bin
14 # Source1-md5:  521fb28f0027c4d7c84f7ef26c21b790
15 Source2:        %{name}.png
16 Source3:        %{name}.desktop
17 URL:            http://gallery.menalto.com/wiki/Gallery_Remote
18 BuildRequires:  sed >= 4.0
19 Requires:       ImageMagick
20 Requires:       ImageMagick-coder-jpeg
21 Requires:       ImageMagick-coder-jpeg2
22 Requires:       ImageMagick-coder-png
23 Requires:       ImageMagick-coder-tiff
24 Requires:       jre >= 1.4
25 Requires:       libjpeg-progs
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _appdir %{_datadir}/%{name}
30
31 %description
32 Gallery Remote is a client-side Java application that provides users
33 with a rich front-end to Gallery. This application makes it easier to
34 upload images to your Gallery.
35
36 %description -l pl.UTF-8
37 Gallery Remote to aplikacja w Javie działająca po stronie klienta
38 udostępniająca użytkownikom bogaty frontend do Gallery. Ta
39 aplikacja czyni łatwiejszym umieszczanie obrazków w Gallery.
40
41 %prep
42 %setup -q -c -n %{name}-%{_base}
43 install -d gallery_docs
44 unzip -qq -o Disk1/InstData/Resource1.zip
45 mv '$IA_PROJECT_DIR$' %{name}
46 cd %{name}
47
48 unzip -qq -o %{SOURCE1}
49 mv gallery_docs/dist/grpackage html
50 rm -f LICENSE # GPL v2
51 rm -rf */{win32,macos} # wrong os
52
53 # make it configured
54 mv imagemagick/im.properties{.preinstalled,}
55 mv imagemagick/HOWTO HOWTO.imagemagick
56 rm imagemagick/LICENSE # imagemagick license
57
58 # and jpegtran too
59 mv jpegtran/{linux/,}jpegtran.properties
60 rm jpegtran/linux/jpegtran # binary
61 rm jpegtran/jpegtran.preinstalled
62 rm -rf jpegtran/linux
63 sed -i -e '/^jp\.path/s/=.*/=jpegtran/' jpegtran/jpegtran.properties
64 # undos
65 sed -i -e 's,\r$,,' jpegtran/jpegtran.properties
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 cd %{name}
70
71 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_pixmapsdir},%{_desktopdir}}
72 cp -a imagemagick img jpegtran lib $RPM_BUILD_ROOT%{_appdir}
73 cp -a *.jar $RPM_BUILD_ROOT%{_appdir}
74 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
75 #!/bin/sh
76 cd %{_appdir}
77 exec java -cp GalleryRemote.jar com.gallery.GalleryRemote.GalleryRemote
78 EOF
79 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
80 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc %{name}/{ChangeLog,README,HOWTO.imagemagick,html}
88 %attr(755,root,root) %{_bindir}/*
89 %{_appdir}
90 %{_desktopdir}/*.desktop
91 %{_pixmapsdir}/*.png
This page took 0.05136 seconds and 3 git commands to generate.