]> git.pld-linux.org Git - packages/gallery-remote.git/blob - gallery-remote.spec
- worksforme
[packages/gallery-remote.git] / gallery-remote.spec
1 Summary:        Gallery Remote
2 Name:           gallery-remote
3 Version:        1.4.1
4 Release:        0.12
5 License:        GPL v2
6 Group:          Applications/Publishing
7 Source0:        http://dl.sourceforge.net/gallery/GalleryRemote.%{version}.jar
8 # Source0-md5:  763af4f97120f5142222961f02e3943d
9 URL:            http://gallery.menalto.com/modules.php?op=modload&name=phpWiki&file=index&pagename=Gallery%20Remote
10 BuildRequires:  sed >= 4.0
11 Requires:       jre >= 1.4
12 Requires:       ImageMagick
13 Requires:       ImageMagick-coder-tiff
14 Requires:       ImageMagick-coder-jpeg2
15 Requires:       ImageMagick-coder-jpeg
16 Requires:       ImageMagick-coder-png
17 Requires:       libjpeg-progs
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _appdir %{_datadir}/%{name}
22
23 %description
24 Gallery Remote is a client-side Java application that provides users
25 with a rich front-end to Gallery. This application makes it easier to
26 upload images to your Gallery.
27
28 %prep
29 %setup -q -c
30 unzip -qq Disk1/InstData/Resource1.zip
31
32 # use better names
33 mv '$IA_PROJECT_DIR$' %{name}
34
35 cd %{name}
36
37 mv gallery_docs/dist/grpackage html
38 rm -f LICENSE # GPL v2
39 rm -rf */{win32,macos} # wrong os
40
41 # make it configured
42 mv imagemagick/im.properties{.preinstalled,}
43 mv imagemagick/HOWTO HOWTO.imagemagick
44 rm imagemagick/LICENSE # imagemagick license
45
46 # and jpegtran too
47 mv jpegtran/{linux/,}jpegtran.properties
48 rm jpegtran/linux/jpegtran # binary
49 rm jpegtran/jpegtran.preinstalled
50 rm -rf jpegtran/linux
51 sed -i -e '/^jp\.path/s/=.*/=jpegtran/' jpegtran/jpegtran.properties
52 # undos
53 sed -i -e 's,
54 $,,' jpegtran/jpegtran.properties
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 cd %{name}
59
60 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir}}
61 cp -a imagemagick img jpegtran lib $RPM_BUILD_ROOT%{_appdir}
62 cp -a defaults.properties rar*.* $RPM_BUILD_ROOT%{_appdir}
63 cp -a *.jar $RPM_BUILD_ROOT%{_appdir}
64 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
65 #!/bin/sh
66 exec java -cp %{_appdir}/GalleryRemote.jar com.gallery.GalleryRemote.GalleryRemote
67 EOF
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc %{name}/{ChangeLog,README,HOWTO.imagemagick,html}
75 %attr(755,root,root) %{_bindir}/*
76 %{_appdir}
This page took 0.105421 seconds and 3 git commands to generate.