]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- updated to 2.0.4
[packages/galeon.git] / galeon.spec
index 56def551ed4de5b3e6fd1403593be1a38187163a..f4e5689aa1a544868ce2e73dc487b48b1515a861 100644 (file)
@@ -1,33 +1,30 @@
 #
 # Conditional build:
-%bcond_with    nautilus        # disable nautilus view
+%bcond_with    nautilus        # enable nautilus view
 %bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
                                # plugin (better get gcc3-compiled one).
                                # Flash plugin seems to still not work, use
                                # mozilla instead. To compile wit this option, You
                                # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       5:1.7
-%define                snap    20040117
-
 Summary:       Galeon - gecko-based GNOME web browser
-Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
-Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
+Summary(pl.UTF-8):     Galeon - przeglądarka WWW dla GNOME
+Summary(pt_BR.UTF-8):  O galeon é um browser para o GNOME baseado no mozilla
+Summary(zh_CN.UTF-8):  基于Gecko的GNOME流览器
 Name:          galeon
-Version:       2.0.0
+Version:       2.0.4
 Release:       1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
 Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
-# Source0-md5: 5106e037bb52bdb234b3fc09c1e0a3f3
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+# Source0-md5: ee960c2d36b9bc7ab61ee77b1e7ee020
 Source1:       %{name}-config-tool.1
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-home_etc.patch
 Patch2:                %{name}-po.patch
 Patch3:                %{name}-mozilla.patch
+Patch4:                %{name}-agent.patch
 URL:           http://galeon.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.4.0
 BuildRequires: ORBit2-devel >= 2.8.3
@@ -46,37 +43,44 @@ BuildRequires:      libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.6
-BuildRequires: mozilla-devel >= %{minmozver}
+BuildRequires: xulrunner-devel >= 1.8.0.4
 %{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-Requires(post,preun):  GConf2
+BuildRequires: sed >= 4.0
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
 Requires:      glib2 >= 1:2.4.4
 Requires:      gtk+2 >= 2:2.4.4
 Requires:      libbonobo >= 2.4.0
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      wwwbrowser
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
 
 %if %{with gcc2}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
 GNOME browser based on Gecko (Mozilla rendering engine).
 
-%description -l pl
-Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
+%description -l pl.UTF-8
+Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
-%description -l pt_BR
-O galeon é um browser para o GNOME baseado no mozilla.
+%description -l pt_BR.UTF-8
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
@@ -84,6 +88,10 @@ O galeon 
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+
+sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
+mv po/sr\@{Latn,latin}.po
 
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
@@ -91,7 +99,6 @@ orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0
 mv Galeon*.[ch] ../src
 
 %build
-rm -f missing
 cp /usr/share/automake/mkinstalldirs .
 %{__glib_gettextize}
 %{__intltoolize}
@@ -121,10 +128,8 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 # No components installed now.
 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 
-rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
-
 # galeon-2.0.mo, but gnome/help/galeon
-%find_lang galeon-2.0 --with-gnome --all-name
+%find_lang galeon-2.0 --with-gnome --with-omf --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -147,11 +152,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_datadir}/gnome-2.0/ui/*.xml
-%{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
-%{_sysconfdir}/gconf/schemas/*
+%{_sysconfdir}/gconf/schemas/galeon.schemas
 %{_sysconfdir}/sound/events/*
 %{_mandir}/man1/*
This page took 0.039775 seconds and 4 git commands to generate.