]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- converted to UTF-8
[packages/galeon.git] / galeon.spec
index 77cba7d02c024e33ff50b9685d848e1c0be99b0d..a88859304ae033e12433f57008bee1c06fd5f296 100644 (file)
@@ -1,28 +1,25 @@
 #
 # Conditional build:
-%bcond_with nautilus   # disable nautilus view
-%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
-                       # plugin (better get gcc3-compiled one).
-                       # Flash plugin seems to still not work, use
-                       # mozilla instead. To compile wit this option, You
-                       # have to install mozilla compiled with gcc2.
+%bcond_with    nautilus        # disable nautilus view
+%bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
+                               # plugin (better get gcc3-compiled one).
+                               # Flash plugin seems to still not work, use
+                               # mozilla instead. To compile wit this option, You
+                               # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       5:1.7
-%define                snap    20040117
 
 Summary:       Galeon - gecko-based GNOME web browser
-Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
-Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
+Summary(pl.UTF-8):   Galeon - przeglądarka WWW dla GNOME
+Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
+Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
 Name:          galeon
-Version:       1.3.20
-Release:       3
+Version:       2.0.2
+Release:       1
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: 13954dd2f11748c02f3071ac9987d7d3
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 43d395aa3e6424d980919942e5499dba
 Source1:       %{name}-config-tool.1
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-home_etc.patch
@@ -36,6 +33,7 @@ BuildRequires:        automake
 BuildRequires: bison
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-desktop-devel >= 2.9.91
 BuildRequires: gnome-vfs2-devel >= 2.10.0-2
 BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
@@ -45,37 +43,38 @@ BuildRequires:      libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.6
-BuildRequires: mozilla-devel >= %{minmozver}
+BuildRequires: xulrunner-devel >= 1.8.0.4
 %{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
-BuildRequires: nspr-devel
 BuildRequires: pkgconfig
-BuildRequires: rpm-build >= 4.1-10
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-Requires(post):        GConf2
+Requires(post,postun): desktop-file-utils
 Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
 Requires:      glib2 >= 1:2.4.4
 Requires:      gtk+2 >= 2:2.4.4
 Requires:      libbonobo >= 2.4.0
-Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
+%requires_eq   xulrunner
+Provides:      wwwbrowser
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
 %if %{with gcc2}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
 GNOME browser based on Gecko (Mozilla rendering engine).
 
-%description -l pl
-Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
+%description -l pl.UTF-8
+Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
-%description -l pt_BR
-O galeon é um browser para o GNOME baseado no mozilla.
+%description -l pt_BR.UTF-8
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
@@ -92,8 +91,8 @@ mv Galeon*.[ch] ../src
 %build
 rm -f missing
 cp /usr/share/automake/mkinstalldirs .
-glib-gettextize --copy --force
-intltoolize --copy --force
+%{__glib_gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
@@ -106,7 +105,6 @@ intltoolize --copy --force
        %else
        --enable-nautilus-view=no
        %endif
-
 %{__make}
 
 %install
@@ -121,7 +119,7 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 # No components installed now.
 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 
-#rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
 
 # galeon-2.0.mo, but gnome/help/galeon
 %find_lang galeon-2.0 --with-gnome --all-name
@@ -130,15 +128,16 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 rm -rf $RPM_BUILD_ROOT
 
 %post
-umask 022
-/usr/bin/scrollkeeper-update
-%gconf_schema_install
-[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
+%scrollkeeper_update_post
+%gconf_schema_install galeon.schemas
+%update_desktop_database_post
+
+%preun
+%gconf_schema_uninstall galeon.schemas
 
 %postun
-umask 022
-/usr/bin/scrollkeeper-update
-[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
+%scrollkeeper_update_postun
+%update_desktop_database_postun
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
@@ -146,7 +145,7 @@ umask 022
 %attr(755,root,root) %{_bindir}/*
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
This page took 0.113401 seconds and 4 git commands to generate.