]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- rel 5
[packages/galeon.git] / galeon.spec
index 6cef735be73bd584a09241d26887a3d57d514590..933194d46732c3862ffded95c713d3d445dae020 100644 (file)
 #
 # Conditional build:
-# _with_gcc2           - compile using gcc2 to get working java plugin.
-#                        Flash plugin seems to still doesn't work, use 
-#                        mozilla instead. To compile wit this option, You 
-#                        have to install mozilla compiled with gcc2.
+%bcond_with    nautilus        # disable nautilus view
+%bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
+                               # plugin (better get gcc3-compiled one).
+                               # Flash plugin seems to still not work, use
+                               # mozilla instead. To compile wit this option, You
+                               # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       1.4b
-%define                snap            20030518
 
 Summary:       Galeon - gecko-based GNOME web browser
-Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o gnome baseado no mozilla
-Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
+Summary(pl.UTF-8):     Galeon - przeglądarka WWW dla GNOME
+Summary(pt_BR.UTF-8):  O galeon é um browser para o GNOME baseado no mozilla
+Summary(zh_CN.UTF-8):  基于Gecko的GNOME流览器
 Name:          galeon
-Version:       1.3.5
-#Release:      1.%{snap}.1
-Release:       2
+Version:       2.0.2
+Release:       5
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
-# Source0-md5: 6d0a503e82e0c676712859ee273dcd81
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 43d395aa3e6424d980919942e5499dba
 Source1:       %{name}-config-tool.1
-URL:           http://galeon.sourceforge.net/
 Patch0:                %{name}-desktop.patch
-BuildRequires: autoconf
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-po.patch
+Patch3:                %{name}-mozilla.patch
+URL:           http://galeon.sourceforge.net/
+BuildRequires: GConf2-devel >= 2.4.0
+BuildRequires: ORBit2-devel >= 2.8.3
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
-BuildRequires: GConf2-devel >= 2.0.0
-BuildRequires: ORBit2-devel >= 2.0.0
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel >= 2.0.0
-BuildRequires: gtk+2-devel >= 2.0.6
+BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-desktop-devel >= 2.9.91
+BuildRequires: gnome-vfs2-devel >= 2.10.0-2
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
-BuildRequires: libbonobo-devel >= 2.3.1-4
-BuildRequires: libbonoboui-devel >= 2.1.1
-BuildRequires: libglade2-devel >= 2.0.0
-BuildRequires: libgnomeui-devel >= 2.0.5
+BuildRequires: libbonoboui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel >= 2.4.0
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.0.0
-BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 2.6.6
+BuildRequires: xulrunner-devel >= 1.8.0.4
+%{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-BuildRequires: rpm-build >= 4.1-10
-Requires:      libbonobo >= 2.3.1-4
-Requires:      mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
-Requires(post):        GConf2
-Requires(post):        mozilla
-Requires(post):        scrollkeeper
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
+Requires:      glib2 >= 1:2.4.4
+Requires:      gtk+2 >= 2:2.4.4
+Requires:      libbonobo >= 2.4.0
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      wwwbrowser
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
-%if%{?_with_gcc2:1}%{!?_with_gcc2:0}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%if %{with gcc2}
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
-Gnome browser based on Gecko (Mozilla rendering engine).
+GNOME browser based on Gecko (Mozilla rendering engine).
 
-%description -l pl
-Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
+%description -l pl.UTF-8
+Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
-%description -l pt_BR
-O galeon é um browser para o gnome baseado no mozilla.
+%description -l pt_BR.UTF-8
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+# regenerate - didn't compile with ORBit2 2.7.2
+cd idl
+orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
+mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
-glib-gettextize --copy --force
-intltoolize --copy --force
+cp /usr/share/automake/mkinstalldirs .
+%{__glib_gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
        --disable-schemas-install \
-       --disable-werror \
-       --with-mozilla-snapshot=1.4b \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       %if %{with nautilus}
        --enable-nautilus-view=yes
-
+       %else
+       --enable-nautilus-view=no
+       %endif
 %{__make}
 
 %install
@@ -102,33 +112,38 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT 
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-%find_lang galeon-2.0
+# No components installed now.
+#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+
+# galeon-2.0.mo, but gnome/help/galeon
+%find_lang galeon-2.0 --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/bin/scrollkeeper-update
-umask 022
-rm -f %{_libdir}/mozilla/component.reg
-MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
-%gconf_schema_install
+%scrollkeeper_update_post
+%gconf_schema_install galeon.schemas
+%update_desktop_database_post
+
+%preun
+%gconf_schema_uninstall galeon.schemas
 
-%postun -p /usr/bin/scrollkeeper-update
+%postun
+%scrollkeeper_update_postun
+%update_desktop_database_postun
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_datadir}/applications/*
-%{_datadir}/gnome/help/*
+%{_desktopdir}/*.desktop
 %{_datadir}/gnome-2.0/ui/*.xml
 %{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
This page took 0.085256 seconds and 4 git commands to generate.