]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- use better way to fix locale name
[packages/galeon.git] / galeon.spec
index 40a792655e9382be80b5c61637c987f7db0ab15c..7979b758c424658b5976b8ebe123935c3c16e31c 100644 (file)
@@ -1,77 +1,98 @@
 #
 # Conditional build:
-# _with_gcc2           - compile using gcc2 to get working java plugin.
-#                        Flash plugin seems to still doesn't work, use
-#                        mozilla instead. To compile wit this option, You
-#                        have to install mozilla compiled with gcc2.
+%bcond_with    nautilus        # enable nautilus view
+%bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
+                               # plugin (better get gcc3-compiled one).
+                               # Flash plugin seems to still not work, use
+                               # mozilla instead. To compile wit this option, You
+                               # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       5:1.5
-%define                snap    20031025
 
 Summary:       Galeon - gecko-based GNOME web browser
-Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
-Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
+Summary(pl.UTF-8):     Galeon - przeglądarka WWW dla GNOME
+Summary(pt_BR.UTF-8):  O galeon é um browser para o GNOME baseado no mozilla
+Summary(zh_CN.UTF-8):  基于Gecko的GNOME流览器
 Name:          galeon
-Version:       1.3.10
-Release:       1
+Version:       2.0.3
+Release:       6
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
-Source0:       http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: 1707493228c2174e8ecd856789506ecd
+Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 610fe2258e680f68bdf36ce7c1ba2a24
 Source1:       %{name}-config-tool.1
 Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-po.patch
+Patch3:                %{name}-mozilla.patch
+Patch4:                %{name}-agent.patch
 URL:           http://galeon.sourceforge.net/
-BuildRequires: GConf2-devel >= 2.0.0
-BuildRequires: ORBit2-devel >= 2.7.5-1
-BuildRequires: autoconf
+BuildRequires: GConf2-devel >= 2.4.0
+BuildRequires: ORBit2-devel >= 2.8.3
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel >= 2.0.0
-BuildRequires: gtk+2-devel >= 2.0.6
+BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-desktop-devel >= 2.9.91
+BuildRequires: gnome-vfs2-devel >= 2.10.0-2
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
-BuildRequires: libbonobo-devel >= 2.3.1-4
-BuildRequires: libbonoboui-devel >= 2.3.3-2
-BuildRequires: libglade2-devel >= 2.0.0
-BuildRequires: libgnomeui-devel >= 2.3.3.1-2
+BuildRequires: libbonoboui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
-BuildRequires: libxml2-devel >= 2.4.0
-BuildRequires: mozilla-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.3.7-3
-BuildRequires: openssl-devel >= 0.9.7c
+BuildRequires: libtool
+BuildRequires: libxml2-devel >= 2.6.6
+BuildRequires: xulrunner-devel >= 1.8.0.4
+%{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
+BuildRequires: pkgconfig
+# support for --with-omf in find_lang.sh
+BuildRequires: rpm-build >= 4.4.9-10
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-BuildRequires: rpm-build >= 4.1-10
-Requires(post):        GConf2
-Requires(post):        mozilla
-Requires(post):        scrollkeeper
-Requires:      libbonobo >= 2.3.1-4
-Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
+Requires:      glib2 >= 1:2.4.4
+Requires:      gtk+2 >= 2:2.4.4
+Requires:      libbonobo >= 2.4.0
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      wwwbrowser
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
 
-%if %{?_with_gcc2:1}%{!?_with_gcc2:0}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%if %{with gcc2}
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
 GNOME browser based on Gecko (Mozilla rendering engine).
 
-%description -l pl
-Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
+%description -l pl.UTF-8
+Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
-%description -l pt_BR
-O galeon é um browser para o GNOME baseado no mozilla.
+%description -l pt_BR.UTF-8
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+
+sed -i -e s#sr\@Latn#sr\@latin# configure.in
+mv po/sr\@{Latn,latin}.po
 
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
@@ -80,24 +101,21 @@ mv Galeon*.[ch] ../src
 
 %build
 rm -f missing
-glib-gettextize --copy --force
-intltoolize --copy --force
+cp /usr/share/automake/mkinstalldirs .
+%{__glib_gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
        --disable-schemas-install \
-       --disable-werror \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
+       %if %{with nautilus}
        --enable-nautilus-view=yes
-
+       %else
+       --enable-nautilus-view=no
+       %endif
 %{__make}
 
 %install
@@ -109,32 +127,37 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+# No components installed now.
+#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 
 # galeon-2.0.mo, but gnome/help/galeon
-%find_lang galeon-2.0 --with-gnome --all-name
+%find_lang galeon-2.0 --with-gnome --with-omf --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/bin/scrollkeeper-update
-%gconf_schema_install
+%scrollkeeper_update_post
+%gconf_schema_install galeon.schemas
+%update_desktop_database_post
+
+%preun
+%gconf_schema_uninstall galeon.schemas
 
-%postun -p /usr/bin/scrollkeeper-update
+%postun
+%scrollkeeper_update_postun
+%update_desktop_database_postun
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_datadir}/gnome-2.0/ui/*.xml
-%{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
-%{_sysconfdir}/gconf/schemas/*
+%{_sysconfdir}/gconf/schemas/galeon.schemas
 %{_sysconfdir}/sound/events/*
 %{_mandir}/man1/*
This page took 0.388508 seconds and 4 git commands to generate.