]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- rel 6 (mozilla-firefox 1.5.0.7)
[packages/galeon.git] / galeon.spec
index 0087c3e047d947be22e878ce97d3c09eb790ed6a..52b939fd13e287f3f5bb840c689527475963929b 100644 (file)
@@ -1,13 +1,13 @@
 #
 # Conditional build:
-%bcond_without nautilus        # disable nautilus view
-%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
-                       # plugin (better get gcc3-compiled one).
-                       # Flash plugin seems to still not work, use
-                       # mozilla instead. To compile wit this option, You
-                       # have to install mozilla compiled with gcc2.
+%bcond_without mozilla_firefox # build without mozilla-firefox-devel
+%bcond_with    nautilus        # disable nautilus view
+%bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
+                               # plugin (better get gcc3-compiled one).
+                               # Flash plugin seems to still not work, use
+                               # mozilla instead. To compile wit this option, You
+                               # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       5:1.7
 %define                snap    20040117
 
 Summary:       Galeon - gecko-based GNOME web browser
@@ -15,19 +15,19 @@ Summary(pl):        Galeon - przegl
 Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
 Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
 Name:          galeon
-Version:       1.3.16
-Release:       3
+Version:       2.0.1
+Release:       6
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: 539f8c4672a7e7448745f35110ec1529
+Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: 34d6e3a6ee78f9e4d12736e5d81b462b
 #Source0:      %{name}-%{version}-%{snap}.tar.bz2
 Source1:       %{name}-config-tool.1
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-home_etc.patch
-Patch2:                %{name}-locale-names.patch
-Patch3:                %{name}-po.patch
+Patch2:                %{name}-po.patch
+Patch3:                %{name}-mozilla.patch
 URL:           http://galeon.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.4.0
 BuildRequires: ORBit2-devel >= 2.8.3
@@ -35,9 +35,10 @@ BuildRequires:       autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: glib2-devel >= 1:2.4.2
-BuildRequires: gnome-vfs2-devel >= 2.4.0
-BuildRequires: gtk+2-devel >= 2:2.4.3
+BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-desktop-devel >= 2.9.91
+BuildRequires: gnome-vfs2-devel >= 2.10.0-2
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
 BuildRequires: libbonoboui-devel >= 2.4.0
 BuildRequires: libglade2-devel >= 1:2.4.0
@@ -45,24 +46,35 @@ BuildRequires:      libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.6
-BuildRequires: mozilla-devel >= %{minmozver}
+%if %{with mozilla_firefox}
+BuildRequires: mozilla-firefox-devel
+%else
+BuildRequires: mozilla-devel >= 5:1.7
+%endif
 %{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
-BuildRequires: rpm-build >= 4.1-10
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-Requires(post):        GConf2
-Requires(post):        scrollkeeper
-Requires:      glib2 >= 1:2.4.2
-Requires:      gtk+2 >= 2:2.4.3
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
+Requires:      glib2 >= 1:2.4.4
+Requires:      gtk+2 >= 2:2.4.4
 Requires:      libbonobo >= 2.4.0
-Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
+%if %{with mozilla_firefox}
+%requires_eq   mozilla-firefox
+%else
+Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
+%endif
+Provides:      wwwbrowser
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
 
 %if %{with gcc2}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
@@ -82,8 +94,6 @@ O galeon 
 %patch2 -p1
 %patch3 -p1
 
-mv po/{no,nb}.po
-
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
@@ -92,8 +102,8 @@ mv Galeon*.[ch] ../src
 %build
 rm -f missing
 cp /usr/share/automake/mkinstalldirs .
-glib-gettextize --copy --force
-intltoolize --copy --force
+%{__glib_gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
@@ -106,7 +116,6 @@ intltoolize --copy --force
        %else
        --enable-nautilus-view=no
        %endif
-
 %{__make}
 
 %install
@@ -118,7 +127,10 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+# No components installed now.
+#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
 
 # galeon-2.0.mo, but gnome/help/galeon
 %find_lang galeon-2.0 --with-gnome --all-name
@@ -127,16 +139,21 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/bin/scrollkeeper-update
-%gconf_schema_install
+%scrollkeeper_update_post
+%gconf_schema_install galeon.schemas
+%update_desktop_database_post
+
+%preun
+%gconf_schema_uninstall galeon.schemas
 
-%postun -p /usr/bin/scrollkeeper-update
+%postun
+%scrollkeeper_update_postun
+%update_desktop_database_postun
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
 %{_desktopdir}/*
This page took 0.077552 seconds and 4 git commands to generate.