]> git.pld-linux.org Git - packages/galeon.git/blobdiff - galeon.spec
- use %pld_release macro and apply proper agent patch, BR: rpm >= 4.4.9-56
[packages/galeon.git] / galeon.spec
index db41bbd1eba29b288b1cd53ea4f797356e13696f..424ee6a295a5b7a6c8b8369f5f0fcd6c43f2ef8c 100644 (file)
 #
 # Conditional build:
-%bcond_without nautilus        # disable nautilus view
-%bcond_with gcc2       # compile using gcc2 to get working gcc2-compiled java
-                       # plugin (better get gcc3-compiled one).
-                       # Flash plugin seems to still not work, use
-                       # mozilla instead. To compile wit this option, You
-                       # have to install mozilla compiled with gcc2.
+%bcond_with    nautilus        # enable nautilus view
+%bcond_with    gcc2            # compile using gcc2 to get working gcc2-compiled java
+                               # plugin (better get gcc3-compiled one).
+                               # Flash plugin seems to still not work, use
+                               # mozilla instead. To compile wit this option, You
+                               # have to install mozilla compiled with gcc2.
 #
-%define                minmozver       5:1.6
-%define                snap    20040117
-
 Summary:       Galeon - gecko-based GNOME web browser
-Summary(pl):   Galeon - przegl±darka WWW dla GNOME
-Summary(pt_BR):        O galeon é um browser para o GNOME baseado no mozilla
-Summary(zh_CN):        »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
+Summary(pl.UTF-8):     Galeon - przeglądarka WWW dla GNOME
+Summary(pt_BR.UTF-8):  O galeon é um browser para o GNOME baseado no mozilla
+Summary(zh_CN.UTF-8):  基于Gecko的GNOME流览器
 Name:          galeon
-Version:       1.3.12
-Release:       1
+Version:       2.0.5
+Release:       4
 Epoch:         2
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
-# Source0-md5: dac3aac7df1169da9b065d053644a69c
-#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+Source0:       http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
+# Source0-md5: bbddb89ad1ba08a62e03bceab5a38d93
 Source1:       %{name}-config-tool.1
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-mozilla.patch
+Patch3:                %{name}-build_fix.patch
+Patch4:                %{name}-ti-agent.patch
+Patch5:                %{name}-agent.patch
 URL:           http://galeon.sourceforge.net/
 BuildRequires: GConf2-devel >= 2.4.0
 BuildRequires: ORBit2-devel >= 2.8.3
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: gettext-devel
-BuildRequires: gnome-vfs2-devel >= 2.4.0
-BuildRequires: gtk+2-devel >= 2.2.0
+BuildRequires: glib2-devel >= 1:2.4.4
+BuildRequires: gnome-desktop-devel >= 2.9.91
+BuildRequires: gnome-vfs2-devel >= 2.10.0-2
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: intltool
-BuildRequires: libbonobo-devel >= 2.4.0
 BuildRequires: libbonoboui-devel >= 2.4.0
-BuildRequires: libglade2-devel >= 2.0.1
-BuildRequires: libgnomeui-devel >= 2.4.0
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.6.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.4.0
-BuildRequires: mozilla-devel >= %{minmozver}
+BuildRequires: libxml2-devel >= 2.6.6
+BuildRequires: xulrunner-devel >= 1.8.0.4
 %{?with_nautilus:BuildRequires:        nautilus-devel >= 2.4.0}
-BuildRequires: openssl-devel >= 0.9.7c
-BuildRequires: rpm-build >= 4.1-10
+BuildRequires: pkgconfig
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(find_lang) >= 1.23
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper >= 0.1.4
-Requires(post):        GConf2
-Requires(post):        scrollkeeper
+BuildRequires: sed >= 4.0
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
+Requires:      glib2 >= 1:2.4.4
+Requires:      gtk+2 >= 2:2.4.4
 Requires:      libbonobo >= 2.4.0
-Requires:      mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
+%requires_eq_to        xulrunner xulrunner-devel
+Provides:      wwwbrowser
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
 
 %if %{with gcc2}
-%define         __cc            gcc2
-%define         __cxx           gcc2
+%define                __cc            gcc2
+%define                __cxx           gcc2
 %endif
 
 %description
 GNOME browser based on Gecko (Mozilla rendering engine).
 
-%description -l pl
-Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
+%description -l pl.UTF-8
+Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
 interpretacji stron Mozilli).
 
-%description -l pt_BR
-O galeon é um browser para o GNOME baseado no mozilla.
+%description -l pt_BR.UTF-8
+O galeon é um browser para o GNOME baseado no mozilla.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%if "%{pld_release}" == "ti"
+%patch4 -p1
+%else
+%patch5 -p1
+%endif
+
+sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
+mv po/sr\@{Latn,latin}.po
 
 # regenerate - didn't compile with ORBit2 2.7.2
 cd idl
@@ -83,31 +105,21 @@ orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0
 mv Galeon*.[ch] ../src
 
 %build
-rm -f missing
 cp /usr/share/automake/mkinstalldirs .
-glib-gettextize --copy --force
-intltoolize --copy --force
+%{__glib_gettextize}
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-mozilla-libs=%{_libdir} \
-       --with-mozilla-includes=%{_includedir}/mozilla \
-       --with-mozilla-home=%{_libdir}/mozilla \
-       --enable-nls \
-       --disable-included-gettext \
        --disable-schemas-install \
-       --disable-werror \
-       --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
        %if %{with nautilus}
        --enable-nautilus-view=yes
        %else
        --enable-nautilus-view=no
        %endif
-       
-
 %{__make}
 
 %install
@@ -119,32 +131,37 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
+# No components installed now.
+#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
 
 # galeon-2.0.mo, but gnome/help/galeon
-%find_lang galeon-2.0 --with-gnome --all-name
+%find_lang galeon-2.0 --with-gnome --with-omf --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/bin/scrollkeeper-update
-%gconf_schema_install
+%scrollkeeper_update_post
+%gconf_schema_install galeon.schemas
+%update_desktop_database_post
+
+%preun
+%gconf_schema_uninstall galeon.schemas
 
-%postun -p /usr/bin/scrollkeeper-update
+%postun
+%scrollkeeper_update_postun
+%update_desktop_database_postun
 
 %files -f galeon-2.0.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README*
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/%{name}
 %{_libdir}/bonobo/servers/*
 %{_datadir}/galeon
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_datadir}/gnome-2.0/ui/*.xml
-%{_omf_dest_dir}/%{name}
 %{_datadir}/sounds/galeon
 %{_pixmapsdir}/*
-%{_sysconfdir}/gconf/schemas/*
+%{_sysconfdir}/gconf/schemas/galeon.schemas
 %{_sysconfdir}/sound/events/*
 %{_mandir}/man1/*
This page took 0.078021 seconds and 4 git commands to generate.