]> git.pld-linux.org Git - packages/gaby.git/blobdiff - gaby.spec
- tabs in preamble
[packages/gaby.git] / gaby.spec
index 8a03d4d412a023a4d3fa11688a37cc3b1cd21172..fc7a4806e3d86c17d5ae557b3e94db6e78cfbd5f 100644 (file)
--- a/gaby.spec
+++ b/gaby.spec
@@ -1,14 +1,14 @@
 #
 # Conditional build:
-# _without_gtk         - without gtk+-based gui (text only)
-# _without_python      - plain gtk-based version without python support
-# _without_gnome       - without gnome-based support
-# _without_libglade    - without libglade config
-# _without_xml         - without xml config
-# _without_gdk_pixbuf  - without gdk-pixbuf
+%bcond_without gtk             # without gtk+-based gui (text only)
+%bcond_without python          # plain gtk-based version without python support
+%bcond_without gnome           # without gnome-based support
+%bcond_without libglade        # without libglade config
+%bcond_without xml             # without xml config
+%bcond_without gdk_pixbuf      # without gdk-pixbuf
 #
 Summary:       Gaby is a small personal databases manager
-Summary(pl):   Gaby - ma³y osobisty zarz±dca baz danych
+Summary(pl.UTF-8):     Gaby - mały osobisty zarządca baz danych
 Name:          gaby
 Version:       2.0.2
 Release:       1
@@ -23,37 +23,37 @@ URL:                http://gaby.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-%{!?_without_gdk_pixbuf:BuildRequires: gdk-pixbuf-devel >= 0.7.0}
+%{?with_gdk_pixbuf:BuildRequires:      gdk-pixbuf-devel >= 0.7.0}
 BuildRequires: gettext-devel
-%{!?_without_gnome:BuildRequires:      gnome-libs-devel}
-%{!?_without_gui:BuildRequires:                gtk+-devel >= 1.2.5}
-%{!?_without_libglade:BuildRequires:   libglade-devel}
+%{?with_gnome:BuildRequires:   gnome-libs-devel}
+%{?with_gui:BuildRequires:             gtk+-devel >= 1.2.5}
+%{?with_libglade:BuildRequires:        libglade-devel}
 BuildRequires: libtool
-%{!?_without_libglade:BuildRequires:   libxml-devel}
-%{!?_without_xml:BuildRequires:                libxml-devel}
-%{!?_without_python:BuildRequires:     python-devel}
-%{!?_without_python:BuildRequires:     python-pygtk < 1.99}
+%{?with_libglade:BuildRequires:        libxml-devel}
+%{?with_xml:BuildRequires:             libxml-devel}
+%{?with_python:BuildRequires:  python-devel}
+%{?with_python:BuildRequires:  python-pygtk < 1.99}
 # python-pygtk and gtk+-devel require to be installed with the same prefix
 # to be visible; currently not this case :(
-%{!?_without_python:%{!?_without_gui:Requires: python-pygtk < 1.99}}
-%{!?_without_gui:Requires:     gtk+ >= 1.2.5}
-%{!?_without_python:Requires:  python}
+%{?with_python:%{?with_gui:Requires:   python-pygtk < 1.99}}
+%{?with_gui:Requires:  gtk+ >= 1.2.5}
+%{?with_python:Requires:       python}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Gaby is a small personal databases manager using GTK+ and Gnome (if
+Gaby is a small personal databases manager using GTK+ and GNOME (if
 available) for its GUI. It was designed to provide straight-forward
 access to databases a 'normal' user would like (addresses, books, ...)
 while keeping the ability to easily create databases for other needs.
 On a technical side it was designed with extensibility in mind and
 relies a lot on plug-ins.
 
-%description -l pl
-Gaby jest ma³ym osobistym zarz±dc± baz danych u¿ywaj±cym GTK+ i
-GNOME. Zosta³ zaprojektowany aby udostêpniæ prosty dostêp do baz
-danych, które "zwyk³y" u¿ytkownik chcia³by mieæ (adresy, ksi±¿ki...),
-pozwalaj±c ³atwo tworzyæ bazy do innych celów. Od technicznej strony
-zosta³ zaprojektowany tak, by byæ rozszerzalnym poprzez wtyczki.
+%description -l pl.UTF-8
+Gaby jest małym osobistym zarządcą baz danych używającym GTK+ i
+GNOME. Został zaprojektowany aby udostępnić prosty dostęp do baz
+danych, które "zwykły" użytkownik chciałby mieć (adresy, książki...),
+pozwalając łatwo tworzyć bazy do innych celów. Od technicznej strony
+został zaprojektowany tak, by być rozszerzalnym poprzez wtyczki.
 
 %prep
 %setup -q
@@ -70,12 +70,12 @@ zosta
 %{__automake}
 CPPFLAGS="`gdk-pixbuf-config --cflags` `libglade-config --cflags` `orbit-config --cflags client`"
 %configure \
-       %{?_without_gnome:--disable-gnome} \
-       %{?_without_python:--disable-python} \
-       %{?_without_gtk:--disable-gui} \
-       %{?_without_libglade:--without-libglade-config} \
-       %{?_without_xml:--without-xml-config} \
-       %{?_without_gdk_pixbuf:--disable-gdk_pixbuftest} \
+       %{!?with_gnome:--disable-gnome} \
+       %{!?with_python:--disable-python} \
+       %{!?with_gtk:--disable-gui} \
+       %{!?with_libglade:--without-libglade-config} \
+       %{!?with_xml:--without-xml-config} \
+       %{!?with_gdk_pixbuf:--disable-gdk_pixbuftest} \
 
 %{__make}
 
@@ -105,5 +105,5 @@ rm -rf $RPM_BUILD_ROOT
 %lang(de) %{_datadir}/gaby/gaby_tips_de.txt
 %lang(fi) %{_datadir}/gaby/gaby_tips_fi.txt
 %lang(fr) %{_datadir}/gaby/gaby_tips_fr.txt
-%lang(no) %{_datadir}/gaby/gaby_tips_no.txt
+%lang(nb) %{_datadir}/gaby/gaby_tips_no.txt
 %{_mandir}/man1/*
This page took 0.094656 seconds and 4 git commands to generate.