]> git.pld-linux.org Git - packages/gaby.git/blobdiff - gaby.spec
- mass commit: cosmetics (removed trailing white spaces)
[packages/gaby.git] / gaby.spec
index d39e62bba78bbf0c3a3f3951927a196073f08dcc..8a03d4d412a023a4d3fa11688a37cc3b1cd21172 100644 (file)
--- a/gaby.spec
+++ b/gaby.spec
@@ -1,17 +1,44 @@
+#
+# Conditional build:
+# _without_gtk         - without gtk+-based gui (text only)
+# _without_python      - plain gtk-based version without python support
+# _without_gnome       - without gnome-based support
+# _without_libglade    - without libglade config
+# _without_xml         - without xml config
+# _without_gdk_pixbuf  - without gdk-pixbuf
+#
 Summary:       Gaby is a small personal databases manager
+Summary(pl):   Gaby - ma³y osobisty zarz±dca baz danych
 Name:          gaby
-Version:       1.9.20
+Version:       2.0.2
 Release:       1
-Group:         X11/GNOME/Applications
-Group(pl):     X11/GNOME/Aplikacje
 License:       GPL
-Url:           http://gaby.netpedia.net
-Source0:       %{name}-%{version}.tar.gz
-Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Requires:      gtk+ >= 1.2.0
-
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
+Group:         X11/Applications
+Source0:       http://gaby.sourceforge.net/archives/%{name}-%{version}.tar.gz
+# Source0-md5: 1203f7a548e46bc0bf5987fb2e1508ee
+Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-gcc33.patch
+Patch2:                %{name}-doc.patch
+URL:           http://gaby.sourceforge.net/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: bison
+%{!?_without_gdk_pixbuf:BuildRequires: gdk-pixbuf-devel >= 0.7.0}
+BuildRequires: gettext-devel
+%{!?_without_gnome:BuildRequires:      gnome-libs-devel}
+%{!?_without_gui:BuildRequires:                gtk+-devel >= 1.2.5}
+%{!?_without_libglade:BuildRequires:   libglade-devel}
+BuildRequires: libtool
+%{!?_without_libglade:BuildRequires:   libxml-devel}
+%{!?_without_xml:BuildRequires:                libxml-devel}
+%{!?_without_python:BuildRequires:     python-devel}
+%{!?_without_python:BuildRequires:     python-pygtk < 1.99}
+# python-pygtk and gtk+-devel require to be installed with the same prefix
+# to be visible; currently not this case :(
+%{!?_without_python:%{!?_without_gui:Requires: python-pygtk < 1.99}}
+%{!?_without_gui:Requires:     gtk+ >= 1.2.5}
+%{!?_without_python:Requires:  python}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Gaby is a small personal databases manager using GTK+ and Gnome (if
@@ -21,46 +48,62 @@ while keeping the ability to easily create databases for other needs.
 On a technical side it was designed with extensibility in mind and
 relies a lot on plug-ins.
 
+%description -l pl
+Gaby jest ma³ym osobistym zarz±dc± baz danych u¿ywaj±cym GTK+ i
+GNOME. Zosta³ zaprojektowany aby udostêpniæ prosty dostêp do baz
+danych, które "zwyk³y" u¿ytkownik chcia³by mieæ (adresy, ksi±¿ki...),
+pozwalaj±c ³atwo tworzyæ bazy do innych celów. Od technicznej strony
+zosta³ zaprojektowany tak, by byæ rozszerzalnym poprzez wtyczki.
+
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir}
-make
+%{__gettextize}
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+CPPFLAGS="`gdk-pixbuf-config --cflags` `libglade-config --cflags` `orbit-config --cflags client`"
+%configure \
+       %{?_without_gnome:--disable-gnome} \
+       %{?_without_python:--disable-python} \
+       %{?_without_gtk:--disable-gui} \
+       %{?_without_libglade:--without-libglade-config} \
+       %{?_without_xml:--without-xml-config} \
+       %{?_without_gdk_pixbuf:--disable-gdk_pixbuftest} \
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} prefix=$RPM_BUILD_ROOT%{_prefix} install-strip
-for F in `find $RPM_BUILD_ROOT%{_prefix} -perm -111`
-do
-       strip $F || true
-done
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.a' -o -name '*.la' | xargs rm -f
+
+%find_lang %{name} --with-gnome
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS COPYING ChangeLog Gabyrc INSTALL NEWS README 
-%doc README.translations README.upgrading TODO TODO.more gaby.lsm 
-%doc doc/*.sgml doc/C/*.sgml 
-%%{_sysconfdir}/gaby
-%{_libdir}/gaby
-%{_datadir}/gaby
-%attr(755,root,root) %{_bindir}/gaby 
-%attr(755,root,root) %{_bindir}/gabyprint 
-%attr(755,root,root) %{_bindir}/gbc 
-%attr(755,root,root) %{_bindir}/gcd 
-%attr(755,root,root) %{_bindir}/videobase 
-%attr(755,root,root) %{_bindir}/gnomecard 
-%attr(755,root,root) %{_bindir}/builder
-%{_datadir}/locale/da/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/de/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/es/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/fi/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/fr/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/ja/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/nl/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/no/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/pl/LC_MESSAGES/gaby.mo
-%{_datadir}/locale/sv/LC_MESSAGES/gaby.mo
+%doc AUTHORS BUGS ChangeLog NEWS README* TODO* misc/Gabyrc
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/%{name}
+%{_sysconfdir}/gaby
+%dir %{_datadir}/gaby
+%{_datadir}/gaby/glade
+%{_datadir}/gaby/scripts
+%{_datadir}/gaby/gaby_tips.txt
+%lang(de) %{_datadir}/gaby/gaby_tips_de.txt
+%lang(fi) %{_datadir}/gaby/gaby_tips_fi.txt
+%lang(fr) %{_datadir}/gaby/gaby_tips_fr.txt
+%lang(no) %{_datadir}/gaby/gaby_tips_no.txt
+%{_mandir}/man1/*
This page took 0.24609 seconds and 4 git commands to generate.