]> git.pld-linux.org Git - packages/gaby.git/blobdiff - gaby.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/gaby.git] / gaby.spec
index 84cf6bbd4df63b6800da42051ff3e0ea5c17d022..1491fdf1ed580c773dcfa73fccdb28a167518c1f 100644 (file)
--- a/gaby.spec
+++ b/gaby.spec
@@ -1,50 +1,47 @@
 #
 # Conditional build:
-# _without_gtk         - without gtk+-based gui (text only)
-# _without_python      - plain gtk-based version without python support
-# _without_gnome       - without gnome-based support
-# _without_libglade    - without libglade config
-# _without_xml         - without xml config
-# _without_gdk_pixbuf  - without gdk-pixbuf
+%bcond_without gtk             # without gtk+-based gui (text only)
+%bcond_without python          # plain gtk-based version without python support
+%bcond_without gnome           # without gnome-based support
+%bcond_without libglade        # without libglade config
+%bcond_without xml             # without xml config
+%bcond_without gdk_pixbuf      # without gdk-pixbuf
 #
 Summary:       Gaby is a small personal databases manager
-Summary(pl):   Gaby - ma³y osobisty menad¿er baz danych
+Summary(pl):   Gaby - ma³y osobisty zarz±dca baz danych
 Name:          gaby
 Version:       2.0.2
 Release:       1
-Group:         X11/Applications
-Group(de):     X11/Applikationen
-Group(es):     X11/Aplicaciones
-Group(pl):     X11/Aplikacje
-Group(pt_BR):  X11/Aplicações
-Group(pt):     X11/Aplicações
 License:       GPL
-Url:           http://gaby.sourceforge.net/
+Group:         X11/Applications
 Source0:       http://gaby.sourceforge.net/archives/%{name}-%{version}.tar.gz
-Patch0:                gaby-DESTDIR.patch
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-BuildRequires: libtool
+# Source0-md5: 1203f7a548e46bc0bf5987fb2e1508ee
+Patch0:                %{name}-DESTDIR.patch
+Patch1:                %{name}-gcc33.patch
+Patch2:                %{name}-doc.patch
+URL:           http://gaby.sourceforge.net/
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: bison
-%{!?_without_gui:BuildRequires:                gtk+-devel >= 1.2.0}
-%{!?_without_python:BuildRequires:     python-devel}
-%{!?_without_gnome:BuildRequires:      gnome-libs-devel}
-%{!?_without_libglade:BuildRequires:   libglade-devel}
-# shouldn't this dependency be moved to libglade-devel ?
-%{!?_without_libglade:BuildRequires:   libxml-devel}
-%{!?_without_xml:BuildRequires:                libxml-devel}
-%{!?_without_gdk_pixbuf:BuildRequires: gdk-pixbuf-devel}
-%{!?_without_gui:Requires:     gtk+ >= 1.2.0}
-%{!?_without_python:Requires:  python}
-%{!?_without_gnome:Requires:   gnome-libs}
+%{?with_gdk_pixbuf:BuildRequires:      gdk-pixbuf-devel >= 0.7.0}
+BuildRequires: gettext-devel
+%{?with_gnome:BuildRequires:   gnome-libs-devel}
+%{?with_gui:BuildRequires:             gtk+-devel >= 1.2.5}
+%{?with_libglade:BuildRequires:        libglade-devel}
+BuildRequires: libtool
+%{?with_libglade:BuildRequires:        libxml-devel}
+%{?with_xml:BuildRequires:             libxml-devel}
+%{?with_python:BuildRequires:  python-devel}
+%{?with_python:BuildRequires:  python-pygtk < 1.99}
 # python-pygtk and gtk+-devel require to be installed with the same prefix
 # to be visible; currently not this case :(
-%{!?_without_python:%{!?_without_gui:Requires: python-pygtk}}
-
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
+%{?with_python:%{?with_gui:Requires:   python-pygtk < 1.99}}
+%{?with_gui:Requires:  gtk+ >= 1.2.5}
+%{?with_python:Requires:       python}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Gaby is a small personal databases manager using GTK+ and Gnome (if
+Gaby is a small personal databases manager using GTK+ and GNOME (if
 available) for its GUI. It was designed to provide straight-forward
 access to databases a 'normal' user would like (addresses, books, ...)
 while keeping the ability to easily create databases for other needs.
@@ -52,60 +49,61 @@ On a technical side it was designed with extensibility in mind and
 relies a lot on plug-ins.
 
 %description -l pl
-Gaby jest ma³ym osobistym menad¿erem baz danych u¿ywaj±cym GTK+ i
-GNOME. Zosta³ zaprojektowany aby dostarczyæ prosty dostêp do baz
+Gaby jest ma³ym osobistym zarz±dc± baz danych u¿ywaj±cym GTK+ i
+GNOME. Zosta³ zaprojektowany aby udostêpniæ prosty dostêp do baz
 danych, które "zwyk³y" u¿ytkownik chcia³by mieæ (adresy, ksi±¿ki...),
 pozwalaj±c ³atwo tworzyæ bazy do innych celów. Od technicznej strony
-zosta³ zaprojektowany tak, by byæ rozszerzalnym poprzez pluginy.
+zosta³ zaprojektowany tak, by byæ rozszerzalnym poprzez wtyczki.
 
 %prep
 %setup -q
-%patch0 -p0
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-CFLAGS="%{rpmcflags}" ./configure \
-       --prefix=%{_prefix} \
-       --sysconfdir=%{_sysconfdir} \
-       %{?_without_gnome:--disable-gnome} \
-       %{?_without_python:--disable-python} \
-       %{?_without_gtk:--disable-gui} \
-       %{?_without_libglade:--without-libglade-config} \
-       %{?_without_xml:--without-xml-config} \
-       %{?_without_gdk_pixbuf:--disable-gdk_pixbuftest} \
-       
+%{__gettextize}
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+CPPFLAGS="`gdk-pixbuf-config --cflags` `libglade-config --cflags` `orbit-config --cflags client`"
+%configure \
+       %{!?with_gnome:--disable-gnome} \
+       %{!?with_python:--disable-python} \
+       %{!?with_gtk:--disable-gui} \
+       %{!?with_libglade:--without-libglade-config} \
+       %{!?with_xml:--without-xml-config} \
+       %{!?with_gdk_pixbuf:--disable-gdk_pixbuftest} \
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} prefix=$RPM_BUILD_ROOT%{_prefix} install
 
-gzip -9nf AUTHORS BUGS ChangeLog NEWS README* TODO*
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.a' -o -name '*.la' | xargs rm -f
+
+%find_lang %{name} --with-gnome
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS.gz BUGS.gz ChangeLog.gz Gabyrc NEWS.gz README.gz
-%doc README.translations.gz README.upgrading.gz TODO.gz TODO.more.gz 
-%doc doc/*.sgml doc/C/*.sgml 
+%doc AUTHORS BUGS ChangeLog NEWS README* TODO* misc/Gabyrc
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/%{name}
 %{_sysconfdir}/gaby
-%{_libdir}/gaby
-%{_datadir}/gaby
-%attr(755,root,root) %{_bindir}/gaby 
-%attr(755,root,root) %{_bindir}/gabyprint 
-%attr(755,root,root) %{_bindir}/gbc 
-%attr(755,root,root) %{_bindir}/gcd 
-%attr(755,root,root) %{_bindir}/videobase 
-%attr(755,root,root) %{_bindir}/gnomecard 
-%attr(755,root,root) %{_bindir}/builder
-%lang(da) %{_datadir}/locale/da/LC_MESSAGES/gaby.mo
-%lang(de) %{_datadir}/locale/de/LC_MESSAGES/gaby.mo
-%lang(es) %{_datadir}/locale/es/LC_MESSAGES/gaby.mo
-%lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/gaby.mo
-%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/gaby.mo
-%lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/gaby.mo
-%lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/gaby.mo
-%lang(no) %{_datadir}/locale/no/LC_MESSAGES/gaby.mo
-%lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/gaby.mo
-%lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/gaby.mo
+%dir %{_datadir}/gaby
+%{_datadir}/gaby/glade
+%{_datadir}/gaby/scripts
+%{_datadir}/gaby/gaby_tips.txt
+%lang(de) %{_datadir}/gaby/gaby_tips_de.txt
+%lang(fi) %{_datadir}/gaby/gaby_tips_fi.txt
+%lang(fr) %{_datadir}/gaby/gaby_tips_fr.txt
+%lang(nb) %{_datadir}/gaby/gaby_tips_no.txt
+%{_mandir}/man1/*
This page took 0.113867 seconds and 4 git commands to generate.