]> git.pld-linux.org Git - packages/fz-api.git/blob - fz-api.spec
- disabled system libyuv because it removed Bayer support making it useless here
[packages/fz-api.git] / fz-api.spec
1 Summary:        FZ-API to access the Fotonic cameras
2 Summary(pl.UTF-8):      FZ-API pozwalające na dostęp do kamer Fotonic
3 Name:           fz-api
4 # see fz_api_src/fzapi.cpp /FZAPI_VERSION
5 Version:        4.1.2
6 %define verdate 20130925
7 Release:        0.%{verdate}.2
8 License:        LGPL v3+
9 Group:          Libraries
10 Source0:        http://www.fotonic.com/assets/documents/files/131002/fz-linux-api_x64_%{verdate}.tar.gz
11 # Source0-md5:  bd306ca31230cd632ca4060b5c26b98b
12 # there is also
13 #Source1:       http://www.fotonic.com/assets/documents/files/fz-linux-api_x86_20130322.tar.gz
14 ## Source1-md5: 05b3be93d3ba1644c53f5cca9f6029f9
15 # but it's older and both versions could be built from the same sources
16 Patch0:         %{name}-system-libyuv.patch
17 URL:            http://www.fotonic.com/content/Products/downloads.aspx
18 BuildRequires:  libstdc++-devel
19 #BuildRequires: libyuv-devel
20 BuildRequires:  sed >= 4.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 FZ-API to access the Fotonic cameras.
25
26 %description -l pl.UTF-8
27 FZ-API pozwalające na dostęp do kamer Fotonic.
28
29 %package devel
30 Summary:        Header files for FZ-API
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FZ-API
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for FZ-API.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki FZ-API.
40
41 %package static
42 Summary:        Static FZ-API library
43 Summary(pl.UTF-8):      Statyczna biblioteka FZ-API
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static FZ-API library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka FZ-API.
52
53 %package doc
54 Summary:        FZ-API documentation
55 Summary(pl.UTF-8):      Dokumentacja do FZ-API
56 Group:          Documentation
57
58 %description doc
59 FZ-API documentation.
60
61 %description doc -l pl.UTF-8
62 Dokumentacja do FZ-API.
63
64 %prep
65 %setup -q -c
66 # system libyuv removed Bayer support making it useless here
67 #%patch0 -p0
68
69 %build
70 %{__make} -C fz-linux-api_x64/fz_api_src \
71         CC="%{__cc}" \
72         CPP="%{__cxx}" \
73         COMPILERFLAGS="%{rpmcflags} -Wall" \
74         LDFLAGS="%{rpmldflags}" \
75         TARGET_ARCH= \
76         TARGET_OS=Linux
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
81
82 install fz-linux-api_x64/fz_api_src/libfz_api.so.1.0 $RPM_BUILD_ROOT%{_libdir}
83 ln -sf libfz_api.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libfz_api.so.1
84 ln -sf libfz_api.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libfz_api.so
85 cp -p fz-linux-api_x64/fz_api_src/libfz_api.a $RPM_BUILD_ROOT%{_libdir}
86 cp -p fz-linux-api_x64/include/*.h $RPM_BUILD_ROOT%{_includedir}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libfz_api.so.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libfz_api.so.1
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libfz_api.so
102 %{_includedir}/fz_api.h
103 %{_includedir}/fz_commands.h
104 %{_includedir}/fz_types.h
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libfz_api.a
109
110 %files doc
111 %defattr(644,root,root,755)
112 %doc fz-linux-api_x64/doc/*.pdf
This page took 0.063463 seconds and 3 git commands to generate.