]> git.pld-linux.org Git - packages/fwupdate.git/commitdiff
- added overflow patch (avoid implicit overflow warning by using explicit cast)
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 15 Nov 2016 15:26:40 +0000 (16:26 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 15 Nov 2016 15:26:40 +0000 (16:26 +0100)
fwupdate-overflow.patch [new file with mode: 0644]
fwupdate.spec

diff --git a/fwupdate-overflow.patch b/fwupdate-overflow.patch
new file mode 100644 (file)
index 0000000..060e1c1
--- /dev/null
@@ -0,0 +1,11 @@
+--- fwupdate-8/efi/fwupdate.c.orig     2016-11-15 16:24:00.862246035 +0100
++++ fwupdate-8/efi/fwupdate.c  2016-11-15 16:24:06.562245972 +0100
+@@ -44,7 +44,7 @@
+ #endif
+ #ifndef uintn_mult
+ #define uintn_mult(a, b, c) ({                                        \
+-              const UINTN _limit = ~0ULL;                     \
++              const UINTN _limit = (UINTN)~0ULL;              \
+               int _ret = 1;                                   \
+               if ((a) != 0 && (b) != 0) {                     \
+                       _ret = _limit / (a) < (b);              \
index 8a4be7f9da413e9328a64a82c580960a045e5148..d9c176dd3238351ff700ef636c66438ce9b53420 100644 (file)
@@ -11,6 +11,7 @@ License:      GPL v2
 Group:         Libraries
 Source0:       https://github.com/rhinstaller/fwupdate/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: b68e67b706ac5f551e8fcab20cf43a60
+Patch0:                %{name}-overflow.patch
 URL:           https://github.com/rhinstaller/fwupdate
 BuildRequires: efivar-devel >= 0.19
 BuildRequires: gnu-efi
@@ -72,6 +73,7 @@ Bashowe uzupełnianie parametrów polecenia fwupdate.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %if %{without pesign}
 %{__sed} -i -e 's/pesign/cp $< $@ \&\& : &/' efi/Makefile
This page took 0.071847 seconds and 4 git commands to generate.