]> git.pld-linux.org Git - packages/fwupd.git/commitdiff
- updated to 1.4.4 auto/th/fwupd-1.4.4-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 7 Jul 2020 15:05:19 +0000 (17:05 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 7 Jul 2020 15:05:19 +0000 (17:05 +0200)
- added qmi patch (fix build with libqmi 1.26+)

fwupd-bashcomp.patch
fwupd-qmi.patch [new file with mode: 0644]
fwupd.spec

index f938b59b9aff3962764d702a9ea66b8d237ba6ea..42f5626ff95be13b78621aec6cae3a730c8179dd 100644 (file)
@@ -5,19 +5,19 @@
  option('efi-includedir', type : 'string', value : '/usr/include/efi', description : 'path to the EFI header directory')
  option('efi_os_dir', type: 'string', description : 'the name of OS directory in ESP')
 +option('bash_completiondir', type : 'string', value : '')
---- fwupd-1.1.3/data/bash-completion/meson.build.orig  2018-10-17 17:20:45.844927437 +0200
-+++ fwupd-1.1.3/data/bash-completion/meson.build       2018-10-17 17:20:49.401594061 +0200
+--- fwupd-1.4.4/data/bash-completion/meson.build.orig  2020-07-06 21:50:32.951174519 +0200
++++ fwupd-1.4.4/data/bash-completion/meson.build       2020-07-06 22:18:15.335501944 +0200
 @@ -1,8 +1,12 @@
 -if bashcomp.found()
-+tgt = get_option('bash_completiondir')
++completions_dir = get_option('bash_completiondir')
 +
-+if tgt == '' and bashcomp.found()
-   tgt = bashcomp.get_pkgconfig_variable('completionsdir',
-                                          define_variable: [ 'prefix', prefix ],
++if completions_dir == '' and bashcomp.found()
+   completions_dir = bashcomp.get_pkgconfig_variable('completionsdir',
+     define_variable: bashcomp.version().version_compare('>= 2.10') ? ['datadir', datadir] : ['prefix', prefix],
    )
 +endif
  
-+if tgt != ''
++if completions_dir != ''
  
- if get_option('daemon')
-     install_data(['fwupdmgr'],
+ if get_option('agent')
+     install_data(['fwupdagent'],
diff --git a/fwupd-qmi.patch b/fwupd-qmi.patch
new file mode 100644 (file)
index 0000000..fe79c73
--- /dev/null
@@ -0,0 +1,44 @@
+--- fwupd-1.4.4/plugins/modem-manager/fu-qmi-pdc-updater.c.orig        2020-06-10 16:43:14.270352000 +0200
++++ fwupd-1.4.4/plugins/modem-manager/fu-qmi-pdc-updater.c     2020-07-07 06:24:20.714166201 +0200
+@@ -226,11 +226,13 @@
+       guint            token;
+ } WriteContext;
++#if (QMI_MAJOR_VERSION < 1) || ((QMI_MAJOR_VERSION == 1) && (QMI_MINOR_VERSION < 26))
+ #pragma clang diagnostic push
+ #pragma clang diagnostic ignored "-Wunused-function"
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcLoadConfigInput, qmi_message_pdc_load_config_input_unref)
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcLoadConfigOutput, qmi_message_pdc_load_config_output_unref)
+ #pragma clang diagnostic pop
++#endif
+ static void fu_qmi_pdc_updater_load_config (WriteContext *ctx);
+@@ -435,11 +437,13 @@
+       guint            token;
+ } ActivateContext;
++#if (QMI_MAJOR_VERSION < 1) || ((QMI_MAJOR_VERSION == 1) && (QMI_MINOR_VERSION < 26))
+ #pragma clang diagnostic push
+ #pragma clang diagnostic ignored "-Wunused-function"
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcActivateConfigInput, qmi_message_pdc_activate_config_input_unref)
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcActivateConfigOutput, qmi_message_pdc_activate_config_output_unref)
+ #pragma clang diagnostic pop
++#endif
+ static gboolean
+ fu_qmi_pdc_updater_activate_config_timeout (gpointer user_data)
+@@ -540,11 +544,13 @@
+                                       fu_qmi_pdc_updater_activate_config_ready, ctx);
+ }
++#if (QMI_MAJOR_VERSION < 1) || ((QMI_MAJOR_VERSION == 1) && (QMI_MINOR_VERSION < 26))
+ #pragma clang diagnostic push
+ #pragma clang diagnostic ignored "-Wunused-function"
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcSetSelectedConfigInput, qmi_message_pdc_set_selected_config_input_unref)
+ G_DEFINE_AUTOPTR_CLEANUP_FUNC(QmiMessagePdcSetSelectedConfigOutput, qmi_message_pdc_set_selected_config_output_unref)
+ #pragma clang diagnostic pop
++#endif
+ static gboolean
+ fu_qmi_pdc_updater_set_selected_config_timeout (gpointer user_data)
index f60f280d5d8cbb6ffbe9791806d8859fd4a6fd71..7be6b0e4bf4c9c76e36223b1abfb6c3560b32399 100644 (file)
 Summary:       System daemon for installing device firmware
 Summary(pl.UTF-8):     Demon systemowy do instalowania firmware'u urządzeń
 Name:          fwupd
-Version:       1.4.0
+Version:       1.4.4
 Release:       1
 License:       LGPL v2.1+
 Group:         Applications/System
 Source0:       https://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 53c57d2cde8179e25e91eaf82648d9aa
+# Source0-md5: b506e291f5baedc49ce4ace6569fc952
 Patch0:                %{name}-bashcomp.patch
 Patch1:                %{name}-flashrom.patch
+Patch2:                %{name}-qmi.patch
 URL:           https://github.com/hughsie/fwupd
 %{?with_modemmanager:BuildRequires:    ModemManager-devel >= 1.10.0}
 %{?with_cairo:BuildRequires:   cairo-devel}
@@ -186,6 +187,7 @@ API języka Vala do biblioteki fwupd.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %ifarch x32
 # -m64 is needed to build x64 EFI
This page took 0.122675 seconds and 4 git commands to generate.