]> git.pld-linux.org Git - packages/ftpd-BSD.git/blob - ftpd-BSD.spec
- fix wtmp handling
[packages/ftpd-BSD.git] / ftpd-BSD.spec
1 Summary:        OpenBSD's ftpd ported to Linux (with IPv6 support)
2 Name:           ftpd-BSD
3 Version:        0.3.2
4 Release:        4
5 License:        BSD-like
6 Group:          Networking/Daemons
7 Group(pl):      Sieciowe/Serwery
8 Source0:        ftp://quatramaran.ens.fr/pub/madore/ftpd-BSD/%{name}-%{version}.tar.gz
9 Source1:        %{name}.inetd
10 Source2:        %{name}.pamd
11 Source3:        %{name}-ftpusers
12 Patch0:         %{name}-anonuser.patch
13 Patch1:         %{name}-paths.patch
14 Buildrequires:  libwrap-devel
15 Buildrequires:  pam-devel
16 Requires:       rc-inetd
17 Requires:       inetdaemon
18 Provides:       ftpserver
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Obsoletes:      wu-ftpd
21 Obsoletes:      proftpd
22 Obsoletes:      heimdal-ftpd
23 Obsoletes:      linux-ftpd
24
25 %description
26 This is a Linux port of the BSD ftp server (ftpd). It doesn't have all
27 the bells and whistles of wu-ftpd, but it is also probably less buggy
28 and more secure (at least, it was certainly so before I ported it, and
29 I hope I didn't mess things up *too* much).
30
31 The source code was taken from the OpenBSD CVS as of 2000/01/23 (this
32 is between releases 2.6 and 2.7). The ftpd version number is 6.4 and
33 this port's version number is 0.3.0.
34
35 %description -l pl
36 Pakiet ten zawiera linuksowy port serwera ftp BSD (ftpd). Nie zawiera
37 on wszystkich wymy¶lnych elementów wu-ftpd, jest jednak
38 prawdopodobniej mniej zapluskwiony i bardziej bezpieczny (w kazdym
39 razie by³ takim zanim go przenios³em na Linuksa, i mam nadziejê, ¿e
40 nie naba³agani³em *za bardzo*). Kod ¼ród³owy pochodzi z repozytorium
41 CVS OpenBSD z dnia 2000/01/23 (tj. miêdzy wersj± 2.6 a 2.7). Numer
42 wersji ftpd to 6.4, za¶ numer wersji tego portu to 0.3.0.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 %{__make} -C ftpd OPT_CFLAGS="$RPM_OPT_FLAGS"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
55         $RPM_BUILD_ROOT%{_sysconfdir}/{ftpd,pam.d,sysconfig/rc-inetd} \
56         $RPM_BUILD_ROOT/home/ftp/{upload,pub}
57
58 install -s ftpd/ftpd $RPM_BUILD_ROOT%{_sbindir}/ftpd-BSD
59 install ftpd/ftpd.8 $RPM_BUILD_ROOT%{_mandir}/man8/
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/ftpd
61 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/ftp
62 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ftpd/ftpusers
63
64 gzip -9nf README $RPM_BUILD_ROOT%{_mandir}/man8/*
65
66 %post
67 if [ -f /var/lock/subsys/rc-inetd ]; then
68         /etc/rc.d/init.d/rc-inetd reload 1>&2
69 else
70         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
71 fi
72
73 %postun
74 if [ -f /var/lock/subsys/rc-inetd ]; then
75         /etc/rc.d/init.d/rc-inetd reload
76 fi
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.gz
84 %attr(755,root,root) %{_sbindir}/ftpd-BSD
85 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pam.d/ftp
86 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpd/ftpusers
87 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sysconfig/rc-inetd/ftpd
88 %dir /home/ftp 
89 %dir /home/ftp/pub 
90 %attr(755,ftp,ftp) %dir /home/ftp/upload
91 %{_mandir}/man8/*
This page took 0.030864 seconds and 3 git commands to generate.