]> git.pld-linux.org Git - packages/ftpcube.git/blob - ftpcube.spec
- extract icon using original source
[packages/ftpcube.git] / ftpcube.spec
1 Summary:        Multithreaded FTP client for X Window System
2 Summary(pl.UTF-8):      Wielowątkowy klient FTP dla systemu X Window
3 Name:           ftpcube
4 Version:        0.5.1
5 Release:        2
6 License:        Artistic for code, GPL v2 for icons
7 Group:          X11/Applications/Networking
8 Source0:        http://dl.sourceforge.net/ftpcube/%{name}-%{version}.tar.gz
9 # Source0-md5:  3eb93ae44fa552ec50a24b7882198dd1
10 Source1:        %{name}.desktop
11 URL:            http://ftpcube.sourceforge.net/
12 BuildRequires:  python
13 %pyrequires_eq  python-libs
14 BuildRequires:  python-wxPython
15 Requires:       python-wxPython
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 FtpCube is a multi-platform, graphical FTP client written in Python,
21 using the wxPython graphical tookit. FtpCube's interface is based on
22 LeechFTP by Jan Debis but its codebase has been developed from scratch
23 and includes functionality that surpasses the original LeechFTP.
24
25 FtpCube aims to provide a high quality user interface, as well as a
26 rich feature set. The FtpCube project was born out of my search to
27 find a good, capable Unix FTP client that offered an intuitive and
28 sexy UI. Plus, I liked the idea of having an FTP client written in
29 Python. So, voila FtpCube.
30
31 %description -l pl.UTF-8
32 FtpCube to wieloplatformowy, graficzny klient FTP napisany w Pythonie,
33 używający biblioteki graficznej wxPython. Interfejs FtpCube jest
34 oparty na LeechFTP Jana Debisa, ale kod został stworzony od początku i
35 zawiera funkcjonalność przewyższającą oryginał.
36
37 FtpCube ma zapewnić wysokiej jakości interfejs użytkownika, a także
38 bogaty zbiór możliwości. Projekt FtpCube narodził się z poszukiwań
39 dobrego, uniksowego klienta FTP o dużych możliwościach, oferującego
40 intuicyjny i seksowny interfejs. Autorowi spodobała się idea klienta
41 FTP napisanego w Pythonie. Tak więc, voila FtpCube.
42
43 %prep
44 %setup -q
45
46 %build
47 # Extracting program icon from .py
48 %{__python} -c "import libftpcube.icons.ftpcube; print libftpcube.icons.ftpcube.getData()" > %{name}.png
49 %{__python} setup.py build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
54 %{__python} setup.py install \
55         --optimize=2 \
56         --prefix=%{_prefix} \
57         --install-scripts=%{_bindir} \
58         --root=$RPM_BUILD_ROOT
59
60 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
61 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README CHANGELOG COPYING COPYING.ICONS
69 %attr(755,root,root) %{_bindir}/*
70 %{py_sitescriptdir}/libftpcube
71 %{_desktopdir}/*.desktop
72 %{_pixmapsdir}/*
This page took 0.063112 seconds and 4 git commands to generate.