]> git.pld-linux.org Git - packages/fsplib.git/blob - fsplib.spec
- -D_FILE_OFFSET_BITS=64 to be consistent with elinks on rpi
[packages/fsplib.git] / fsplib.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        fsp library
6 Summary(pl.UTF-8):      Biblioteka fsp
7 Name:           fsplib
8 Version:        0.11
9 Release:        2
10 License:        BSD-like (see COPYING)
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/fsp/%{name}-%{version}.tar.gz
13 # Source0-md5:  f2f4809159d331baada8135d3977563c
14 Patch0:         %{name}-scons.patch
15 URL:            http://fsp.sourceforge.net/fsplib.html
16 BuildRequires:  scons
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is C library which support talking with FSP server using FSP v2
21 protocol and provides POSIX-like file manipulation interface.
22
23 For more information about FSP protocol see
24 <http://fsp.sourceforge.net/>.
25
26 For library and API info see <http://fsp.sourceforge.net/fsplib.html>.
27
28 %description -l pl.UTF-8
29 To jest biblioteka napisana w C, która obsługuje "rozmowę" z serwerem
30 FSP przy użyciu wersji 2 protokołu i dostarcza interfejsu operacji na
31 plikach podobnego do POSIX.
32
33 Więcej informacji o protokole FSP można znaleźć na
34 <http://fsp.sourceforge.net/>.
35
36 Informacje o bibliotece i API znajdują się na
37 <http://fsp.sourceforge.net/fsplib.html>.
38
39 %package devel
40 Summary:        Header files for FSP library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FSP
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for FSP library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki FSP.
50
51 %package static
52 Summary:        Static FSP library
53 Summary(pl.UTF-8):      Statyczna biblioteka FSP
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static FSP library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka FSP.
62
63 %prep
64 %setup -q -c
65 %patch0 -p1
66
67 %build
68 %scons \
69         CCFLAGS="%{rpmcflags}" \
70         enable-shared=yes
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
75
76 # we know scons is great :/
77 install libfsplib.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}
78 ln -sf libfsplib.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libfsplib.so.0
79 ln -sf libfsplib.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libfsplib.so
80 cp -a libfsplib.a $RPM_BUILD_ROOT%{_libdir}
81 cp -a fsplib.h $RPM_BUILD_ROOT%{_includedir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog COPYING NEWS README TODO
92 %attr(755,root,root) %{_libdir}/libfsplib.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libfsplib.so.0
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libfsplib.so
98 %{_includedir}/fsplib.h
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libfsplib.a
104 %endif
This page took 0.07236 seconds and 3 git commands to generate.