]> git.pld-linux.org Git - packages/frox.git/blobdiff - frox.spec
- more s|/var/log/archiv|/var/log/archive|g
[packages/frox.git] / frox.spec
index 0dfeb55b3e8ffa7e4caa30ceb0e5c578cc56a5b5..9e2746a31527a8aab91776e77263bd51e0693f00 100644 (file)
--- a/frox.spec
+++ b/frox.spec
@@ -1,35 +1,35 @@
-
-%define                _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
-%define                _kernel24       %(echo %{_kernel_ver} | grep -qv '2\.4\.' ; echo $?)
-%if %{_kernel24}
-%define                _kernel_series  2.4
-%else
-%define                _kernel_series  2.2
-%endif
-
+# Conditional build:
+%bcond_without libiptc         # doesn't build with 2.2 kernel
+#
 Summary:       Transparent FTP proxy
-Summary(pl):   Przezroczyste proxy FTP
+Summary(pl.UTF-8):     Przezroczyste proxy FTP
 Name:          frox
-Version:       0.7.14
-Release:       1@%{_kernel_series}
+Version:       0.7.18
+Release:       3
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://frox.sourceforge.net/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 95ef94973e94ba2cfb33f1004c74190e
+# Source0-md5: d30c35b9820d706ff2f9a6ab3b501247
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Patch0:                %{name}-config.patch
 URL:           http://frox.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
-PreReq:                rc-scripts
-Requires(pre): /usr/bin/getgid
+BuildRequires: linux-libc-headers >= 7:2.6.12.0-12
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/groupmod
 Requires(pre): /usr/sbin/useradd
-Requires(postun):      /usr/sbin/userdel
-Requires(postun):      /usr/sbin/groupdel
-Requires(post,preun):  /sbin/chkconfig
+Requires(pre): /usr/sbin/usermod
+Requires:      rc-scripts
+Provides:      group(frox)
+Provides:      user(frox)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -37,10 +37,10 @@ Frox is transparent FTP proxy. It also has support for non-transparent
 connections, caching of anonymous ftp, and active --> passive
 conversion of data connections.
 
-%description -l pl
-Frox to przezroczyste proxy FTP, posiada równie¿ wsparcie do
-nieprzezroczystych po³±czeñ, buforowania anonimowego ftp, i konwersji
-po³±czeñ z aktywnych na pasywne.
+%description -l pl.UTF-8
+Frox to przezroczyste proxy FTP, posiada również wsparcie do
+nieprzezroczystych połączeń, buforowania anonimowego ftp, i konwersji
+połączeń z aktywnych na pasywne.
 
 %prep
 %setup -q
@@ -52,16 +52,16 @@ po
 %configure \
        --enable-http-cache \
        --enable-local-cache \
-       %{?_kernel24:--enable-libiptc} \
-       %{?!_kernel24:--disable-libiptc} \
+       --%{!?with_iptc:dis}%{?with_iptc:en}able-libiptc \
        --enable-transparent-data \
        --enable-configfile=%{_sysconfdir}/frox.conf
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_mandir}/man{5,8}} \
-       $RPM_BUILD_ROOT/var/lib/frox
+install -d $RPM_BUILD_ROOT{/var/lib/frox,%{_mandir}/man{5,8}} \
+       $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig,rc.d/init.d} \
+       $RPM_BUILD_ROOT/var/{log/{archive/frox,frox},cache/frox}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -72,47 +72,55 @@ install doc/frox.conf.man   $RPM_BUILD_ROOT%{_mandir}/man5/frox.5
 install %{SOURCE1}     $RPM_BUILD_ROOT/etc/rc.d/init.d/frox
 install %{SOURCE2}     $RPM_BUILD_ROOT/etc/sysconfig/frox
 
+cat >$RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/frox << EOF
+/var/log/frox/frox-log {
+       olddir /var/log/archive/frox
+       nocreate
+}
+EOF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-if [ ! -n "`getgid frox`" ]; then
-       /usr/sbin/groupadd -g 97 -r -f frox 1>&2 || :
+if [ "`/usr/bin/getgid frox`" = 97 ]; then
+       /usr/sbin/groupmod -g 103 frox
 fi
+%groupadd -g 103 frox
 
-if [ ! -n "`id -u frox 2>/dev/null`" ]; then
-       /usr/sbin/useradd -M -o -r -u 97 -s /bin/false \
-               -g frox -c "FROX ftp caching daemon" -d /var/cache/frox frox 1>&2 || :
+if [ -n "`id -u frox 2>/dev/null`" ] && [ "`/bin/id -u frox`" = 97 ]; then
+       /usr/sbin/usermod -u 103 frox
+       chown -R frox:frox /var/cache/frox ||:
+       chown -R root:frox /var/log/frox /var/log/archive/frox ||:
 fi
+%useradd -u 103 -s /bin/false -g frox -c "FROX ftp caching daemon" -d /var/cache/frox frox
 
 %post
 /sbin/chkconfig --add frox
-if [ -f /var/lock/subsys/frox ]; then
-       /etc/rc.d/init.d/frox restart >&2
-else
-       echo "Run \"/etc/rc.d/init.d/frox start\" to start frox daemons."
-fi
+%service frox restart "frox daemons"
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/frox ]; then
-               /etc/rc.d/init.d/frox stop >&2
-       fi
+       %service frox stop
        /sbin/chkconfig --del frox
 fi
 
 %postun
 if [ "$1" = "0" ]; then
-       /usr/sbin/userdel frox 2> /dev/null
-       /usr/sbin/groupdel frox 2> /dev/null
+       %userremove frox
+       %groupremove frox
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc/{FAQ,README.transdata,RELEASE,SECURITY,TODO}
+%doc doc/{ChangeLog,FAQ,README.transdata,RELEASE,SECURITY,TODO}
 %attr(754,root,root) /etc/rc.d/init.d/frox
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/frox
-%attr(640,root,frox) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/frox.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/frox
+%attr(640,root,frox) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frox.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/frox
 %attr(755,root,root) %{_sbindir}/frox
 %attr(770,root,frox) /var/lib/frox
+%attr(770,root,frox) /var/log/frox
+%attr(770,root,frox) /var/log/archive/frox
+%attr(770,frox,frox) /var/cache/frox
 %{_mandir}/man*/*
This page took 0.061451 seconds and 4 git commands to generate.